Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Scanner cannot be found? - Solved

16 Apr 2013   #1

W10 Pro desktop, W10 laptop, W10 laptop, W10 Pro tablet (all 64-bit)
Scanner cannot be found? - Solved

I have a Kodak All-In-One printer/scanner that I have been using with my 64-bit Win 7 Ultimate machine since I built it. About a month ago, I went to use the scanner portion of it by way of the Kodak software and kept getting a "communications error" that prevented me from scanning. The scanner was fine because I was able to go into MS Paint and invoke a scan from there. I finally solved the problem by opening the "Advanced" properties of the shortcut for the Kodak software and checking "Run As Administrator".

Last night I purchased a new Brother Laser printer and installed it. I could print fine but when I went to scan the software told me it could not find the printer. Diagnostics told me the scanner driver installation had failed and for me to uninstall and re-install the Brother software suite. I did that but still got the message that the printer could not be found. I remembered what I did to fix the Kodak printer last month so did the same with the Brother software and now I can scan from my PC.

Has anyone else encountered this? I've had a scanner attached to my Win 7 computers since Win 7 first came out and have never needed to do this until recently. What changed?

At any rate, if all of a sudden you aren't able to scan anymore, try setting the scanner software to "Run As Administrator".

My System SpecsSystem Spec
17 Apr 2013   #2

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

I bet that was a Windows 7 update that caused the problem. From your post it looks as if it would be difficult to determine exactly when this happened, what do you think?
My System SpecsSystem Spec
17 Apr 2013   #3

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

Yes I have. Pretty much the same symptoms. I never figured out the administrator solution. I reinstalled the (Epson) all in one.

The problem in diagnosing it was messed up because I broke my main rule: never make 2 changes to the PC at the same time.

On that day I installed a set of Windows updates, ran chkdsk, and I ran a hard drive diagnostic tool.
That scanner error came up and I thought the files had been corrupted. My first thought was a failing hard drive so I ran the chkdsk diagnostic. That came up with some file system errors and repaired them. Then all hell broke loose and the system really started acting up. I ran the Western Digital diagnostics and all was good. I solved it once and for all by restoring a disk image from before the incident. Very odd.

What never occurred to me until days after the incident were the Windows Updates. I wondered if one of them altered some files that affected the scanner. Way too late to figure out what or why though.
With no facts to go on I can't draw any conclusions, but maybe there are some good clues for you in my tale of woe.
My System SpecsSystem Spec

17 Apr 2013   #4

W10 Pro desktop, W10 laptop, W10 laptop, W10 Pro tablet (all 64-bit)

A Windows update makes sense in the case of the Kodak software, which was previously installed and working, but I don't understand the new installation of the Brother software since no Windows updates were applied between the time I installed the software and when I attempted to scan. I also find it odd that the error message doesn't mention security or permissions but just indicates that the scanner can't be found or can't be communicated with.
My System SpecsSystem Spec
17 Apr 2013   #5

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

I wonder if they were both trying to use the same version of Twain. That seems to me to be the only common factor as it was the scan part of the combo that was at fault!
My System SpecsSystem Spec
17 Apr 2013   #6

W10 Pro desktop, W10 laptop, W10 laptop, W10 Pro tablet (all 64-bit)

I don't think TWAIN was the issue because I was able to access the scanner via TWAIN using MS Paint and even from within MS Word (at least in the case of the Kodak, didn't try Paint or Word when I encountered the issue with the Brother).
My System SpecsSystem Spec

 Scanner cannot be found? - Solved

Thread Tools

Similar help and support threads
Thread Forum
"No DLL were found in the Waterfall procedure" Finally SOLVED.
I finally figured this one out. I've seen lots of mention of this on various forums, but never a solution. The error is usually associated with some kind of 3rd party media player that suddenly stops working for no apparent reason. The error is really annoying and apparently a huge pain to...
USB disc not found at boot but is found when restarted
Hello all, I've had this issue for quite some time now, it never really bothered me that much, but it is annoying, so I thought I'd give it a shot to see if anyone could help me out. I've got 2 external USB drives, one on 2 Gb and one on 4 Gb. the 2Gb drive is no issues at all. Works...
Hardware & Devices
installed software, but drivers for XP scanner cannot be found
Hi all, newbie here. I am attempting to install my older XP scanner on my new PC. But i am running into driver issues, which don't seem like normal issues you would encounter moving a peripheral from XP to Win7. This is what i did: First i tried it with the OEM software. After i download the...
operating system not found and no drivers were found eror
as usual I turned off my laptop and after a while a turned on again to use my laptop but it couldn't reach operating system and showed error : " OPERATING SYSTEM NOT FOUND" ! I tried all instructions to solve the problem and finally run by windows start up CD to re-install new windows. this...
Installation & Setup
Boot Hang Solved; separately Sleep Problem Solved
I want to share how I solved these problems to give back to the many posters I read here who helped me. First, the sleep problem. The second day after I installed Windows 7, the computer went to hybrid sleep (s3) overnight. When I moved the mouse the case light came on, the fans roared to life...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:38.
Twitter Facebook Google+