Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot access old HDD in usb case, "Invalid"

17 Apr 2013   #1

Windows 8 Pro x64
Cannot access old HDD in usb case, "Invalid"

Somehow (It might have been me), system files used for windows were unaccessible or corrupted so I would get a BSOD on boot and a screen telling me that my laptop couldn't boot. I had no backups of any sort because I didn't have any external drives that were large enough (>400GB). So I had to order a new larger and faster HDD (I have been meaning to for a while just never had this kind of motivation to). I got it today and have installed it and successfully reinstalled windows and some other programs and am typing this because I put my old HDD that was in my laptop, put it in a external USB enclosure and when I plug it in (both to this laptop and another desktop that I have running Windows 7 x64 it doesn't let me access the drive. It doesn't even appear in windows explorer even though the computers detect that it was plugged in and the hard drive is whirring and clicking. On my laptop in Disk management it recognizes that it is a Dynamic Disk but says invalid and doesn't give any info on it. Is there any way to fix it or just access the files so that I can get all of my data off without deleting the files first. I have recently found a 500GB external HDD that I can transfer the files to if I can access them.

Edit: I have solved it, I managed to find a program that works perfectly and have already copied all possibly needed files before I wipe the old hdd (Program is called Find and mount).

My System SpecsSystem Spec
18 Apr 2013   #2

Windows 7 Home Premium 32 bit

Hi Darkstar1756,

Welcome onboard.

I have heard that EaseUs Partition Manager can do it.
Free convert dynamic disk to basic disk without data loss under windows 2000/XP/Vista/7/8 and Server 2000/2003/2008 32 bit and 64 bit.

TestDisk can also be used to copy all files to another external Disk (as a matter of abundant caution) and rewrite the partition table to convert it to baslc. Data will not be lost but even if it is lost, one has already copied it to another drive.

One can also use Hexeditor to make a small change in the first sector to make it basic. Seems to have worked for many.
My System SpecsSystem Spec

 Cannot access old HDD in usb case, "Invalid"

Thread Tools

Similar help and support threads
Thread Forum
"Windows Cannot Access" my WD "My Book Live" NAS drives
New to the forum, hoping to find answers or new ideas to try... My Win7 OS computer has problems seeing my WD network drives most of the time. I'll say up front that my Macbook, my Windows XP laptops, all other computers of various types in my house see and access these drives just fine, but the...
Network & Sharing
"access denied" when using "assoc" and "ftype" from cmdline?
I tried to associate the file extension .txt to a new editor program with the well known cmdline programs ASSOC and FTYPE. No, assigning them through WinExplorer menu does not work. But this is another problem which should not discussed here. When I type now one of the following...
General Discussion
"User profile service failed the logon" special case access denied
Hello SevenForums! A friend of mine brought a Windows 7 Ultimate x86 laptop saying that he can't log in with his account. When he tries to log in it shows this message: "The User Profile Service failed the logon. User profile cannot be loaded." Now I've searched the internet and found a few...
General Discussion
"No Network Access" and "Limited Connection/Connectivity" ?
Hey, I am really hoping someone can help me solve this problem, it's driving me up the wall! When I started using my computer this morning everything was fine, and then "no network access" kept appearing, along with "limited connection/connectivity". I would troubleshoot the problem, but then at...
Network & Sharing
"Access is denied" - "Unable to display current owner"
Hi, I just tried to install the latest iTunes update, but keep getting an error when it tries to access the C:\Program Files\iPod folder. When I try to access the iPod folder directly through Windows Explorer, I get "Access is denied". The same happens when logged in with the system...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:51.
Twitter Facebook Google+