Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 3TB Seagate drive shows "negative" space?

03 May 2013   #1

Windows 7 Professional x64
3TB Seagate drive shows "negative" space?

Hey all,

I have a 3TB Seagate Barracuda drive which I use as a data (storage) drive. It's formatted NTFS, and I use the GPT partition scheme so that I can access the single large partition.

I had the drive attached via SATA to USB connector to a computer that went down suddenly a few days ago. When I tried to plug in the drive into a Windows computer, a very weird thing happened. The drive was there, but it wasn't quite recognized. Windows Explorer wouldn't load My Computer, and would just show a magnifying glass over the My Computer icon in the left sidebar.

However, when I entered Disk Management, the drive was shown normally, and had a drive letter assigned to it as well. Nothing abnormal there. While in DM, I was even able to right-click the drive and select "Open" and "Explore" which would open the drive's contents in a new Explorer window. So far, so good.

Here's where it gets really weird.

I opened the drive up in both AOMEI Partition Assistant Home Edition and MiniTool Partition Wizard Home Edition, and wouldn't you know it, the drive is shown with two partitions: one with 700 odd GB, and the rest of the drive as used space. The funny thing is, the space is shown with a negative sign (-) next to it! So for some reason, both programs saw the drive as having an incorrect amount of space, and showed a nonexistent program to boot!

I launched chkdsk on the drive, but after running for several hours, the drive was stuck after step 2, and got nowhere fast.

I looked around online, and I saw other people with similar problems. One suggestion was to resize the existing partition, or create a new one in Disk Management, and Windows will see the drive properly.

Well I decided to go ahead and try it in DM. Problem was, DM wouldn't let me shrink the partition, even though it saw it properly. It reported that the partition didn't have enough space.

This is where I made my big mistake.

I went into AOMEI and decided to resize the bogus partition - the 700GB partition, that is. After I did that, and performed a reboot, a couple of things happened. For starters, the drive no longer appeared in My Computer, as it didn't have a drive letter assigned to it. Second, the original (and correct size) 3TB partition was gone. Disk Management saw only the 700GB resized partition, and nothing else. I tried to assign a drive letter with DM, but it simply gave me an error that "The operation failed because the console needs to be refreshed." When I check the partition in my two programs, they report that the drive is either NTFS, or unallocated, or unformatted.

However, when I use MiniTool, if I use the recover partition tool, and select the existing partition, it does reveal the drive contents, exactly as they were before everything went haywire, down to the last filename and structure. I confirmed this with MiniTool Data Recovery (Trial Version).

What should I do now? Should I try to recover what I can with a data recovery program, and reformat the drive to repair the NTFS file system and partition scheme, which is all screwed up? And will it recognize the drive as a 3TB, and not just a 700GB drive? Are my files recoverable now, since I haven't reformatted anything yet?

It's a mystery to me!

My System SpecsSystem Spec
03 May 2013   #2

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

Most likely the file table (GPT) got corrupted due to the PC crashing. That means the data is all on the drive but the table that keeps track of it all got screwed up.

Quote   Quote: Originally Posted by Diogones View Post
Should I try to recover what I can with a data recovery program, and reformat the drive to repair the NTFS file system and partition scheme.
The first thing anyone should do before trying to fix things is backup the data.
Then wipe the drive (zero-out using PW or Diskpart) and afterward, using Disk Management, install it and initialize it as GPT, then create a new volume.

Quote   Quote: Originally Posted by Diogones View Post
And will it recognize the drive as a 3TB, and not just a 700GB drive?
If you do as above, yes

Quote   Quote: Originally Posted by Diogones View Post
Are my files recoverable now, since I haven't reformatted anything yet?
They should be. Try Recuva. It's free and and easy to use, and should do the job.

You could also (after recovering data!) try using Partition Wizard to "Rebuild the GPT". But that may not work now since you have already made other changes.
My System SpecsSystem Spec
03 May 2013   #3

Windows 7 Professional x64

Thanks so much for your prompt and helpful reply TVeblen! Thank you for taking the time to read my post!

I think you are absolutely correct: my first priority is to get whatever I need off of the drive. The good news is it is not that much - as I have almost everything on a redundant drive.

I didn't even think about using Partition Wizard's Rebuild GPT feature! I'll give it a shot, but as you said, now that the "fake" partition was resized, whether or not it will work is anyone's guess.

I will try your advice and post back my results. Things are looking good! :)
My System SpecsSystem Spec


 3TB Seagate drive shows "negative" space?

Thread Tools

Similar help and support threads
Thread Forum
"New" Installation to Seagate 250GB Drive Fails after Install Steps
I am currently trying to install Windows 7 64-Bit onto a "new" (refurbished) drive I got for a decent price online. I was forced to use YUMI and create a USB Boot Drive which was working great after my Windows 7 DVD kept giving me the following error: "device driver missing"... I booted into my...
Installation & Setup
HDD shows in "Device Manager" but not in "DiskPart"or" Disk Management
Hi Guys, any ideas how to access my external hard drive device manager can see it but it does not appear in disc management. I use this HDD perfectly in my car HDD player. But when I try to connect it to my Laptop, it does not show up in disk management. Please check the attached screen...
Hardware & Devices
New Seagate External Hard Drive Marked "Active"
Hello 7Forums Guru's. I've never used external media and am trying to decide on a partition scheme for data storage (ISO's, music, pictures about 100-150 gb) and to store weekly backups, system image etc) but before I even start on that end, should my external HDD (Seagate Backup Plus 1 TB) be set...
Hardware & Devices
Cant find "System Image" of 36 GB but its shows on "Manage Disc Space"
Dear Experts, I have created windows image on Drive F: but delete it after some time manually due to some space prob. But while backup shows about 40 GB only few GB space got free after deletion. When i try to again take the the backup using windows 7 backup & restore option, its still shows 35...
Backup and Restore
Seagate teases "game-changing" hard drive
Seagate teases "game-changing" drive, coming May 26 - TechSpot News The 150% increase on a HDD over current ones is interesting...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:44.
Twitter Facebook Google+