Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: SD Memory Card - This device cannot start (Code 10)

19 May 2013   #1
agentrozanova

Windows 7 Ultimate x86 SP1
 
 
SD Memory Card - This device cannot start (Code 10)

I have an SD card that I use in my phone, and it's saying that it's corrupt. When I put it in the computer it doesn't appear in "My Computer", and in Device Manager I get "This device cannot start (Code 10).
I have only found solutions for Windows XP computers, none for Windows 7.
If anyone can help me solve this problem and fix my SD card, it would be greatly appreciated.


My System SpecsSystem Spec
.
19 May 2013   #2
Dude

Windows 10 Pro X64
 
 

Does your device manager show any errors (Yellow Bangs)? Could be that card reader driver needs installed.

Drivers & Downloads | Dell US
My System SpecsSystem Spec
19 May 2013   #3
agentrozanova

Windows 7 Ultimate x86 SP1
 
 

Yes it does show a yellow triangle next to the device
My System SpecsSystem Spec
.

19 May 2013   #4
Dude

Windows 10 Pro X64
 
 

right click it and choose update driver software
My System SpecsSystem Spec
19 May 2013   #5
agentrozanova

Windows 7 Ultimate x86 SP1
 
 

I did and it says the driver software is up to date
My System SpecsSystem Spec
19 May 2013   #6
Dude

Windows 10 Pro X64
 
 

Try to disable it, then re enable it
My System SpecsSystem Spec
19 May 2013   #7
agentrozanova

Windows 7 Ultimate x86 SP1
 
 

I tried disabling it and enabling it again, and I tried uninstalling it and reinstalling it again, nothing changes
My System SpecsSystem Spec
19 May 2013   #8
Dude

Windows 10 Pro X64
 
 

Can you post a screenshot of it in device manager. Right click it, hit properties and choose the driver tab

Post screenshot


Also wanted to ask, did you try the driver from the link I gave earlier

SD Memory Card - This device cannot start (Code 10)-cardreader.png


My System SpecsSystem Spec
19 May 2013   #9
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

It may be due to the fact the phone uses an entirely different format? My w7 rig won't read the SD card from my Razr Maxx.
My System SpecsSystem Spec
19 May 2013   #10
agentrozanova

Windows 7 Ultimate x86 SP1
 
 

There's the SD in device manager and the driver tab in properties...


Attached Images
SD Memory Card - This device cannot start (Code 10)-sd.png SD Memory Card - This device cannot start (Code 10)-sd2.png 
My System SpecsSystem Spec
Reply

 SD Memory Card - This device cannot start (Code 10)




Thread Tools




Similar help and support threads
Thread Forum
Audio problem,Realtek AC97,Code 10,This device cannot start. (Code 10)
Basicaly the title explain it all,can find the driver for on board audio device. I just buy a second hand MBO.It is MSI Neo 4 H,MS-7125 Ver:3,Bios ver. V5.3 072106 Newly instaled Windovs 7 Ultima 64bits. Trayed few diferent drivers non of them works,so probably is audio device gone. Any...
Sound & Audio
This device cannot start. (Code 10)
Serious guru points if you can solve this one! Windows 7, UFDs and iPod Nano were working fine. Then I cloned the Windows 7 C drive using the Samsung Data Migration tool from an 840 Pro Series 2.5-Inch 256 GB SATA 6GB/s Solid State Drive MZ-7PD256BW to an 850 EVO 500GB 2.5-Inch SATA III Internal...
Drivers
This device cannot start. (Code 10)
I've got 2 Devices giving me the same problems. The only USB devices that do work are the mouse and keyboard. I do the same for both and get the same problems. A bit of background. Everythign was working perfectly, then I moved the computer downstairs, (in doing so unplugged all the usb devices),...
Hardware & Devices
No sound - This device cannot start. (Code 10)
Hello! Since I got Win7 my sound isn't working anymore. When I go to sound it says "no audio devices are installed". And when I go to the device manager it says "this device cannot start (code 10)" It says that the drivers are up to date when I search for them, but I still tried to install...
Sound & Audio
USB device detected won't start (code 10)
I've done a fresh install of W7 yesterday on my desktop PC and I want to use the virtual PC for some USB hardware that doesn't have any x64 drivers. I can choose the USB devices fine in the virtual machine, they are detected and XP starts the usual hardware install wizard. However one of my...
Virtualization


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:04.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App