Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Trying to update firmware on Crucial C300...

30 May 2013   #1

Windows 7 H.P
Trying to update firmware on Crucial C300...

Good Morning All,

I've posted to this site a few times, with excellent results and fantastic support from the members, thanks so much for all your help.

Here's a new one:

My Crucial C300 has firmware 001....needless to say I've been having some issues, BSOD's, etc...

So, I download all the updates, 1 > 2, 2 > 6, 6 > 7....and follow the Update Guide to the letter...

All is good and fine until I have to set my machine to IDE in order to install the update.
BIOS SATA controller says "AHCI or RAID" other options.
Cannot update the firmware. NO drive detected. Tried RAID, just in case. Nope.

I have a Dell XPS 9100, and have an ASUS U3S6 as well, but connected the SSD to the motherboard as the guide said to do....tried all the ports 0-3....nope.

I've set aside the time and patience to update the firmware to well as reconfigure some things with my system, 'housekeeping', if you will...

How do I get my machine into IDE mode? (And then back into AHCI when the updates are finished) Did I miss something in BIOS?

Thanks again.

My System SpecsSystem Spec
30 May 2013   #2

Windows 7 Home Premium 64bit

Just a note of caution, I would recommend doing a full system image before updating the firmware especially since you are having issues.
I am not advocating updating the BIOS on the Dell, but have you checked Dell's website and the associated release notes for any/all Bios upgrades?
My System SpecsSystem Spec
30 May 2013   #3

Windows 7 H.P

I plan to do a backup of the C: drive, as that is where the OS and some programs are. My plan is to ultimately have only the OS on the SSD, no other programs whatsoever. (Should have do this from the get go, but laziness set in over the last few years.)

I understand the firmware update will erase everything on the drive, but am looking forward to a clean install of the OS, and having nothing else on the drive.

--a secondary question: Can I simply copy the Program Files and Program Files (x86) folders to the other drive prior to the update, or are there other steps involved to accomplish this?

Thanks again for your help
My System SpecsSystem Spec

30 May 2013   #4

Windows 10 Pro/ Windows 10 Pro Insider

I would not advise moving system files and would also suggest leaving programs on the SSD. That's why you bought the SSD to get performance from programs as well as the OS. You can move user folders to the other drive or put them there and 'include in library'. Some other very large programs can be moved to the other drive if needed, but I would certainly keep my most used programs on the SSD. I have games and install them to another drive. I just create a folder, select custom install and change the default location to install to.

As far as the firmware update, do you have an option for 'legacy'? Yhat may work. I've never had a board without IDE as an option. Failing that, you will probably have to move the drive to another computer which does have an IDE option.
My System SpecsSystem Spec
30 May 2013   #5

Windows 7 H.P

Thanks for the reply. I think my problem is that I have tried to get the controller on IDE when the drive is connected to the U3S6. When my backup is done, I'll try connecting it to the MoBo and see if I can change it from AHCI to IDE.
My System SpecsSystem Spec

 Trying to update firmware on Crucial C300...

Thread Tools

Similar help and support threads
Thread Forum
Crucial M4 drive freezing after 000F firmware update
I've spent my whole day trying to figure out what is going on with this to no avail What I've Done: Installed Windows 7 ultimate 64-bit OS on Crucial M4 drive that was acting up and freezing Continued freezing after installing drivers, stable for 10-30mins then freeze, requires hard reset every...
BSOD Help and Support
SSD performance degradation, Crucial C300 vs. OCZ V3...
I have two systems with different SSD drives; the performance of both systems with Win7 64-bit is just fine, there are no issues. Just out of curiosity, I compared the AS SSD historical benchmarks performance to see, if there's any substantial performance degradation between the time frames the...
Performance & Maintenance
New crucial C300 SSD keeps crashing my laptop after sleep
Hello. This is becoming unbearable. My laptop keeps crashing after I have installed my new SSD (crucial c300, 64gb, fw 0006). It gives me a BSOD 90% of the time i wake the laptop from sleep. It works fine while im in windows. But as soon as i put it to sleep, its a gambling most of the...
BSOD Help and Support
Crucial c300 ssd + asus u3s6 sata 3 controller
Hello i have a problem with boot i bought recently one of the crucial c300 ssd's and since my motherboard doesnt support sata 3 i bought this card asus u3s6, the problem is i cant boot from ssd when i plug it on this card there is an option in bios in boot order for this card but nothing happens it...
Hardware & Devices
Crucial C300 and Asus U3S6 Problem.
After much effort I got my new Crucial C300 128GB drive to boot when connected to the Asus U3S6 card (and it's wicked fast). Problem is, if I have my SATA II Samsung F3 plugged in, the PC won't boot. I've tried the Samsung both in the U3S6 and on board. The C300 is definately first in the boot...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:49.
Twitter Facebook Google+