Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: New HDD disappearing from Windows 7

03 Jun 2013   #1
okami 11x

Win7 Pro - 64bit
New HDD disappearing from Windows 7

So, this is a nightmare.

On Friday, I purchased a Seagate 1TB HDD (link) and plugged it into my computer. It worked for about 15 minutes then completely disappeared from Windows. I originally thought it was my PSU since my computer was underpowered with a 400W PSU. I replaced it with a Corsair GS800 and still had this issue. I returned the HDD and got a replacement (same model). Still wouldn't stay in Windows. Today, I returned it and got a different Seagate model (link) and lo-and-behold, it still lasts only 15 minutes at max before disappearing from Windows 7.

I downloaded SeaTools to see what it said on each of the HDDs.
First: didn't even pass the Short Generic test
Second: passed the Short Generic but failed the Long Generic
Current: passed the Short Generic but failed the Long Generic

When the HDDs disappear from Windows, it cannot be found anywhere until I restart the computer. It's gone from Windows Explorer. It's gone from Device Manager. It's gone from the partition wizard.
  • I have used the SATA cables that came with the HDDs. (so a brand new one each time)
  • I have used multiple SATA 6.0Gbps ports (haven't tried a 3.0Gbps port yet).
  • This issue is present with both of my PSUs so I don't believe it has something to do with power.
  • I've looked on the MOBO and have not found any blown capacitors (a friend of mine suggested this).
  • I have not done anything with BIOS yet

My computer's hardware is as follows:
Windows 7 Pro 64bit
Intel i7-3770K Ivy 3.5GHz processor
Intel DZ77GAL-70K (visual BIOS)
Intel SSD 520 180GB [C drive]
Samsung HD501LJ 500GB HDD [D drive]
ST380811AS 80GB HDD [E drive]
WDC WD5000AADS-00S9B0 500GB HDD [F drive]
System Reserved 100 MB [G drive]
Corsair Vengence 16GB (4x4GB) RAM
Nvidia GTX 550ti 2GB Graphics Card

The 'faulty' HDDs are never initialized when I first plug them in. I initialize them and partition them to be my H drive.

I have one 3.0Gbps SATA port available but since these HDDs are 6.0Gbps, I didn't try it. I have tried both of my available 6.0Gbps ports and both have this issue. I believe I have a PCI SATA card if it'd be useful for troubleshooting.

Something of note:
I had two BSOD errors when I had the second HDD installed. One while playing DmC Devil May Cry and the other overnight so I didn't see when it happened. I can post those dump files if people want them.

I hope that this is something either faulty with Seagate HDDs or where I need to update a driver cuz replacing anything else is gonna be expensive.

My System SpecsSystem Spec
04 Jun 2013   #2

Windows 7 64-bit, Windows 8.1 64-bit, OSX El Capitan, Windows 10 (VMware)

Your Seagate HDDs have, quote:
Data Transfer Rate to/from Interface Up to 6 Gbps
What it means is that it is compatible with SATA 6 interface, but will not make the HDD to transfer at SATA 6 rate. Use the SATA 3 ports for HDDs, even SATA 3 max transfer rates are faster than the HDD's capabilities.

Is your SSD on the SATA 6 port, like the HDDs?

Check your BIOS version and update, if it is available.
My System SpecsSystem Spec
04 Jun 2013   #3
okami 11x

Win7 Pro - 64bit

Oh, thanks for the info :)

My SSD is on SATA 6. Two of the three other HDDs are on SATA 3 while one is on Sata 6 for some reason. The troublesome seagate is on Sata 6.

I'll give my BIOS a check right now.
My System SpecsSystem Spec

04 Jun 2013   #4
okami 11x

Win7 Pro - 64bit

I'll give a quick update.

I tried a BIOS update but it just sat there so I restarted.

I moved the Seagate to a Sata 3 and so far so good. I'm in the middle of a Long Generic test but it's going on longer than normal so that's a good sign. We'll see if it stays this way
My System SpecsSystem Spec
04 Jun 2013   #5
okami 11x

Win7 Pro - 64bit

OK it looks like that was the issue. Is that normal for Seagate drives to not like the Sata 6 ports?

It now passes:
  • Short Generic
  • Long Generic
  • SMART Check
  • Short Drive Self Test

So why does SATA 6 not work for these Seagates? Is this Seagate's fault? What if I want to add another HDD to my computer? Which kind will work in a Sata 6 (since that's all I have left now)?

In the pic, starting from bottom right and moving up then left one column (bottom) and move up et cetera: Blue and Grey are SATA6. Both blue are filled. Both grey are not. I tried using the grey ports for my Seagate HDDs

Attached Thumbnails
New HDD disappearing from Windows 7-bios_sata2.jpg  
My System SpecsSystem Spec
04 Jun 2013   #6

Windows 10 Education 64 bit

Keep in mind that a mechanical drive "spinner" will never come close to even SATA 3 speeds. It may state that it is SATA 6 interface compatible but it will never ever come close to SATA 6 speeds. It's overkill plugging a spinner drive into that interface and won't make it run faster. It sounds good from a marketing stand point and push comes to shove, if that's all you have available, it should work in a SATA 6 port. In real life you will run into the odd occasion where it just doesn't work correctly. It's hard to say why? Hardware? Driver? Or a combination of both? I don't know?
My System SpecsSystem Spec
05 Jun 2013   #7

Windows 7 64-bit, Windows 8.1 64-bit, OSX El Capitan, Windows 10 (VMware)

To my recollection the Intel Z77 chipset supports two SATA 6 ports, the two additional SATA 6 ports are provided by the Marvell chipset. You should check your manual for the color coding of these ports; the chances are that the blue ones are managed by the Z77 chipset, while the gray ones are handled by the Marvell chipset. You probably did, but have to ask; did you install the Marvell drivers?

Keep in mind that the Marvell chipset utilizes a single PCI lane (max 5 Gb/s) and its transfer rate does not support SATA 6 (6 Gb/s) transfer rate.

I use Seagate HDDs, all of them are one TBs, with two different systems and never had an issue with these drives. The Intel managed SATA 6 ports got the SSDs, while the Marvell managed SATA 6 ports have the eSATA drives and the internal HDDs/DVDs are connected to the SATA 3. Plugging in the HDD to the internal Marvell SATA 6 ports provides hot-plug capabilities, which I don't need.
My System SpecsSystem Spec

 New HDD disappearing from Windows 7

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 Gadgets keep disappearing
My desktop gadgets disappeared on startup a few weeks ago, I was able to get them back by turning off the gadgets 'Windows features' and then back on again. But every few days they disappear and I have to go through the 'Windows features' process again. Any ideas?
HDD's keeps disappearing Windows 7 Ultimate x32
Hello, I know this has been posted before but I have gone through every topic on this forum in hope for a solution to my problem. I'm listing below my computer's configuration followed by the problem. MotherBoard: Intel DH67BL Processor: Intel Core i7 2600k Sandy Bridge 3.40 GHz RAM: DD3 4GB...
Hardware & Devices
Windows 7 Cursor keeps disappearing
Cursor Cursor disappears on the right side of the screen, and am unable to turn right whilst playing games. Have changed graphics card but am still having a problem. Any suggestions please?
Graphic Cards
Windows disappearing to the side...
Hi, My step daughter (11 yo) just called and told me that her paint and ie windows keep disappearing to the right when she tries to open them. I'm not up to speed with W7 yet (still using XP and Vista) so I tried shutting off Aero Snap. This didn't help. the windows minimize to the taskbar,...
General Discussion
Disappearing windows?
I have an app, which for some reason, had the window disappear. I see the app icon in the taskbar, and when I hover over the icon, I can see what goes on in the window. I have sound coming from the app. I can see it when I do :orb:-tab. However, when I click on it, it won't show up. When I select...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:19.
Twitter Facebook Google+