Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB ports (3.0) no longer working after Windows 7 Re-Install.

19 Jun 2013   #11
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Intel USB3.0 eXtensible Host Controller



My System SpecsSystem Spec
.
19 Jun 2013   #12
Squshiest

Windows 7 Home Premium 64bit SP1
 
 

Unfortunately still nothing appears to have changed :P

I'm sorry this is so frustrating and I can't be of more use! Am I literally just running setup after downloading the driver package? Am I meant to delete/uninstall the current (broken?) drivers off of device manager first?
My System SpecsSystem Spec
19 Jun 2013   #13
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Those are the drivers that should fix missing drivers for your USB 3.0 . Might want to call Asus tech support . Did this laptop come preinstalled with Windows 8 ?
My System SpecsSystem Spec
.

19 Jun 2013   #14
Squshiest

Windows 7 Home Premium 64bit SP1
 
 

Are the drivers you have been sending me for Windows 8? I am running windows 7 lol sorry should probably made that more clear.

Yes it was pre installed when I purchased the laptop and they were working perfectly fine however after a clean install they appear to have stopped working.
My System SpecsSystem Spec
19 Jun 2013   #15
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

No the drivers are for Windows 7 32 and 64 bit . From Intel . They work on both
My System SpecsSystem Spec
19 Jun 2013   #16
Squshiest

Windows 7 Home Premium 64bit SP1
 
 

Oh right,

Yeah I am not really sure what to do at this point. It doesn't seem to be hardware related but installing the drivers doesn't seem to be having any effect. I may try to contact customer support anyways.
My System SpecsSystem Spec
19 Jun 2013   #17
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

See if installing the drivers this way will help

Driver Install - Device Manager

Note   Note
This is installing the driver using the .inf file
My System SpecsSystem Spec
19 Jun 2013   #18
Squshiest

Windows 7 Home Premium 64bit SP1
 
 

Hey there,

I tried this with all 3 and from my conclusion it appears that Windows thinks that correct drivers are installed
which is blocking the install of others.

When I try to update the drivers it says the ones installed are the most up to date, when I click to browse my computer for the files it comes up with a screen found below.

This is really annoying I'm just not sure what to do now!!


Attached Thumbnails
USB ports (3.0) no longer working after Windows 7 Re-Install.-search.png  
My System SpecsSystem Spec
19 Jun 2013   #19
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

My System SpecsSystem Spec
19 Jun 2013   #20
Squshiest

Windows 7 Home Premium 64bit SP1
 
 
Success!

Hey there!

Just tried the last post and it seems to have done the trick!!

Thank you very much for the help you have provided, been very useful and very prompt! Sorry it took a few tries to work it out and I couldn't reply quickly sometimes.

Anyways yeah, cheers! Great not to have to use the crappy trackpad all the time.

Is there a way I can add to your rep or something?

Squshiest
My System SpecsSystem Spec
Reply

 USB ports (3.0) no longer working after Windows 7 Re-Install.




Thread Tools




Similar help and support threads
Thread Forum
USB ports no longer working
I have a Toshiba Satellite laptop which has an ELAN touchpad. Since I detest touchpads, I've always used a mouse instead. Today, my mouse stopped working. I checked the batteries, they're good; even changed the batteries. The mouse won't work. So, I plugged in a wired mouse that I know works. ...
Hardware & Devices
USB ports not working on clean install of windows 7. How to fix?
asus rog g751jy-vs71(wx) "one drive, dual boot" windows 10 Home Premium 64bit, and 7 Pro 64bit In W7, When Booting the USB works fine and I have a mouse, but when it gets to the login screen the keyboard and mouse just go black and do not function at all in W7. W10 works fine all the time. I...
Hardware & Devices
USB Ports Stop Working After USB Controller Install
I have a custom built computer running Windows 7 Pro x64. The keyboard and mouse work currently, but nothing else works when plugged into the USB (have 3.1, 3.0, and 2.0) ports. Seems like a simple driver issue. There are two different usb host controllers from what everything tells me. One is...
Drivers
After new motherboard install - usb ports - dvd drive; ect not working
I am an absolute newby at this , so my apologies in advance, if I did stupid things - I google and do what people had found to work in the past. FYI: got all the drivers from the Acer website and installed them - there is no exclamation marks in device manager, all drivers installed and working...
Drivers
USB ports no longer working
I do apologize if I'm not in the right section and I have already searched through the forums as well up and down looking for a fix but so far nothing has worked, so it started last night when I noticed just my keyboard in a certain USB port wouldn't work after trying other ports and reset I...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App