Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to add printer in Windows 7 Embedded x32

11 Jul 2013   #1

Windows 7 x64 Pro
Unable to add printer in Windows 7 Embedded x32


First post, so if I'm in the wrong place. Feel free to scold me :-)


I have a Win7 Embedded (x32) device at work and it needs to be able to print to somewhere. The printer in question is defined on our printserver like every other printer.
Normally when I add a printer I open the printserver's network location and doubleclick the printQ. However, on this PC that did nothing.

So I tried to add the printer the long way. Start --> Devices and printers --> Add printer. The entire devices and printers menu is missing. I tried opening it via Start, via Control panel, via cmd (control /name Microsoft.DevicesAndPrinters), ... Nothing works.

I'm getting a sneaking supsicion that printer support is not installed here. Is it possible to activate this "Feature" somehow?

Thanks in advance!

My System SpecsSystem Spec
17 Jul 2013   #2

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Hello Fraeco mate one query is this company yours or not if it is someone else's who you work for and you are not the IT tech then I'd leave well alone.

But I suppose you would not be remiss for trying another cable perhaps and sometimes just shutting down the printer and rebooting the computer works and you surely couldn't get into strife for that.
My System SpecsSystem Spec

 Unable to add printer in Windows 7 Embedded x32

Thread Tools

Similar help and support threads
Thread Forum
Unable to install printer drivers, uninstall old printer, update Windo
My Mom has an HP laptop. She recently purchased a new HP printer and I have been trying for the last 4 days to get it to install/connect. I've been in touch with HP but the links they provide aren't resolving the issues. First, using the CD that came with the printer: hangs up at around 85-90%....
Hardware & Devices
Unable to setup share printer in Windows 7
I have two windows 7 computers. computer-A is connecting EPSON printer and I have enabled the file and printer sharing function. The file sharing function is working fine. Then I tried to add the printer in control panel on computer-B, it sees the epson printer but when I try to install the...
Network & Sharing
Unable to map printer to LPT1
Hi, My office use DOS application and shared printer. I login as administrator, use "net use" command to lpt1 and it always prompt for user and password, every time I type user password, it always failed and has an error like this: I tried to map to another port like LPT2 or LPT3, it...
Hardware & Devices
Printer unable to communicate with PC
Hi. I'm having problems with my printer (Dell V105 ) because every-time I try to print something I get the following: 'Printer unable to communicate with PC.' I have downloaded the latest driver software from the Dell website which seemed to install properly but the problem remains. Any...
Hardware & Devices
Unable to share printer!
Short Version: When trying to enable printer sharing on Win7Ultimate PC, receive "Printer settings could not be saved. Operation coupld not be completed (error 0x000006cc)." when I click the apply button after checking the "Share this printer" tab. Printer works fine locally otherwise. Long...
Network & Sharing
Unable to print in WIndows xp printer.
Hello! Please be informed that I have 1 Desktop running Windows xp and one laptop running Windows 7 Ultimate at home. Files and printer sharing is enabled in both the system and I am able to share files and folders. Desktop is connected with a Lexmark X 4270 printer with USB cable and the...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:28.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App