Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB Flash Drive showing up as "Local Disk" in Windows 7

29 Jul 2013   #1

Windows 7 Professional 64bit
USB Flash Drive showing up as "Local Disk" in Windows 7


So I have a 64GB USB Flash Drive (Centon DataStick Sport). I had not used the drive in several months until the other day when I plugged it into my computer and it asked me to reformat it. I don't know why it asked me to reformat it, but it might have been due to water damage (I had carried it in my backpack and water may have hit it. I'm not quite sure).

I reformatted the drive using NTFS file system and everything is fine aside from one thing; when I plug it in, it shows up as a "Local Drive" under "Hard Drives" like my WD 1TB drive does. I would think that it should show up under 'Devices with removable storage" but it does not.

Does anyone know why this is?


My System SpecsSystem Spec
30 Jul 2013   #2

windows 7 home 64bit

Hi SlashEmUp Welcome to Seven Forums .. Right click on the Usb Drive propertys/hardware uninstall the Driver . Then unplug the Flash Drive .. Re-Install .. See if that works
My System SpecsSystem Spec
30 Jul 2013   #3

Win 7 Pro 64-bit 7601

I would run a full disk check (both options checked) to see if it is damaged (in the report look for "damaged sectors", if it is higher than 0 then you have problems). Asking to be formatted could mean it is damaged.

If plugged in another PC still acts the same (or if what maxie says does not work), you might have managed to "flip the removable bit" by accident (that's the jargon, don't look at me that way).
Windows asks to the device if it is removable. What the device answers depends from a "bit", a number in its controller's programming. This can be changed with tools or by accident.

If the device answers that it's "not removable", windows 7 will treat it as an hard disk. If it's the case, you will be able to multi-partition it and all partitions will be detected. Removable devices can only have one partition for windows 7, any further partition is not detected.

Either way, it's not a major issue if the disk check says it's fine.
My System SpecsSystem Spec

30 Jul 2013   #4

Windows 7 Professional 64bit

First off, thanks to both of you for the timely response.

Following what you both said, I ran the disk check and attempted to uninstall the drivers. Disk Check showed no errors and everything was good. I also plugged it into my laptop and it also shows up as a Local Disk.

Interestingly enough, when I went into Properties and then Driver, the option to uninstall the driver was greyed out and the only option was to view the Driver Details (see this pic: 93d8b7f9be12ce238819a1fb032572fb.png).

So, it seems to me that I may have switch the removable bit by accident and now Windows is treating it as a hard drive. In any case, it's not too big of a deal since it's working but I'd prefer it to be under "Devices with Removable Storage"
My System SpecsSystem Spec
30 Jul 2013   #5

Windows 7 Professional x64

seems to be a "common issue" these days. here is another discussion about this same issue. it could be a corrupt USBstor.sys file (Driver) See the other thread here
My System SpecsSystem Spec
30 Jul 2013   #6

Windows 7 Professional x64

Britton just reminded me about a recent article from SanDisk with might make more sense about this issue. I have a feeling Many manufactures are going to be following suit. Thank you Britton for the heads up.
See sandisk article here
My System SpecsSystem Spec
30 Jul 2013   #7
Microsoft MVP

Windows 7 Ultimate X64 SP1

Thank you Herb, here's the link to the SanDisk explanation.
Flash Drive shows as Hard Disk Drive (Fixed Disk) in Windows Explorer
My System SpecsSystem Spec
02 Dec 2013   #8

Windows 7 Pro x64

So I've seen why the problem exists, but has anybody found a solution for this?

The HP recovery software, on their laptops, running windows 8 will allow you to create a restore partition on a flash drive, but it will only do it if the drive is recognized as removable storage. As long as it's marked local disk it won't recognize the drive as a valid type of media.

Don't want to shell out the money for another flash drive that I'll have to research to make sure it will work with the software, and I haven't been able to find a compatibility list on HP's site yet.

Any ideas?
My System SpecsSystem Spec
02 Dec 2013   #9
Microsoft MVP

Windows 7 Ultimate X64 SP1

Welcome to Seven Forums Trakeen.

No solution has been found. The newer USB flash sticks if certified for Win 8 will appear as a fixed disk, another way MS tells us what we want. My drive was a SanDisk, the op's a Centon and I don't know if other makers have followed like lemmings or not.

First I'd recommend against using a flash drive for a recovery they can be unreliable and be corrupted easily. I would use a USB hard drive (HDD) in an enclosure. I have a 500GB and 750GB ones I used in this way.

Secondly if the HP software creates a factory recovery it will back up all the included HP bloatware, if not it may copy over temp files and the page file which isn't needed for a recovery and can increase the recovery size a lot.

I use this Imaging with free Macrium and it is very reliable making the image fairly small while retaining the entire OS, program, settings, drivers, etc.
My System SpecsSystem Spec
16 Sep 2015   #10

windows 7

I am having the same problem centon 64gig stick told me I had to format it gets to about 98% and says it cannot be done now the stick is not recognized when I plug it in the LED light stays lit and does not blink what do I do I tried uninstalling driver and reinstalling and nothing still
My System SpecsSystem Spec

 USB Flash Drive showing up as "Local Disk" in Windows 7

Thread Tools

Similar help and support threads
Thread Forum
"System Reserved (C:)" and "Local Disk (D:)" ??
Newbie here. I have searched around for a while but have not found a post with my exact situation. I just installed a new Seagate Momentus 500gb (7200rpm) SATA drive in my Lenovo X61 laptop and have been working on a installation of Windows7 Ultimate. Not realizing this was an upgrade...
Installation & Setup
Removable Flash Drive Recognized as a Local Disk and not a Flash Drive
I recently purchased a 32 GB San Disk Flash Drive. The security files pre-installed on the drive were junk, and I could not delete them so I formatted the drive to remove them. This cleaned the disk, and it holds data, but I'm not sure if this is part of my problem. I am trying to load my copy of...
Hardware & Devices
usb flash drive - "Disk is write protected"
My Sandisk 32GB USB Flash Drive doesn't allow deleting of files nor Formatting. The message reads "Disk is write protected". Since all it holds now is 'old stuff' its useless. Can we restore so it can be used again?
Hardware & Devices
"Local Disk" folder in Music Library
If I go to the music library, then Sample Music, which has 3 sample files, it also has a folder named local disk. Its empty, but right clicking and viewing properties shows it has 3 files and 4 folders, and is 400 bytes in size. It was created during the OSs install date, and is shared. ...
General Discussion
Flash stick showing as "Local Disk"
I just got a new 16GB SanDisk Extreme USB 3.0 flash drive that says Local disk instead of Removable Disk, which all the other USB flash drives do. I did uninstall its driver, replugged and it still shows as Local Disk.
Hardware & Devices
Flash Drive USB error "Not Accessible" and "Needs to be Formatted"
So after my Period 4 class ended, I headed off to my spare class to work on some assignments on the Mac. My Flash Drive worked perfectly fine in, and before Period 4, then in Period 5 it wasn't working. On the Mac, during my Period 5, it said "Disk not accessible" with three options. I then tried...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App