Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Drive name limited to 11 characters

02 Aug 2013   #11

XP Pro (x86) | 7 HP (x86) & (x64) | 7 Pro (x64)

Open up an Elevated Command Prompt. Click on in type CMD . Right click on CMD under Programs (1) choose . On the User Access Control window click on the Yes button . Command Prompt opens up to C:\Windows\System32>_
Just tried your process but my Win7 32bit does not have the features quoted
I tried your steps in both "Classic Start" UI and default Win7 UI
Click on "Start"
Run:= CMD ... opens command prompt ... C:\Users\Owner>
Search:= CMD ... opens command prompt ... C:\windows\system32>
1: No "Run as Administrator" on RClick context menu
2: No "Programs (1)" to select
3: No User Access Control window
4: No "Yes" button
Should I just log-in as administrator to carry out the conversion, and bypass 1: thru 4: ?
The only way I can get C:\windows\system32> is via "Search"
Would the cmd string be ...
C:\windows\system32>Convert X: /FS:NTFS
... OR ... should there be a space as in ...
C:\windows\system32> Convert X: /FS:NTFS
Thank you for your patience

My System SpecsSystem Spec
02 Aug 2013   #12

Win 7 Pro 64-bit 7601

Did you disable the User Account Control perhaps? (that's the screen dimming and popup when you are running administrator stuff asking password or a yes/no)

If it's disabled you can't run stuff as an admin unless you are logged in with an admin account. Log as an admin and follow the same procedure, if there is no "run as admin" even in the admin account you can bypass 1 through 4 and assume that you have full privileges anyway.

When you open a CMD as admin it's set to C:\windows\system32> by default (that text is already there).

No space is required before the text you write.

Remember to write the drive letter of your usb thumbdrive instead of the X: or it will think it has to work on drive X: (that on most systems does not exist) and will return an error.
My System SpecsSystem Spec
02 Aug 2013   #13

Windows 7 Pro 64 bit

Note that with NTFS remote drives you MUST use the Safe Removal Icon in the notification area. Otherwise you risk data loss.

Also be aware that flash drives are the least reliable of modern storage media and cannot be used for primary storage of important files. They should be used primarily as a transport media.
My System SpecsSystem Spec

15 Sep 2013   #14

XP Pro (x86) | 7 HP (x86) & (x64) | 7 Pro (x64)

My apologies for this belated thank you

bobafetthotmail +1
My post #11 ... after re-reading your directions and risking the process on a spare thumb drive....
... I got carried away with Enter key after I typed "cmd" in the "Search" edit box.
I failed to notice the list of search results as a result of Search:= cmd. ...

Right-Clicked on "cmd.exe" (ie, programs(1) list item
There after ... it all fell into place as you instructed.
LMiller7 +1
Safe Removal:
After years of sometimes difficult/sticky storage devices (and once I lost some data) for two years I have used the commercial version of "USB Safely Remove". It tells me where the problem is rather than Windows bland "device cannot be removed". Progress bar "shows" me something is happening.
My employees and significant other love it. Happy campers are happy workers.
(With Windows safe removal I could never tell if Windows was doing anything or Uncle Bill had nodded off.)

Thumb Drives:
Thank you for the advice. I have been using a thumb drive with 4,388 txt files of code snippets + info.
(Fifteen years of accumulated VBA/VBScript/formulas/etc stuff)
Have now moved all those txt files onto an external pocket HDD.
Not as quick as the thumb drive but now more secure.
Thank you. ++1
One trick I learnt after reformatting an external storage device (to clear all data) ...
ie, WinExp > Drive-letter > RClick > Format ...
Remove the USB device after reformatting then reconnect to populate the device with any data.
Else Windows does not allow safely-remove.
I don't know if the same applies to "FileSystem" change
My System SpecsSystem Spec
15 Sep 2013   #15

XP Pro (x86) | 7 HP (x86) & (x64) | 7 Pro (x64)

How I did it! With homage to "bobafetthotmail "

Note   Note
- modifies storage device's File System
- converting FAT32 to NTFS
- does not affect (nor delete) data files
Start > Search:= cmd
- on list of search results
cmd.exe > RClick
"Run as Administrator" ... LClick
User Account Control (UAC) ... alert
[Yes] ... Click
- Command prompt screen opens with ...
- then type Convert x: /FS:NTFS ... where "x" = drive device to be changed
ie, one line example: C:\Windows\System32>_Convert f: /FS:NTFS
(where "f" is the target drive)
[Enter] key
My System SpecsSystem Spec

 Drive name limited to 11 characters

Thread Tools

Similar help and support threads
Thread Forum
rename hard drive with 11 characters - consequences?
Hi I am suddenly getting a message from my pro tools iLok that I need to have fewer than 11 characters in my drive name in order to avoid corrupting the iLok security; if I do this, changing 'local drive (C:)' to, say, Ldrive(C:), will this mess up any of my program and file assignments? ...
Hardware & Devices
Virus on flash drive, unknown characters
Hello! My friend plugged in her USB Flash Drive on a computer shop this week. After plugging in, she got a couple of viruses. She let me take a look at it. I scanned the Flash Drive with my AV and I found couple of viruses. But when I opened the USB, I found something strange. The file names (as...
System Security
Clicking from disc drive when installing NFS Shift 2 (Limited Edition)
I have been trying to install Need for Speed: Shift 2 Unleashed (Limited Edition) on my laptop, HP Envy 17 1050EA, but I have been having no luck at all. After starting the installation, all I get is that the installation wizard is stuck on "Copying new files", and the disc drive is clicking. Now...
Hardware & Devices
FAT32 Flash drive can store files with more than 8.3 characters?
For some reason, FAT32 flash drive can store files with more than 8.3 characters? I thought FAT formatted drives can only have files with names that are no longer than 8.3 characters?
Hardware & Devices
Foreign Characters/Characters appearing.
Hi there. This is an odd problem, whenever certain characters are used ("^ are just some) then a letter is pressed foreign characters appear. I.E When I press " Then O it comes up as , instead of "O, and so on. Does anyone have any ideas, on how this could be fixed. I've checked in the...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:55.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App