Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Fat32 not recognised

30 Aug 2013   #1

Windows 7 Enterprise 32bit
Fat32 not recognised

I have been using win 7 enterprise for a while now with my fat32 usb stick and the other day it came up asking for it to be formatted, thinking that it was faulty i asked it to format it again to fat32 and it fails. I can format to NTFS but not fat32.

I used HP's disk format tool and still the same thing, I used gparted to format it again to fat32 which succeeded but when plugged into win 7 it shows the message asking me to format it.

I have deleted the usb drivers and such using a tool recommended on another website (USBOblivion) and restarted and still nothing. Ive searched around and found nothing that looks the same type of issue.

Ive tried multiple usb sticks and none work but all work on another standard build win7 machines in our organisation.

Any ideas?



My System SpecsSystem Spec
30 Aug 2013   #2

Windows 7 Home Premium 32 bit

Hi Chapman81, Welcome to SevenForums

What antivirus software are you running on the PC?

I have seen atleast one report that says after an AVG version update, windows stopped recognising FAT32 drives. Uninstalling AVG resolved the problem. Interesting. Isn't it?

"About 1 month ago windows stopped recognising fat 32 drives and said that the drive needed formatting ( most notable with usb and sd cards ).
I went through every possibility i could think of.
I noticed that AVG anti virus had updated to a new version and that it would not connect to its own server for virus updates.
I deleted AVG and hay presto windows recognised fat 32
I re installed AVG and the problem returned


Microsoft now do a very good security suite that is free (MSE)"

-post dated 14 Aug 2013
My System SpecsSystem Spec
30 Aug 2013   #3

Windows 7 Enterprise 32bit

No sorry we use FEP. It's not an av problem. They all have standard builds with the same apps.
My System SpecsSystem Spec

30 Aug 2013   #4

Windows 7 Home Premium 32 bit

Quote   Quote: Originally Posted by chapmana81 View Post
...... They all have standard builds with the same apps.
Just curious. And all of them ( with Windows Enterprise) "suddenly" started rejecting FAT32 almost at the same time or is it just one of them??????

While I am not proposing any solution - I simply do not know what is in your kitty :), the idea one could get from the above user experience - which he had double checked by reinstalling AVG- is that it need not necessarily be an antivirus update, it could be any other updates, installation of a new program, program updates etc.,

Now, if you do not want to investigate on this line or you are so confident that nothing ever changed in your system, it is upto you.

It is my firm belief that something has changed in your that one system or all systems depending upon it is just one or all..

You may wait to see whether others have any idea why this problem has arisen.

EDIT: If it is not your personal computer but belongs to an organisation - as it appears to be now -and the network is managed by a System Administrator, any problems arising in their usage in all propriety should be taken up with the System Administrator.
My System SpecsSystem Spec
30 Aug 2013   #5

Windows 7 Enterprise 32bit

No only one machine rejects it. The others show all the USB drives I've tested fine. Just this one doesn't recognise FAT32 partitions.

Also I am desktop support and I'm trying to resolve an issue so I am an admin. Plus all machines Re centrally managed and have the same updates and software.
My System SpecsSystem Spec
30 Aug 2013   #6

Windows 7 Home Premium 32 bit

OK, when you say it is just this one system, then the focus shifts to the drivers (software) and hardware.

You may reinstall the chipset drivers or reclone this system with the common template.That should set right any driver corruption notably that of the hard disk controller.

If that does not resolve the problem then there is a hardware problem. You may swap the motherboards and check. The controller chip may be faulty.

Just my thoughts purely analytical. :)
My System SpecsSystem Spec

 Fat32 not recognised

Thread Tools

Similar help and support threads
Thread Forum
USB Error FAT32
Good day I need help If I plugin any USB whatever NTFS or any file type it getting converted by itself to FAT32 like disabled mode and I have no permission to access , Error Massage “H: is not accessible. Access denied”:cry: I tried to change registry permission not thing working, tried...
Hardware & Devices
Win7 cannot recognised my FAT32 harddisk?
Dear sir, I've just got a new computer and the OS is Win7 professional 64but version. And I got 2 old hard disk and both of them are SATA, Western Digital, 250GB harddisk. Now, I would like to backup my data to my new computer, however, when I connect them, one of them can be recognised under...
Hardware & Devices
USB hd and FAT32 format
I connected a new Intenso 2,5" Memorystation 320 GB USB drive and struggled somewhat to get W7 Pro 64-bit to recognize it. Eventually it did and I copied about 20 GB of folders as back up. All fine but every now and then, while copying, I see a pop-up "Are you sure you want to copy this file...
Hardware & Devices
Ok so i need my drive for a backup now and then and download torrents of movies and tv shows do u think i should leave the drive as ntfs or format to fat32?
General Discussion
Fat32 from Windows7 ?
i need to format in fat32 from windows7, so that it can be readable in older systems. what s the settings do i need?
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:53.
Twitter Facebook Google+