Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Logitech MX mouse "Stalls" (?) at startup...

24 Sep 2013   #1

Windows 7 Ultimate x64
Logitech MX mouse "Stalls" (?) at startup...

This problem has been happening now for about a week or two. I've tried to trace down what started it with no luck.

When I boot the PC the mouse won't move for about 30 seconds, then it works fine. I've noticed that it seems to happen after or as the USB drives come online.

This also happends when I wake the PC from sleep mode.

As I said before, this just began about a week or so ago.

If anyone has any ideas please let me know as this is driving me a bit mad.

Intel i7-3930k
ASRock Extreme 11 MB
PNY Quadro 4000 Video
64bg Ram
480bg Mushkin SSD
…misc other secondary and external HDs

My System SpecsSystem Spec
24 Sep 2013   #2

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

drtao mate if you haven't already try downloading the USB drivers I found this list but have no idea which it is cos your specs just say AsRock Extreme and the site is pretty ordinary but have a look.

If you have a branded mouse then maybe you need to update th drive for it too.

Download Files form ASRock Inc. > Latest Drivers Update
My System SpecsSystem Spec
25 Sep 2013   #3

Windows 7 Ultimate x64

Mine is a Extreme11 and it's not on the list.
My System SpecsSystem Spec

26 Sep 2013   #4

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Quote   Quote: Originally Posted by drtao View Post
Mine is a Extreme11 and it's not on the list.
Yes I have just had a look around and I guess like most it comes with its own software.

Just on the off chance maybe it is worth running these
will not take long and at least it eliminates the OS.
My System SpecsSystem Spec
26 Sep 2013   #5

windows 7 home 64bit

Hi there ... Updating your USB Drivers as already stated might well help .. In order to do this you need the exact Model Number of your Motherboard ... Go to Start type in start in the search box write in CMD right click on it and Run as Adim when the prompt open type the following ... wmic baseboard get product,Manufacturer,version ..
My System SpecsSystem Spec
27 Sep 2013   #6

Windows 7 Ultimate x64

I've reinstalled the drivers on the website for my mb. Still having the problem.
My System SpecsSystem Spec
29 Sep 2013   #7

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

AS Maxie says drtao we need the motherboard number mate now try running Speccy and open out the motherboard ref and send a screen shot of the readout.
Speccy - Download < from piriform the alternative is to physically look at the board with a strong light and find the model number.

Looking back on your first post you say when the USB's come on line well I could be mistaken but they should be on line the instant the board (machine ) boots.

Now the boot process is thus you power on > the PSU tests itself for correct volts > it then send a signal (via pin 8 - grey lead on the 24 pin plug) to the start up chip on the board all that takes place in microseconds so if the PSU is not functioning properly the board will not come on line. So if the USB's are not coming online straight away suggests t me there maybe something wrong with the power supply?

Attached Images
Logitech MX mouse &quot;Stalls&quot; (?) at startup...-mobo.png 
My System SpecsSystem Spec
29 Sep 2013   #8

Microsoft Community Contributor Award Recipient

Windows 7 Ultimate 64

Exactly which MX mouse do you have? Maybe try this:,4,5/cl/us,en
My System SpecsSystem Spec

 Logitech MX mouse "Stalls" (?) at startup...

Thread Tools

Similar help and support threads
Thread Forum
Win7 Pro stalls during "Expanding Files" or won't restart
OK, I've looked at a lot of info on these excellent forums, and don't really know where to start. I get as far as Step 2 "Expanding files" using the OEM DVD, then install just stops or wants me to press any key to boot from CD drive. Am I better off trying an ISO install instead of the OEM DVD?...
Installation & Setup
Win7 pro startup error "Boot MGR missing"/"Operating System Not Found
I just upgraded from Vista Home Premium to Win7 professional x64 hoping to fix the above mentioned problem. After a complete re-install Im getting the same errors. Im not sure of the proper terminology here, but during startup the computer does a scan of all hardware and "Volume 0" has a...
Installation & Setup
Windows Update on 7 stalls while "Installing Updates (2/3)" on AMD64 m
Hello All, This is yet another issue with Windows Update on 7; I recently (a couple of weeks or so ago) upgraded my father's computer to Windows 7 and he loves it. However, whenever either of us try and use Windows Update, it sits there for hours and hours on "Installing Updates 1 of 2." ...
Windows Updates & Activation
Windows 7 ultimate stalls, "Applying Security Policy"
Just a month ago i bought a new rig, (besides the disks) All have worked fine until just some days ago, was in a game when it freezes and reboots, hmmpfs ok.. Started up again, but since that time the whole system have become unstable, till now when i just boot up all seems fine and just after a...
BSOD Help and Support
fresh install, stalls right after "windows starting" screen. mbr?
Hello, all. I'm flirting with my sanity and have decided to finally reach out for help. I have been googling and searching these forums for the better part of 26 hours, yielding little in the way of results. I'm also browsing/typing with my cell phone; you might imagine nerve endings.... ...
Installation & Setup
Installation stalls at "Setup is starting"
I am having a problem with the installation of Win7 on my laptop, currently running Vista. I have tried a Clean install from both a DVD and a Bootable Flash drive, both sit at "setup is starting" any suggestions? Setup went fine on my desktop machine that was running XP Thanks
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:23.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App