Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Canon 8400F - "Unable to open Twain Source" error message

08 Nov 2013   #1
Al Bud

Windows 7 Professional
Canon 8400F - "Unable to open Twain Source" error message

This looks to be a tricky one. I have two PC's running windows 7 Pro with SP2. One can detect and run Canon Toolbox for scanning, the other does not. When running it states error "Unable to open Twain Source". I have not been able to identify the reason why the windows 7 installation runs differently. I have re-installed the windows 7 (upgrade/repair) on the PC that does not work.

I have read forums that recommend adding a system variable to the path. This does not work. I have tried to compare paths, setting, etc between the machines yet they are the same (at least so far).

Windows scanner and camera properties (c:\program files\windows photo viewer) shows the scanner (Canon 8400F). I ran diagnostics and scanner executes successfully. I select scan profiles and it states "No scanner detected". This is puzzling.

I worked with Canon to delete driver, and re-install (after reboot of course). Re-installed Canon tool box 4.9, the driver is for the windows 7 64 bit. Those seem to install correctly. There seems to be some issue with windows 7 as it seems to see a scanner until you run and then it cannot detect it.

It has puzzled Canon, nothing in the forum so far has a solution and I am puzzled as I have spnet many hours on this. Yet it works on one machine but not the other. I have been un-installing several applications but nothing seems to be in conflict. The driver is shown as installed and ok in device manager.

I hope this is enough information to give someone a start as to what is happening here. I am fairly knowledgable with PC's but this one stumps me. Probably something simple but finding it appears difficult.

My System SpecsSystem Spec
24 Sep 2014   #2

Windows 7 64 bit
Twain problem with Canon 8400f

I can fully relate to the problem of installing the train driver for the Canon 8400f scanner. I suddenly found my scanner not working and spent hours trying every idea I could find on the Internet without success. I tried loading and using the scanner on an old XP computer and it worked fine so I knew the scanner wasn't the problem.

I decided my problem somehow involved Windows 7 software. I downloaded and installed all of the upgrades from Microsoft, including over 40 optional ones, and after this the scanner worked fine. I've no idea which of the many upgrades solved the problem as I didn't install them one at a time..

Judging by posts on the Internet many have had or have this problem so perhaps my solution may be of help to others.
My System SpecsSystem Spec

 Canon 8400F - "Unable to open Twain Source" error message

Thread Tools

Similar help and support threads
Thread Forum
Can't copy or move files - error message "open in other program"
When moving or renaming files I frequently get an error messages informing me that "The action can't be completed because the folder or a file in it is open in another program". This typically happens with the second or third folder I try to rename or move. Navigating away to another folder and...
General Discussion
Error message of "Setup was unable to create a new system partition"
Let me start off my saying I've installed this exact copy of windows 7 before on this computer with no problems and it worked for years. I'm trying to install Windows 7 ultimate 64 bit version when I run into this message "Setup was unable to create a new system partition or locate an existing...
Installation & Setup
"Unable to find a volume for file extraction" Error Message
I am trying to install a C++ Redistributable package and am encountering the following error dialog: I am also encountering a similar dialog when I try to install the latest Silverlight plugin for IE9. I'm running...
General Discussion
"Application was unable to start properly (0xc0150004)" error message
Any quick help would be greatly appreciated. I was trying to fix some BSOD's and windows update issues on a friend's pc. I thought i was successful until i kept getting "Setup has detected that .NET Framework 4 needs to be repaired. Do not restart your computer until the repair is complete." ...
Error Message Displayed When Tyring To Open "msconfig"
I was looking at an article on, trying to optimize whatever i could since my computer has been stalling at start-up. I disabled a few "start-up" programs and one or two other things that are listed int he article here: Optimize Your Windows 7 PC - PCWorld Now every time I try attempt...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:36.
Twitter Facebook Google+