Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External USB3.0 drive is missing at startup

28 Nov 2013   #1
racrwannbe

Windows 7 Home Premium 64bit
 
 
External USB3.0 drive is missing at startup

Hello Windows 7 forum,

My computer does not detect my external hard drive when I turn the computer on. Once it's on, if I unplug the drive and then plug it back in again, it detects it and I can use it normally. However once I shutdown or restart the computer, the drive is once again missing.

This just started happening, I believe since I installed the latest Intel USB 3 drivers. I've tried rolling back to the original driver from my motherboard's homepage, but that hasn't helped.

At startup, I can see in the device manager that the USB Mass Storage Device was unable to start (screenshot attached) but I have no idea why.

Your help is greatly appreciated! Happy Thanksgiving!




Attached Thumbnails
External USB3.0 drive is missing at startup-usb_screenshot.png  
My System SpecsSystem Spec
.
29 Nov 2013   #2
archer

Windows 7 ultimate x64
 
 

Hi, Welcome to Sevenforums.

I think this is an issue with Win 7. I also read a forum with this same issue.

Here is the link for your reference.
My System SpecsSystem Spec
30 Nov 2013   #3
racrwannbe

Windows 7 Home Premium 64bit
 
 

Thank you for your reply. Alas, the method listed in the other link didn't resolve my issue. I ran through the entire procedure just fine, and when I plug the external drive into either USB3 port, it works. But as soon as I restart the computer, the drive is still goes missing (same code 10 error), and I have to un-plug and re-plug into the USB3 port for it to reappear. Interesting enough, if I leave the drive plugged into a USB2 port, the computer remembers the drive after I restart.
My System SpecsSystem Spec
.

30 Nov 2013   #4
racrwannbe

Windows 7 Home Premium 64bit
 
 

I'm starting to think the problem is with the drive itself. I tried a different external drive in both USB 3 ports and the computer has no issue seeing that one on startup. I'll be checking the Seagate forums now. Thank you.
My System SpecsSystem Spec
30 Nov 2013   #5
Golden
Microsoft MVP

Windows 7 Ult. x64
 
 

Unfortunately, it can be a common problem:
The mysterious case of the dissapearing USB3 external drives ...
My System SpecsSystem Spec
30 Nov 2013   #6
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Quote   Quote: Originally Posted by Golden View Post
Unfortunately, it can be a common problem:
The mysterious case of the dissapearing USB3 external drives ...
Did you ever resolve your case ??
My System SpecsSystem Spec
01 Dec 2013   #7
Golden
Microsoft MVP

Windows 7 Ult. x64
 
 

No Wolfgang,I never managed to solve it.
My System SpecsSystem Spec
01 Dec 2013   #8
archer

Windows 7 ultimate x64
 
 

Link given in my post above says that this issue is common with win 7 and 8.
My System SpecsSystem Spec
01 Dec 2013   #9
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Quote   Quote: Originally Posted by Golden View Post
No Wolfgang,I never managed to solve it.
That's too bad. The issue seems to be relatively common and mysterious.
My System SpecsSystem Spec
01 Dec 2013   #10
Golden
Microsoft MVP

Windows 7 Ult. x64
 
 

This is where Microsoft has let us down very badly.....no native USB3.0 drivers on W7
. Something I have ranted about before.
My System SpecsSystem Spec
Reply

 External USB3.0 drive is missing at startup




Thread Tools




Similar help and support threads
Thread Forum
ORICO 2.5 inch USB3.0 External Hard Drive Enclosure (2578U3)not seen
Hi I have a Toshiba Satellite L650 Laptop, I have just upgraded from Win7 32 to Win764, the external hard drive (as shown in the thread title) that I used when using Win7 32 is now not seen in Explorer or Disk management, the light is coming on so I guess there is power to the drive, there...
Drivers
External Hard Drive missing
So I went to look at my last backup and saw that my external backup drive is no longer listed with "my computer" drives. I've tried a number of things, but cannot get that fixed. It lights up and I can hear it running inside when put up to my ear. It a G Tech slim 500GB. I have an HP Pavilion...
Hardware & Devices
USB3 External Drive Ejects in Sleep Mode
As per title. Hitachi Touro 4TB USB3 external drive ejects during sleep mode and often is not acessable or listed in My Computer. It is however listed in the attached SATA drives in the Notification Area and is listed in Devices and Printers. When this happens the PC hangs during a restart. I...
Hardware & Devices
Previously functional USB3 external hard drive shows not initialized
Have a 1TB Iomega USB3 external hard drive that worked well on both a desktop and laptop Win7/64 system. Now it shows up as unidentified and not initialized using computer/manage/storage/disk management. Disk Management also gives the optiin to initialize it but I declined because I would like to...
Hardware & Devices
Saving a disk image to an external USB3 drive?
I have an external 500GB USB3 drive. I need to install USB3 drivers from my motherboard disk before Windows will see the drive. Will this drive work during a restore? Is it better to create a disk image and save it on an internal SATA HDD instead?
Backup and Restore


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App