Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Iomega Ext HDD 1Tb [2 x 500Gb] Format Help

01 Dec 2013   #1

Win 7 H Premium
Iomega Ext HDD 1Tb [2 x 500Gb] Format Help

I have an Iomega 1Tb made up with 2 disks inside Enclosure
Model MDHD10T-UE s/n JPAH 36A354
I need some Help to Format it and get it Stable please
Houses mostly Video & Music
Worked reliably for 3 years
Then I kept getting messages “Check Disk for errors” OR Continue without scanning”
I tried Scan and Fix a couple of times – couldn’t do it
So I continued without scanning but after 10, 20 or 30 minutes the Drive would disconnect/disappear
It would not reappear until I logged of and then back on again
I borrowed a 2 Tb from a friend and s l o w l y managed to copy everything Off
I first tried Formating in Windows – no good
Found Formater on Iomega/Leveno Site and used it
Followed their instructions to Format to NTFS
Copied 400 Gb – all ok
Then I went for a 224 Gb Cut & Paste
At the End, Everything was Gibberish – The Drive Name, the Directory Names etc
Thinking that I had perhaps caused some sort of problem by converting to NTFS,
I used the Iomega Utility and Formated the HDD again
[I did notice at the Bottom it said “Formatted as separate drives”]
I thought it strange, but when I went into Windows, there it was, as approx 1Tb
I copied 2 Folders, about 350 Gb – all OK
Then I Cut and Paste a 224 Gb File
It showed some problems with some Source Files – too many, so I cancelled the Paste Operation
After that The Drive Name reverted to just “F” Disk in Explorer
Showing No Files on it
I ran Checkdisk from inside Windows to Fix File Errors
Green Line went across within a minute but the program appeared to be still Running,
Processor showed 60% activity to I left it for about 4 hours
Now, when I plug it in, I get “Disk needs Formating”
HELP Please
It has 2 Disks and it seems to go wrong after the Halfway Mark
Which seems as though it needs some sort of Software to make the 2 work together [There was only one Drive letter before and Disk Management did show it as one 1Tb Disk and Healthy AFTER a Reformat
Any Help appreciated, I have to give the Borrowed Hdd Back asap
And it takes ages copying
And in Disk Management
RAW 931.52 Gb [Act Prim Part]
Personally, I think it has something to do with the message in Iomega Formatter “Formatted as Separate Drives” –as above
I don’t know
Regards and Thanks for any Help

My System SpecsSystem Spec
01 Dec 2013   #2

Microsoft Windows 7 Home Premium 64-bit 7600

i had an iomega break on me,
if i was experiencing these issues on a drive i had used for 3 years or more then i would be looking to replace it fast.
i recently bought a 4T seagate drive which wasnt that expensive considering the size.
My System SpecsSystem Spec
01 Dec 2013   #3

Windows 7 Home Premium 32 bit

Is it known as Iomega Stor Center?

If so have you installed the Discovery Tool?

If so :) have you tried reconfiguring your drive ab-initio?

I just had a cursory look at the user manual and there is provision in the software to reset it to factory defaults.

And especially in the Disk Management, you can verify the Status, Repair, Format etc.,

I don't own any IOmega, but from what I have seen above, I think you must go through the user manual and do all the necessary things like checking the status, repairing and formatting it from within that software.
My System SpecsSystem Spec


 Iomega Ext HDD 1Tb [2 x 500Gb] Format Help

Thread Tools

Similar help and support threads
Thread Forum
iomega external ssd disk unknown offline, not initialized after format
Well, I really messed this one up... I have an iomega ssd model iomssdu part #31926500. Has been working great up until I intentionally chose an option to remove encryption on the device which formatted it. After format, unplugged from usb. From that point when repluged, nonfunctional. It...
Hardware & Devices
File format changed into other format after format a hard drive
Hi everyone, I recently accidentally formatted a hard drive. So, I quickly install a file recovery software (EaseUS Data Recovery). Then the result shows that most of SWF files are big in size. I think that lots of my files have been converted or combine with other files. So, how do I recover my...
Hardware & Devices
I want to swap 500Gb hdd with a 500Gb sdd. Hardware not compatible???
I was curious if some one might be able to help me please...I have a vaio vpcf121gx. A 500Gb hdd Western Digital hard drive and I picked up a Crucial MX200 ssd 500gb. I took the hdd out and put the ssd in. Tried to do a clean install with win7 pro 64 bit recovery disks. After loading all the disks...
Hardware & Devices
Iomega NAS not accessable.
My Iomega Home Storage NAS is suddenly not accessable. It is formatted in Linux (I believe). Can I in any way connect it via USB as an external HDD and save my files? My computer has Win7 64b. If I try to connect the drive via USB, I cannot see it in "My computer" but it is present in Diskmanager....
Hardware & Devices
How long does it take to format a 500GB HD
I am reformatting a 500GB Western Digital drive via a USB connection. See that attached jpg for the current configuration. The 462 gb partition format ran last night with no change. Today it has run at least 20minutes and continues. How long should I let it run?
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:33.
Twitter Facebook Google+