Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB 3.0 ports not working on Gateway SX2370

10 Jul 2015   #21
smcsmc727

Missouri
 
 
Didn't see any chipset downloads on Gateway website

I didn't find any chipset drivers among those offered on the Gateway link below. How did you get your 3.0 USB ports to work?



Quote   Quote: Originally Posted by thespis99 View Post
Quote   Quote: Originally Posted by maxie View Post
Hi there .. Try the Link below .. There are Drivers available for your Ethernet Controller and you need the Chipset Driver ..

Gateway Support - Downloads & Support Documents - Desktop / SX Series / SX2370

ALL downloaded and installed, 3.0 ports working now, will test later for 3.0 speed, but hardware config now shows 3.0 controllers instead of unknown hardware. I can now make a system restore disk and system image disks THANK YOU so much ... from a humble newbie to this forum.



My System SpecsSystem Spec
.
10 Jul 2015   #22
maxie

windows 7 home 64bit
 
 

Hi Welcome to Seven Forums ... Install the Chipset Driver it is listed under Windows 8 ...
My System SpecsSystem Spec
10 Jul 2015   #23
smcsmc727

Missouri
 
 
thanks!

Quote   Quote: Originally Posted by maxie View Post
Hi Welcome to Seven Forums ... Install the Chipset Driver it is listed under Windows 8 ...
thanks for the quick reply. I'll give it a try.
My System SpecsSystem Spec
.

Reply

 USB 3.0 ports not working on Gateway SX2370




Thread Tools




Similar help and support threads
Thread Forum
2 of 6 USB ports not working
device list was incorrect I hope my description is clear enough to understand. My XPS One 2710 (all-in-one) has 4 USB portson the back and 2 on the side. 2 ports on the back don’t work.The others do.I see in Device Manager that there is a !at the first USB Controller. Opening the last USB...
Drivers
USB Ports Not Working
Hey there Basically, I was just using my comp as normal, went to bed, got up, turned on pc and all of my usb ports weren't working, checked device manager they all had ! next to them, thought ok, il simply uninstall and reinstall and i should be fine. This was not the case, they just keep going...
Hardware & Devices
USB ports not working
I was going to charge a remote control helicopter from my laptop USB port and accidently plugged the end going in to the helicopter in the wrong way:confused:. The helicopter went on even though the switch was in the off position and I unplugged it right away. When I tried again after correcting...
Hardware & Devices
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
LAN not working-the default gateway is not available
two hours ago internet was working on my laptop via lan and suddenly it stopped working,it is working with dial-up connection but not lan,when i ran network diagnostic,it says the default gateway is not available,what to do? :( p.s. i am a mechanical engineering student so dont expect me to know a...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:13.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App