Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Stuck during boot after AHCI change

09 Feb 2014   #11

Windows 7 Home Premium x64

So I just reinstalled Windows. I had it set to AHCI, and I had some issues with the boot DVD not being recognised.

I connected the DVD drive to the Jmicron SATA port and selected it via the F12 boot menu. Installed fine.
I checked the device manager, and the AHCI drivers are installed and up to date. I shut down, and plugged in the other hard drives.

Same. Goddamn. Problem.

I've attached a screenshot of where it hangs. I'm unable to access the BIOS at this stage.

I've unplugged all the drives except the SSD with windows, and I'm able to start up as normal.

Mega sad face

Attached Thumbnails
Stuck during boot after AHCI change-image.jpg  
My System SpecsSystem Spec
09 Feb 2014   #12

Windows 7 Home Premium x64

I'm also certain this isn't normal (picture).

I opened Regedit and msahci was already set to 0. Iastorv was at 3, and I set it to 0. Upon reboot, with only the ssd, I didn't get the lovely screen stating my device driver software was updated.


Attached Thumbnails
Stuck during boot after AHCI change-image.jpg  
My System SpecsSystem Spec
09 Feb 2014   #13

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

OK, 2 different problems.

Problem 1: Internal hard drive shows up as a removable device.
This problem occurs because the AHCI driver that installs during the Windows installation is a generic one-size-fits-all driver, just to give functionality for installation.
The solution is to install the correct AHCI driver from your motherboard manufacturer's website. This could be a specific AHCI driver, the Intel Matrix Storage System driver, or the Intel Rapid Storage Technology driver, whichever one the manufacturer offers. Once the proper driver is installed the incorrect notice will disappear.
There is no need to change regisry values, and, this could mess up the new AHCI driver install.

Problem 2: The system will not BOOT with additional hard drives connected.
This problem can occur because:
  • One of the hard drives is defective
  • One of the SATA ports is defective
  • One of the hard drives contains an ACTIVE partition or second System Reserved partition
  • One of the hard drives contains a second GPT format System partition.
You did not by any chance take a screenshot of the Disk Management window from the old IDE installation? I could quickly see if #3 or #4 is going on looking at that.

To test for defective drives/ports:
Check to be sure that the SSD is installed in SATA Port#1 on the motherboard, if you need to switch ports check to be sure it boots again.

(Shut down PC between each test)
Take one of the additional hard drives and install it in SATA Port #2, start up and check. If no boot then try SATA Port #3, and so on. If it does boot, on all ports, mark it good and remove it.

Then do the same with the next drive, and so on, checking all 4 drives.

If all drives check good then start adding them one at a time and testing, until all 4 are installed or the system does not boot. Mark the drive that causes the system not to boot, or report any other condition you notice.
My System SpecsSystem Spec

09 Feb 2014   #14

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

It is also probably a good time to let us know your system specs so we know what hardware we are dealing with here.
My System SpecsSystem Spec
09 Feb 2014   #15

Windows 7 Home Premium x64

Gigabyte XD58-UD3R, i7-920 on 1366 chipset, 8gb 2-channel Patriot G2 RAM, Windows Home Premium 64bit.

Okay. So, I rebooted into IDE model and it popped up the driver notification. The SSD no longer appears as a removable device.

I changed the SSD from Port 00 to 01, and booted several times with each HDD. None of them have a partition.
There is an unallocated 100mb partition on the SSD. The only option through disk management is to create a new simple volume. This was in IDE.

When I returned to AHCI and attempted to boot with SSD + 1 HDD, I had the same error with one hard drive. The second tried to go into disk check, but rebooted when I stopped it. It was hanging at the windows splash screen but eventually worked. The third HDD went into Disk Check as well. The computer was slow to boot, the reason I'm trying to use AHCI to overcome. I had all three drives in Port 02. I'll try again on 03 shortly.

Port 03 yieled the same result for HDD 1, however the AHCI hang screen only displayed Ports 00-03. It did display that there was two devices. HDD 2 went into Disk Check again, no issues. It rebooted and took about 5 minutes to get past the splash screen so I could enter my password.
The last HDD booted fine, then hung at the splash screen for a couple of minutes. It eventually started.

I booted with HDD 2 & 3 in ports 04 and 05 respectively. This worked fine.
I attempted with the same configuration, and HDD 1 in port 02. That caused the system to hang at the pre-bios AHCI screen. I replaced the cable, still in 02. Same result. I tried again with the new cable in 03, same result. Same result in 00, only the AHCI screen recognised nothing.

So that hard drive is knackered? It's a little older, but it's my main storage drive.
My System SpecsSystem Spec
09 Feb 2014   #16

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

It is starting to look so. Can you test that hard drive in another PC? If it gums up a different system too then you will have your answer.
My System SpecsSystem Spec
09 Feb 2014   #17

Windows 7 Home Premium x64

Unfortunately I don't. It worked just fine in IDE however. I was considering attempting to run it through SATA 6 or 7, the Jmicron port. Will that have an effect?
My System SpecsSystem Spec
10 Feb 2014   #18

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

When I'm dealing with problems I tend to try everything, no matter how effective I think it might be.

Because the JMicron ports are on a separate controller, testing the drive there will tell you whether there may be a problem with the motherboard's Intel controller.
I would set the JMicron controller to AHCI mode in BIOS and then test it.

There is no reason that I can think of (other than those I have already mentioned) why a standard hard drive would have any problem running on a functioning SATA port in AHCI mode. It is bizarre that it will work in IDE mode but not in AHCI.

I just feel there has got to be a missing piece to this puzzle. Some information or condition that has not been mentioned. The clue that breaks the case.

But in any event, you want the Intel SATA controller to be in AHCI mode to run an SSD. Do not compromise on that, and don't play around with the registry settings after a clean reinstall in AHCI mode.
The problem of additional hard drives causing the system to fail to boot in AHCI mode is the problem to focus on.

Note: Port 00 is the first port on your motherboard. I know I said Port 1, but I meant to say: "use the first port". This is just for information. Which port the SSD is in has nothing to do with your problem. But it does make testing the other drives and ports easier.
My System SpecsSystem Spec
10 Feb 2014   #19

Windows 7 Home Premium x64

It's definitely a confusing problem. Luckily, the hard drive worked in Jmicron. SATA cables all over the place, but it's running well so I'm not going to touch anything anymore.

Thank you so much for your help. Now I just have to work out why my new GTX650OC gives me a lower framerate/performance in BF4 than my previous GTX550ti. Nothing is ever simple with computers, but I'd be lying if I said I didn't enjoy a challenge.
My System SpecsSystem Spec
10 Aug 2014   #20

7 professional 64

Solved the same problem by upgrading the bios.

My motherboard is gigabyte ga-ex58-ud5. I was having the exact same problem with hard drives and the bios stopping at the same bios screen.

My old install was getting very slow both in bios startup and windows running so decided to a fresh install with new ssd drive. When attempting to install win 7, it would crash at various stages the eventually after a dozen attempts eventually hanged in bios at posters screen of bios controller. Tried all sata ports but same result. Tried resetting bios via clr cmos button, optimized and failsafe settings but no joy.

Then decided to update the bios as it had never been done. After updating to the latest f13 bios, install went smoothly and no problems! No more bios hangs or lengthy startups.

It looked like something in the bios went corrupt so rewriting (or upgrading in my case) sorted it out.
My System SpecsSystem Spec

 Stuck during boot after AHCI change

Thread Tools

Similar help and support threads
Thread Forum
Change to AHCI after installing SSD won't show my HDD
Hey! Just installed Windows 10 on my newly bought Samsung 850 Pro SSD. Before this I changed the SATA Type from IDE to AHCI in BIOS. Unfortunately after successfully installing Windows I now have the problem that I can't access my HDD anymore! The HDD (a Western Digital 500GB) is listed in the...
Hardware & Devices
Stuck at startup after updating AHCI driver
Hi all, i have recently installed an ssd drive and it is working fine with achci enabled. But when i try to update the ahci driver the system stays forever in the windows starting page (the one with the glowing window logo) Do you have any idea what i should do? Also i have a...
Windows 7 Stuck At BIOS Cannot Enter BIOS or Change Boot Media
My laptop has no problem before. Recently I try to install Windows XP. First attempt fail, so I change SATA at BIOS from AHCI to Compatible, success. However the partition that I want to install*Windows XP to is not available.* So just to test I choose my Windows 7 partition. Since it want to...
General Discussion
Tried to change from IDE to AHCI, now computer is stuck
First off let me say that I don't know very much about computers. I just ordered a SSD online and will get it in a couple days. I was reading up on the tweaks and settings to change to optimize the SSD performance. One of them was to have AHCI enabled during OS installation. I decided to check...
General Discussion
Change IDE to AHCI in BIOS - Much better performance
Hi all It will mean a fresh CLEAN install of Windows I'm afraid but if you have decent SATA disks change the default setting in the BIOS from IDE to AHCI. It really WILL improve system performance --one of my big bugbears on any discussion on performance is how the I/O subsytem (generally...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:41.
Twitter Facebook Google+