Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB device not recognized in Windows 7?

09 Feb 2014   #1

Windows 7 64
USB device not recognized in Windows 7?

I have the strangest problem I've yet to encounter with my computer.
As you may have guessed from the title, I am constantly getting the message displayed. Any fix that has been suggested has been unhelpful or worked for a bit until my computer restarted again (I'll get to that)
First off it started when I noticed my mouse pointer was acting very weird, it was just a vertical line of dots. A forum said an easy fix to the problem was to update my GPU drivers, which I needed to do anyway. So after an update to the GPU drivers I log into my computer (which is password protected, this is slightly important to remember) and I try to go to youtube. I click down at the start menu to type in chrome and nothing appeared. I was able to move the mouse around and click on things but I was unable to type anything.

Luckily for me I have a laptop as well so I checked for any solutions on my laptop and they said that it was a problem with the model of my keyboard specifically This was odd to me considering most of the problems happened OTB for the keyboard and not a month after use, plus I was able to plug it into my laptop and it worked just fine. When I plugged it back into my desktop it gave me the same problem: I couldn't type anything, I also noticed the little pop-up informing me that the USB device was not recognized. "Well, great, time to get my backup keyboard," I thought to myself. Except, that was not the case either. I plugged my backup keyboard into every single USB port on my Computer Tower, even going so far as to unplug the mouse. Absolutely nothing was working. I constantly restarted my computer and each time got the same problem; I'm able to type in my password to log in and then a few minutes after that the USB device stops working. Sometimes after plugging one of the keyboards back into a USB port I would get a message saying it was installing drivers; and then would fail in installing any.

After a bit I navigate through the menus with just my mouse and do a system restore to before the GPU drivers were installed. After that, I started windows in SafeMode and then turned my computer off. Finally, I unplugged my computer completely of all plugs (including my power plug), waited a few minutes, then plugged everything back in again. Amazingly, this fixed the problem, but then it got worse.

After about an hour of gaming, my computer BSOD's, most likely because I decided to alt+tab out of Tomb Raider during a loading screen to stop a video I had on. I restart my computer again, and then the problem returns, only this time absolutely no USB devices work except my one keyboard. The backup keyboard, and both my regular mouse and backup mouse stop working a few minutes after logging in. I try to fix the problem like before, but to no avail. Any USB device I plug in either gives me the "USB device not recognized" or attempts to install the drivers and then fails.

If there is ANY way to fix this problem, it would be greatly appreciated.

My System SpecsSystem Spec
11 Feb 2014   #2

Microsoft Community Contributor Award Recipient


Hello FrankieAce and welcome to Seven Forums.

Your comment that, "Any fix that has been suggested has been unhelpful or worked for a bit until my computer restarted again" doesn't say what fixes you've already tried. I apologize if you've already these:

Try going through the troubleshooting steps prepared by one of the Forum experts. It will take several hours (or overnight when running Memtest86+) to go through all the steps and it's recommended that all steps be followed in the order listed.

Troubleshooting Steps for Windows 7
My System SpecsSystem Spec

 USB device not recognized in Windows 7?

Thread Tools

Similar help and support threads
Thread Forum
Intuos 4 + Windows 7 = USB device not recognized
Please tell me if this is not the right sub-forum. I've been encountering error Code 43. I've tried a lot and I am running out of options. I'm working on an Acer Aspire 5542G. My operating system is Windows 7. The USB device not being recognized is my Wacom Intuos 4 PTK. - I've...
USB device not recognized, in Windows 7 Only
I have a WD Passport 160GB portable HDD, which worked fine in XP on the same computer before I installed Windows 7. As many other people experienced, the once the device is connected, it will show USB device not recognized. However, my mouse and keyboard, which are USB also, are working...
USB device not recognized - but there is no usb device connected
It's recognized in device manager as "Unknown device". But I've not connected anything to pc. Also all of my usb ports are working at 1.1 speed. When I try to connect any device, I get the message "that it could work faster, if i connect it to hi-speed usb port". Any suggestions?
Hardware & Devices
USB Device not Recognized Please Help
Hi everybody I am using windows 7 ultimate sp1 duel boot with windows xp sp2 i have a usb wireless mouse , USB wireless LAN adapter and USB WD My Passport 500GB HDD and Iomega 500GB HDD alos USB They where all working fine before 2 days then suddenly windows prompts a messege saying '' Usb...
Hardware & Devices
USB Device not recognized
Hey all, I'm running win 7 64bit on a P6X58D premium mobo I just build the computer and had a brand new SSD that i loaded windows onto. now none of my USB stuff will work mouse/keyboard/thumbdrives/anything none of them work, but when I plug them in windows detects them and just goes...
Hardware & Devices
Windows 7 ultimate 32bit, sound device not recognized
sound device is not recognized(no sound, video and game controllers in device manager) plus my internet(wireless built in PCI card) does not work im thinking the drivers somehow were deleted when i attempted to charge my ps3 controller via PC(how it all started, went on to do a clean install of...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:45.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App