Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't connect to new router - hard-wired.

19 Feb 2014   #1

Windows 7
Can't connect to new router - hard-wired.

I got a new router - Verizon M1424wr

It works with wireless stuff but not with my PC...which is hard-wired. But it works with my printer (which is hard-wired).

SO, something is up with my pc. I have Win7.

I have a network controller called nforce network controller from nvidia, but people on those forums are saying that nvidia doesn't make those controllers yeah. I looked up my system info and it looks like my adapter is called


Even though, in my network window, it says the nforce is the default network controller.!!!!

My System SpecsSystem Spec
19 Feb 2014   #2

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Are your "System Specs" correct? Do you have an ASUS M4N98TD EVO board?

If so then you have a Broadcom LAN adapter, not nVidia. I think you're mis-reading whatever you're looking at. It is the Broadcom B5071 which is your network adapter, and you should already have correct drivers installed.

Here's the specs for your board from ASUS:

Aside from getting a new M1424wr router from Verizon FIOS, what else in your system has changed? What modem/router were you using before this one? Were you always on FIOS, or were you on your cable system, or what?

How were you connecting to whatever you had previously... wired, or wireless? Again, what was the router hardware previously and who was your ISP service provider, if not FIOS??

Does the Broadcom network card provide a wired vs. wireless configuration setting?? Is there some kind of "network setup" wizard for the supporting software which specifies wired vs. wireless?
My System SpecsSystem Spec
19 Feb 2014   #3

Windows 7

Yes, my system specs are correct. I took the box out and wrote it down myself.

I have always had Verizon FiOS day one. Got it about 5 years ago. Got a new router today when this started to happen. I have 100% been hard-wired, until today when I got problems. I plugged in a usb wireless thing in order to get the internet back so I can use my machine again. But, I rather have it hard-wired, so this wireless stick is just a temp to hold me over.

The internet was going on/off, so I called Verizon and they send over a fellow, he said the router was very old and I should have gotten a new one when I upgraded it 2 years ago. He gave me a "new" one, which is the M1.

We are still having problems with the internet going on and it has to be the main box.

But anyway, when the internet WAS working with the new router, the hard-wired was not working. As I am writing this, it is working (the wireless).

Nothing in my rig has changed in the past 3 months or so. (Upgraded GPU and RAM in November, no problems).

My System SpecsSystem Spec

19 Feb 2014   #4

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

So just to be sure, you were looking at the wrong thing in Device Manager earlier when you described your LAN adapter as from nVidia nForce? That is not your network card according to the ASUS specs.

If you right-click on "Computer" -> Properties -> Device Manager, and then click on the "Network Adapters" item (you might need to scroll down to make that visible) to expand it, I'm expecting you to see that Broadcom B5071 device. And if you click on the Driver tab you should see something like the following, with the driver presumably coming from Broadcom or maybe ASUS or in worst case Microsoft I guess. But we are talking about your Broadcom network adapter, right?

Next, I'm assuming you have re-booted since the FIOS guy swapped the routers, yes? This is MANDATORY when changing your "default gateway", which is what that router is for you. If you haven't re-booted, please do that now and see if this solves your problem. Even if you have previously re-booted, please do it again anyway so we start on a clean page for this discussion.

Next (after re-boot), can you please open a DOS command prompt window (Start -> Accessories -> command prompt) and enter IPCONFIG as the command. Then scroll back up until you see the "Ethernet Adapter Local Area Connection or other similar descriptive title, with information lines indented underneath it. I'm specifically looking for the IPv4 address and the "default gateway" address, if you can provide it (or a screenshot), as in the following:

And, are you still "wireless" when you did this? Can you please go back to "wired" mode (i.e. the problem situation), of course doing a re-boot. Repeat the IPCONFIG step when you're "wired", so that we can see the difference between working and not working.

After the re-boot attempting wired, down in the system tray (notification area, lower-right corner of the screen) do you see a perfectly normal network icon with no yellow or red smaller overlay icon on top of it? And no "x" or some problem indicator in the action center icon? Or do you have problem indications on these two icons?

The following is "normal:"
My System SpecsSystem Spec
20 Feb 2014   #5
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8

Dumb question - does your PC actually have a WiFi ??
My System SpecsSystem Spec
20 Feb 2014   #6

Microsoft Community Contributor Award Recipient

Windows 7 Ultimate 64

marchwaltz welcome to SF,
Have you re-booted into the bios and had a look around as maybe your LAN connection has been disabled?
My System SpecsSystem Spec
20 Feb 2014   #7

Windows 7

Okay, so here is my devices page...and no, nForce has seemed to assumed direct control. The wireless thing is my usb wireless stick, obviously.

Went ahead and ran those ipconfig tests is the WIRELESS one:

The WIRED one:

And yes, I have went into bios to no avail...the ONBOARD LAN option is enabled. Thank you for your time, however.

So what's our next move? nForce thinks it's all cool by running my network...we have to smash it into bits, right?

The peeps at the nVidia forums are saying I should pick up a NIC card...I am willing to invest in one...I just hope my board has the space...have to crack it open check...but I have a giant 760 in there which is I think blocking the PCI spot for the NIC.
My System SpecsSystem Spec
20 Feb 2014   #8

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Quote   Quote: Originally Posted by marchwaltz View Post
Okay, so here is my devices page...and no, nForce has seemed to assumed direct control. The wireless thing is my usb wireless stick, obviously.
Well, I'm certainly mystified by why the ASUS description for your motherboard shows a Broadcom LAN adapter, but let's just forget about it and proceed with what's shown... namely that you somehow apparently have an nVidia wired LAN adapter. You didn't add this separate discrete nVidia network card to your machine, did you? You're really using the onboard network connector from the motherboard? Very strange.

Anyway, the other Linksys WUSB100 item shown is obviously plug-in USB wireless LAN adapter. This is what is providing your wireless connection to the Verizon router, temporarily. I understand.

Went ahead and ran those ipconfig tests is the WIRELESS one:
I would say that at the moment it is your wireless adapter that is operational, and that your Verizon FIOS router is seen as Your PC has been DHCP-assigned an IP address of, wirelessly connected to the FIOS router.

This is perfectly fine and seemingly perfectly operational... wirelessly... as you confirm.

The WIRED one:
Obviously not simultaneously operational. If it were, you'd also see as the "default gateway" and some other IP address (say for IPv4.

But you don't. This really just confirms that the nVidia wired LAN is not operational, for some reason.

Although it's technically possible to have BOTH wired and wireless network adapters active and operational at the same time (with your PC having TWO separate IP addresses assigned by the router), that's not normally the right way to operate. So you either want to be wired (if it worked) or wireless. But to shoot the wired problem you're going to have to remove the Linksys USB adapter, I'm afraid.

And yes, I have went into bios to no avail...the ONBOARD LAN option is enabled.
This is confirmed by the fact that Device Manager shows it without any tiny icon overlaid, which would indicate some type of hardware or driver issue. Looks perfectly operational in Device Manager.

Plus, you say that it used to work just fine wired... until the Verizon guy swapped routers.

I'm fairly certain that the new router has a different set of IP addresses (e.g. that it is now whereas your old router might have been or maybe even or something else). So Windows has now created a new "network connection", and you just need to enable it properly and specify it correctly as a "home network".

So what's our next move?
Ok. First, you need to disconnect the Linksys wireless adapter and just go wired, in order for us to chase this down. Shut your machine down and remove the USB Linksys adapter, connecting the FIOS router wired to your nVidia network connector. Then re-boot.

NOTE: I know I shouldn't have to say this, but you've connected your PC to one of the 1-4 LAN ports on the router, right? You haven't connected it to the WAN port (which goes to the modem), right? Sorry to ask that, but I just want to be sure.

Now, you should see in the lower right system tray notification area those two icons... (1) Action Center, and (2) Network, which I posted a screenshot of earlier. Are they both clean, as my screenshot shows? Or is there a small exclamation mark or red "x" or anything overlaid on one or both that indicates a problem? Hover your mouse over the icon and report back what the popup flyout message says.

If there is a problem shown on the network icon (as there likely will be), right-click on it and select the "troubleshoot problems" item to kick off the Windows networking troubleshooting wizard. This may resolve everything, with the wizard discovering the problem (i.e. perhaps that non-enabled new home network) and place you at the dialog for you to check home/work/public network (and you check the "home network" item). That could be all it takes.

Second possible solution: click on the Start button, and in the "search programs and files" field type in "network connections" (without the surrounding quotes) and press ENTER. This should open the Control Panel -> Network and Internet -> Network connections window. You should probably see BOTH of your networks... (1) the wireless one corresponding to your USB Linksys adapter, which should say DISABLED, and (2) the wired one corresponding to your nVidia onboard adapter. Does it also show DISABLED, or does it show ENABLED? Or DISCONNECTED? Or what?

Left-click on the wired connection icon to select it. Right-click on the icon and select STATUS to produce the status window. What gets shown as the current status? Does it look operational or not? Close the STATUS window.

If it's already ENABLED, right-click on the wired connection icon and select DISABLE. The network icon in the system tray should now show a red "X" over it. Wait 15 seconds. Now right-click on the wired connection icon again and this time select ENABLE. The red "X" over the network icon in the system tray should disappear. Hopefully the wired connection should now spring to life and be operational.

If it doesn't show ENABLED, right-click on the wired connection icon and select DIAGNOSE, and let the wizard try to find a problem. We're trying to get that home/work/public network dialog for the new router's newly created wired network, and if/when we do and you then select "home network" I believe from that point on you will now once again be operational using wired.

Third possibility (lowest probability): right-click on the wired connection icon (in the above "network connections" window) and select PROPERTIES, to get the properties dialog window. Down about 3 from the bottom in the list of various connection items is the "Internet Protocol version 4 (TCP/IPv4)" item. Select it.

Now push the "properties" button. In the resulting properties window, you should have (1) obtain an IP address automatically, and (2) obtain DNS server address automatically, both CHECKED. You shouldn't have the alternative radio buttons checked which specify a hard-coded IP address for your PC (which would have been based on your old Verizon router's network IP address) and/or a hard-coded IP address for your DNS server (i.e. what probably would be the old IP address of your old Verizon router).

In other words, having static values here would likely be tied to your old Verizon router, and would thus prevent your PC from connecting properly to your new Verizon router. By sticking with the "obtain automatically" radio button for both options, your PC should automatically be given an IP address by whatever router you're talking to... as long as the new network (for the new router) is correctly initiated, enabled, and marked as "home network" (which is what I've tried to kick-start with the two approaches described above).

These are just assorted ideas. Report back if you have any success or breakthroughs pursuing any of these approaches.
My System SpecsSystem Spec
20 Feb 2014   #9

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

I know it seems impossible for the Verizon router itself to somehow be mis-configured, so that it doesn't support wired connections. But there is a chance that it is either defective or mis-configured.

I don't know what its GUI looks like or how to navigate around in it, but since your Linksys wireless adapter DOES seem to connect successfully to the router in wireless mode, you should be able to get into the router's setup dialog and "look around", to see if something obvious jumps out at you.

With your Linksys adapter inserted and your machine re-booted and now successfully connected to the router wirelessly, get into a browser (Firefox, IE, etc.) and type as the address and press ENTER. This should get you into the router, which probably might ask you for a userid and password. The userid might be something like "admin" and the password is perhaps the device serial number shown in the barcode label on the back or bottom of the unit. If this isn't right, call Verizon and ask for support to get you into the router.

From this point you're on your own, or you can phone Verizon for support and help, and ask them to guide you through the router to look for (1) "attached devices", which presumably would show BOTH your wireless AND wired connections, with two separate IP addresses, and (b) any settings option that somehow prevents wired access but only permits wireless access (I know, this seems virtually impossible in my experience, but I'm grasping at straws here).
My System SpecsSystem Spec
20 Feb 2014   #10

Win8/8.1,Win7-U64, Vista U64, uncounted Linux distor's

Download the current LAN drivers from ASUS site, it's in the chip set package.
Uninstall all LAN drivers you find.
Reboot to bios, set LAN disable, save and restart to bios, set LAN to enable, save and start. In other words cycle the LAN off then back on.
Install the newly d/l'ed LAN drivers, restart.
Now you should have a Broadcom B5071 LAN driver in devise manager.
My System SpecsSystem Spec

 Can't connect to new router - hard-wired.

Thread Tools

Similar help and support threads
Thread Forum
reinstall of Windows 7 - Can't connect to internet wired thru router
Hi! I'm Chrissy. I recently reinstalled windows 7. That all went well and I had the desired outcome. One little problem though - no internet. I'm directly connected to my Linksys E2000 router. When I connect the ethernet cable into its Jack, the light comes on. The wireless is working fine (I'm...
Network & Sharing
Unable to connect a wired router
Hey, I've recently reinstalled my Windows 7 Home Premium and I since my PC does not detect the router. I've tried using a SKY recovery disk, but that failed and nothing happened. Do I need to download a specific driver so the PC can detect the router? If so, does anybody know where I could...
Connect a laptop wirelessly to a wired LAN with no router
What are my options for connecting a laptop wirelessly to a workstation that is connected to a wired LAN and has no router? Essentially, I want to add wireless connectivity to the workstation so that the laptop can connect to the wired LAN via the workstation.
Network & Sharing
Can't connect to the internet or my wired Router
Just did a clean windows 7 x64 installation on a build a box computer with a new hard drive. Install went fine. Plugged it in to my 3 month old Linksys Wireless G Broadband Router (WRT54GL) and it doesn't recognize that there is any connection at all. Windows says "No connections are available" and...
Network & Sharing
Connect wirelessly to router connected Hard drive
Windows 7 HP Compaq 615, Belkin N+ Router, Freecom 500gb NTFS HDD I am trying to make a wireless connection to my external hard drive which is attached via USB to my Belkin N+ router. I use the router as the default gateway to the internet and have used the ping command to check I can send to...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:23.
Twitter Facebook Google+