Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: transcend usb 3.0 and host controller problem

23 Feb 2014   #11

windows 7 64bit build 7600

yes sorry i did a file transfer while doing the bench, here it is as it should look and does look just like the bench you linked too, also added a pic of device manager but i think theres nothing really going on there.

the last image is of a file transfer the same file as before 2.4gb and that was from my C drive which is an OCZ-vertex2 120gb SSD to the Samsung m3 and it took just shy of 42 seconds the same file from C to to the m3 but using usb2.0 took 100 seconds, does that sound about right am i expecting to much from the 10x faster hype?

no unfortunately i cant put my hands on another 3.0 drive for comparison.

My System SpecsSystem Spec
23 Feb 2014   #12

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

There are LOTS of variables here, but I still think your Transcend card is actually working properly. I think the "culprit" definitely is your Samsung M3 drive.

For example, is it formatted FAT32 (from the factory)? I think if you re-format it to NTFS it might perform a bit better, but don't hold me to it.

Also, just because USB 3.0 "promises" 10X the speed of USB 2.0, things don't happen quite that way in the real world... especially when other factors such as CPU speed, motherboard chipset and SATA/USB controller hardware, data file block size, etc., are taken into consideration. You may get terrific performance (e.g. doing a "system image" backup to a external USB 3.0 drive with Macrium Reflect) which might be up there at about 900Mb/s, or you might get "file copy" showing wide variations depending on source device and source file characteristics.

Just to demonstrate how variable this all can be (and yet it's all absolutely using USB 3.0), I ran some more of my own experiments, using a "decently strong" desktop and a "decently strong" laptop:

(a) desktop - ASUS P8Z77, 8GB, i5-3350p quadcore @ 3.1Ghz, Intel Z77 chipset USB 3.0, Asmedia USB 3.0; multiple SATA hard drives

(b) laptop - Lenovo W530, 8GB, i7-3740QM quadcore @ 2.7Ghz, Intel QM77 chipset USB 3.0; 512GB Samsung 840 Pro SSD

The desktop machine has two different 2TB Verbatim USB 3.0 drives attached. I've installed probably nine different Verbatim drives on assorted machines, and it seems that each one comes with yet another different internal SATA drive inside. These two particular Verbatim drives have (a) Seagate ST2000DL003 in one, and (b) Seagate ST2000DM001 in the other. The DL003 (drive letter W) is a 5900rpm SATA-III 6GB/s drive with 64MB cache and is plugged into one of the Asmedia USB 3.0 ports on the motherboard, and the DM001 (drive letter V) is a 7200rpm SATA-III 6GB/s drive with 64MB cache plugged into one of the Intel USB 3.0 ports on the motherboard.

The laptop machine has one 2TB Verbatim USB 3.0 drive attached, and this time it's actually a Toshiba DT01ACA200 drive inside (drive letter V). This is a 7200rpm SATA-III 6GB/s drive with 32MB cache and is plugged into one of the Intel USB 3.0 ports on the laptop. The laptop has a 512GB Samsung 840 Pro SSD drive in it (no other hard drive).

The experiments involved copying a 5GB file (a WTV recorded TV file), initially located on the M partition of the desktop machine. This is a WD2002FAEX (WD Caviar Black) 7200rpm SATA-III 6GB/s 64MB cache drive. All drives are formatted as NTFS.

The same 5GB file was copied with four different source/destination combinations and resulting elapsed durations:

(1) desktop: copy 5GB file from M to V - 50 seconds
(2) desktop: copy 5GB file from M to W - 1 minute 12 seconds
(3) copy 5GB file from desktop M to D-partition (on SSD) in the laptop via my gigabit network - 54 seconds
(4) laptop: copy 5GB file from D (on SSD) to V (USB 3.0) - 33 seconds

Obviously, (1) and (2) demonstrates that with the same source drive speed, the copy time is a function of the destination drive speed. Since the source is the same and both target drives are USB 3.0, the only possible explanation for the 50 seconds vs. 1 minute 12 seconds different copy durations must be the different speeds of the target drives (I assume the Asmedia and Intel USB 3.0 speeds are the same).

And (4) demonstrates that if the source drive (SSD) is significantly faster (than SATA-III hard drive), once again copy duration can be significantly reduced.

So depending on source and destination hardware characteristics, the same 5GB file copy can take either 33 seconds, 50 seconds, or 1 minute 12 seconds.

==> I think your particular situation is caused by the "very modest performance" of the Samsung M3 drive.

For reference, the following HD Tune benchmarks are provided showing very different performance characteristics between them all. All three different Verbatim drives are provided, along with the WD2002FAEX "source" drive on the desktop, along with the 512GB Samsung 840 Pro SSD on the laptop.

Note the significant increase in performance between the Verbatim DL003 vs. both the Verbatim DM001 as well as the Toshiba DT01ACA200. And yet all three are considered "USB 3.0".

(1) Verbatim DL003 (W - desktop)

(2) Verbatim DM001 (V - desktop)

(3) Verbatim DT01ACA200 (V - laptop)

(4) WD2002FAEX (M - desktop)

(5) 512GB Samsung 840 Pro (laptop), with Samsung Magician software running on the laptop, utilizing "rapid mode" and "over provisioning" for optimized SSD performance:

My System SpecsSystem Spec
24 Feb 2014   #13

windows 7 64bit build 7600

i think your probably right the samsung m3 is just not that fast, that being said i will at some point check on a second pc the same set up just to rule out any hardware problem i may have with my pc
thank you for your help and information dsperber its been very handy
My System SpecsSystem Spec

12 Jul 2014   #14

Windows 7 Home Premium 32 bit
USB 3.0 Expansion Card TS-PDU3

I'm late to the party but can I ask a couple of questions. I just installed this expansion card and bought and hooked up a 4 pin modex cable, I think you call it that. Not sure if I used the right power cord. Anyway I downloaded the Transcend software and I can't get my computer to recognize this card. See attached clips. Thanks

Attached Thumbnails
transcend usb 3.0 and host controller problem-capture-usb-3.0.jpg   transcend usb 3.0 and host controller problem-captureprograms-features-usb-3.0.jpg  
My System SpecsSystem Spec
13 Jul 2014   #15

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Quote   Quote: Originally Posted by rickluc View Post
I'm late to the party but can I ask a couple of questions. I just installed this expansion card and bought and hooked up a 4 pin modex cable
Actually, that's MOLEX, which is a description of the large plastic 4-pin connector.

Presumably you connected an available 4-pin connector coming off of your power supply to the 4-pin connector on the Transcend card, which you have installed in an available PCIe X1 slot of your PC.

Note that the power connector provides the additional power required to support the USB 3.0 devices which would connect to the card. If there was not this extra power connect, the PCIe bus would not provide sufficient power for the card to properly connect to attached USB 3.0 devices, and the card would not function in USB 3.0 mode. This has happened to me when I forgot to attach that power cable in the past.

As to whether it would even work in a degraded USB 2.0 mode without attached power cable, I don't know. But it's obviously NOT designed to work that way.

In any case I would still think the card would be recognizable and drivers installable, even if you didn't have a proper additional power cable connection to it.

Not sure if I used the right power cord.
There's only one type of 4-pin MOLEX-connector cable that can attach to the card, as any other SATA-style connectors from the power supply simply cannot be used as their connectors are incompatible.

Anyway I downloaded the Transcend software and I can't get my computer to recognize this card. See attached clips. Thanks
The screenshot shows "card cannot start". It could be DOA, or perhaps it's got an odd hardware id and the downloaded transcend software didn't recognize it.

If you select the Details tab (in Device Manager properties for the card), and select the second item (Hardware IDs) in the Property dropdown box list, that will present a set of value strings describing the card. That should also be what the driver installer software INF file is looking for. Can you please post a screenshot of those Hardware IDs for the card?

As I previously posted earlier on this thread, I myself have this 2-port Transcend TS-PDU3 PCIe USB 3.0 controller card in my own PC, and its Hardware IDs are as follows:

My System SpecsSystem Spec
13 Jul 2014   #16

Windows 7 Home Premium 32 bit

Attached Thumbnails
transcend usb 3.0 and host controller problem-capture-device-manager.jpg  
Attached Images
transcend usb 3.0 and host controller problem-capture-usb-msconfig.jpg 
My System SpecsSystem Spec
13 Jul 2014   #17

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Quote   Quote: Originally Posted by rickluc View Post
This is the card I got.
I wanted to see a screenshot of the SECOND item in that Property dropdown list... Hardware IDs. What you've captured is the FIRST item... Device Description. Please post another screenshot of Hardware IDs.

And I don't know why you posted that second screenshot of your MSCONFIG startup items, but it looks like it probably matches my own. You haven't captured enough to show everything but it looks right. Here's mine.

All of this says to me that you probably did get the proper Renesas driver software installed, but for some reason the card is not starting.

Have you tried re-seating the card? Re-connecting the Molex power cable to it (be careful about pulling it out and putting it back on... this really should be done with the card removed, so you can hold it with both hands for leverage so as not to break the plastic power connector on the card away from the card)?

Try uninstalling the driver/software using Control Panel (uninstall a program)... "Renesas Electronics USB 3.0 Host Controller Driver", and then re-boot, and then reinstall the drivers again to see if this time it works.

Or... maybe the card is DOA. Or, maybe it's "generic junk".

Worst case, buy another 2-port one from B&H for $13. They're only 2-ports, but I've installed several of these in friend's machines and they've all worked. I did try and install a 4-port card from StarTech once and it NEVER worked. Finally threw it out and installed this 2-port Transcend card and it worked perfectly.

I know, you said you got a 4-port "generic" card from Newegg... so just return it, as it doesn't work. It's about the same $12 price as that 2-port Transcend TS-PDU3 for $13 from B&H, but I "virtually guarantee" the 2-port Transcend card will work. Or, you can get the same 2-port Transcend TS-PDU3 from Newegg for $15. So just get Newegg to exchange your defective 4-port card for a 2-port TS-PDU3.

Don't waste too much more time on this. Newegg will exchange it for no charge. Go with one from Transcend that's known to work... I vouch for it.
My System SpecsSystem Spec
13 Jul 2014   #18

Windows 7 Home Premium 32 bit

Sorry, worse than my kids. I should have read better. How can I get my config to show the hole line like you did, because mine doesn't say what yours does? Thanks

Attached Thumbnails
transcend usb 3.0 and host controller problem-capture-device-manager-2.jpg  
My System SpecsSystem Spec
13 Jul 2014   #19

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Your Hardware ID (VEN_1912&DEV_0015) shows this card to be an NEC chip, not the same as the original Renesas chip (VEN_1933&DEV_0194) which is in my own theoretically identical Transcend TS-PDU3 card but purchased some years ago. Looks like vendor 1933 doesn't exist any longer, since NEC acquired Renesas back in 2010.

Nevertheless, for your current TS-PDU3 the vendor/device info is as follows:

Did you not get a driver CD with the card? If you do have a driver CD, there might be an \NEC 3.0 folder on it. Inside that folder you should possibly find a \uPD720200 or \uPD720202 sub-folder, inside of which should then be a SETUP.EXE to install the driver for your card. If you can find this, RUN that SETUP.EXE to install the drivers for your card.

If you didn't get a driver CD with the card or you don't have an \NEC 3.0 folder on it, I believe you can download the correct driver from the URL address shown in my screenshot above. This is the driver, which I believe is the most current version of the driver for VEN_1912&DEV_0015 device id, i.e. your current USB 3.0 card.

If you download that driver installer file and run it, if it works you should be good to go. If you get an error message popup about "hardware not found" or something to that effect, then we need to look further.

Please report back as to your success or failure with the driver I pointed you to.

As far as how I got the "whole line" to display in MSCONFIG System Configuration -> Startup tab, just hover the mouse over the right side of that line, and you'll get the flyout which will show you everything in that operand which the mouse is hovering over.

Are we talking about that MSCONFIG screenshot, or a different screenshot?

Anyway, please try the driver I pointed you to.
My System SpecsSystem Spec
14 Jul 2014   #20

Windows 7 Home Premium 32 bit

I uninstalled the original drive I had downloaded from Trandscent and downloaded and installed the driver you suggested because I didn't get a CD with the expansion card. Didn't help. So today I went back into computer and pushed harder on the expansion card to make sure it was seated in board. I also, which I think might of been the problem, was remove the 4 pin white connector and plug it into another white 4 pin connector. I wasn't sure which 4 pin white connectors were hot and didn't know for sure how to test and find a power supply for sure.
Anyway everything is working. See attached clip where two Renesas refurances are showing up in device manager. Is this OK? Thanks for your help.

Attached Thumbnails
transcend usb 3.0 and host controller problem-capture-reconnected-different-connector-4-pin-power-cable.jpg  
My System SpecsSystem Spec

 transcend usb 3.0 and host controller problem

Thread Tools

Similar help and support threads
Thread Forum
Problem Installing 1394 ohci compliant host controller legacy driver
I am trying to use my Sony DSR-200A (DV) camera to my HP PC via fire wire. I am running Windows 7 Premium Home Edition, 64 bit. The computer does not recognize that anything is plugged in. I have read other threads saying that the fix is to switch to the 1394 ohci compliant host controller legacy...
Installation & Setup
USB 3.0 Host Controller Not Found
I've just recently upgraded my pc but i'm having issues trying to install and setup the drivers for the usb3.0 ports and updating the firmware. I'm running on Windows 7 x64 My motherboard is the P8P67 PRO Rev. 3.0 - New P67 B3 Revision I have tried the drivers and firmware from here without...
Standard Enhanced PCI to USB host controller problem
I noticed on Devices and printers that my computer needs troubleshooting. I tried to right click and Troubleshoot but it wasn't able to find out the problem. What should I do? I don't even know what those devices are.
Hardware & Devices
PCI to USB Open Host Controller problem
i got this problem since i installed my OS... i tried fixing and searching for solutions but i have no luck. can anyone please help me with this before i will decide reinstalling my OS:cry: here`s my problem; but when i update it says;
USB Host Controller problem
Hi Have the following problem I've so far been unable to solve. I have an ASUS P5K-E running 32 bit Windows 7. In device manager the following are highlighted with the following message. -Standard Universal PCI to USB Host Controller -VIA Rev 5 or Later USB Universal Host Controller -VIA...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:25.
Twitter Facebook Google+