Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: transcend usb 3.0 and host controller problem

14 Jul 2014   #21

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Quote   Quote: Originally Posted by rickluc View Post
I uninstalled the original drive I had downloaded from Trandscent and downloaded and installed the driver you suggested because I didn't get a CD with the expansion card. Didn't help.
What happened when you ran the installer file? Did it complete normally? Did it fail with an error message, complaining about hardware not found?

So today I went back into computer and pushed harder on the expansion card to make sure it was seated in board. I also, which I think might of been the problem, was remove the 4 pin white connector and plug it into another white 4 pin connector. I wasn't sure which 4 pin white connectors were hot and didn't know for sure how to test and find a power supply for sure.
Anyway everything is working.
Well, that's certainly the good news we were shooting for. I suspect reseating the card and trying another power supply cable were good things to try, and they obviously produced the desired results.

However it's still not possible for the device to be working without drivers. Your screenshot of Device Manager showing the two Renesas USB 3.0 devices is perfect. So my guess is that you are now actually running the driver I pointed you to and that you ran (but said "didn't help"). While it might not seemed to have helped initially, after you re-seated the card and used a different power supply cable the just-installed drivers now actually did have proper hardware to apply themselves to.

If you right-click on the Renesas 3.0 XHCI Host Controller item in Device Manager, select Properties, and then select the Driver tab, I suspect you will now see that the driver IS installed and that it is the very Renesas version from 8/21/2012 that I pointed you to and that you just installed.

If it's not that driver, it's still got to be some other driver... because hardware can't work without some driver installed. So what is the driver vendor, version and date, shown on the Driver tab of that device??

Also, if you go into Control Panel, Programs, and then slide down until you see the Renesas USB 3.0 driver software (which I'm sure will be there), look over on the right and you'll see the "installed date" and "version". Again, I suspect it will be today's date and version corresponding to your installing the file I pointed you to today. So, what do you see in Control Panel?

Anyway, sounds like you've emerged victorious!! And that's what's important. Excellent.

My System SpecsSystem Spec
16 Jul 2014   #22

Windows 7 Home Premium 32 bit

Maybe I shouldn't have but I uninstalled the driver I had installed prior to you telling me were to go to get new driver. The driver you told me to download and install seemed to install fine. I think you and I got it. Thanks

Attached Thumbnails
transcend usb 3.0 and host controller problem-capture-programs-features.jpg  
Attached Images
transcend usb 3.0 and host controller problem-capture-host-controller.jpg 
My System SpecsSystem Spec
16 Jul 2014   #23

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

You're home free. Perfect.

Interestingly, while I was doing my own research I downloaded that driver installer file and ran it for myself on my own laptop... which does NOT have the Transcend card installed.

Remarkably, the installation process "completed normally", which is certainly strange considering the required hardware was NOT present on the machine. In another similar forum thread the chipset was not from Renesas/NEC, but was from VIA. And the installer had been written so that if the required hardware was not present an error message would be presented advising of that fact... which is good design, in my opinion.

Anyway, rather casually, this Renesas driver installer (which both you and I ran) just quietly completes "successfully", no matter whether it actually found the expected hardware or not.

So, back to your story, I'm sure that's exactly what happened. You uninstalled your first originally installed Transcend driver and then ran this Renesas driver installer (, which now being installed was there dormant and waiting for the hardware it would support.

And then when you removed and re-seated the card, and connected a different power supply cable, well now the hardware finally actually WAS electrically connected and truly ready for use. So when you next booted Windows, the "new hardware detected" process launched, with the VEN_1912&DEV_0015 Hardware ID. Windows then searched its "Driver Repository" for a suitable INF to match the Hardware ID, and found the Renesas INF which you'd just installed with that Renesas driver installer.

You probably then saw "installing drivers for device...", and then "drivers installed successfully, device is now ready for use".

And bingo... you now have a pair of working USB 3.0 ports on your machine! Congratulations.

Note that even though USB 3.0 has a theoretical high speed that is maybe 5X that of regular USB 2.0, you won't likely actually achieve that in real life. For sure, the speeds you will actually get reading and writing to an external USB 3.0 drive vary significantly, depending on the underlying drive (probably SATA-III, but could be SATA-II) in the enclosure and its specifications. You can use HDTune (free version is fine) to run performance tests on the external USB 3.0/2.0 drive and compare it to the performance of the same drive when plugged into a standard USB 2.0 port.
My System SpecsSystem Spec


 transcend usb 3.0 and host controller problem

Thread Tools

Similar help and support threads
Thread Forum
Problem Installing 1394 ohci compliant host controller legacy driver
I am trying to use my Sony DSR-200A (DV) camera to my HP PC via fire wire. I am running Windows 7 Premium Home Edition, 64 bit. The computer does not recognize that anything is plugged in. I have read other threads saying that the fix is to switch to the 1394 ohci compliant host controller legacy...
Installation & Setup
USB 3.0 Host Controller Not Found
I've just recently upgraded my pc but i'm having issues trying to install and setup the drivers for the usb3.0 ports and updating the firmware. I'm running on Windows 7 x64 My motherboard is the P8P67 PRO Rev. 3.0 - New P67 B3 Revision I have tried the drivers and firmware from here without...
Standard Enhanced PCI to USB host controller problem
I noticed on Devices and printers that my computer needs troubleshooting. I tried to right click and Troubleshoot but it wasn't able to find out the problem. What should I do? I don't even know what those devices are.
Hardware & Devices
PCI to USB Open Host Controller problem
i got this problem since i installed my OS... i tried fixing and searching for solutions but i have no luck. can anyone please help me with this before i will decide reinstalling my OS:cry: here`s my problem; but when i update it says;
USB Host Controller problem
Hi Have the following problem I've so far been unable to solve. I have an ASUS P5K-E running 32 bit Windows 7. In device manager the following are highlighted with the following message. -Standard Universal PCI to USB Host Controller -VIA Rev 5 or Later USB Universal Host Controller -VIA...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:44.
Twitter Facebook Google+