Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't format my Kingston 8GB USB, it says the disk is write protected

24 Feb 2014   #1

Can't format my Kingston 8GB USB, it says the disk is write protected

Already tried DiskPart-> clean and it didn't work. This just happened when i plugged my USB into my 3.0 port and did the automated windows "scan and fix" option when it popped up, afterwards It errored and i cant access my files anymore, nor format it as it says "write protected"

I also tried the cmd:
>list volume
>select volume 4 (the USB)
>attributes disk clear readonly
Result is: Disk attributes cleared successfully

but it still says read only =(

My System SpecsSystem Spec
24 Feb 2014   #2

7 home premium 64 bit

I have searched the internet and it seems to indicate that in order for your flash drive to become Write Protected there should be a switch on it somewhere. They also said to try it in a different computer and see if you can access it. That lets us rule out flash drive or computer. They seem to indicate some flash drives can be write protected via software that comes with the flash drive. Does any of this apply to your flash drive?

My System SpecsSystem Spec
24 Feb 2014   #3


nope, there is no switch and ive tried on multiple computers as well. When i select that drive and do "det dis" on cmd this is what appears, there is no software that comes with the USB too, i bought it to their customer support and we did the entire cmd diskpart thing to no avail. (coz of the read only stuff)

Kingston DataTraveler G2 USB Device
DIsk ID: 00000001
Type: USB
Status: Online
Path: 0
Target: 0
Location Path: UNAVAILABLE
Current Read-Only State: Yes
Read-only: No
Boot Disk: No
Pagefile Disk: No
Hibernation File Disk: No
Crashdump Disk: No
Clustered Disk: No

doing att dis clear readonly doesnt do anything to the current read only state, only to the read-only part
My System SpecsSystem Spec


 Can't format my Kingston 8GB USB, it says the disk is write protected

Thread Tools

Similar help and support threads
Thread Forum
If a usb says don't format me i am write protected then what to do
If a usb says don't format me i am write protected then what to do? :eek:
Hardware & Devices
How to format write-protected USB flash
Hello, I have a USB flash memory that while there isn't any switch on it when formatting it says can't format, it's write-protected! Why it's this way and how to format it please?
Hardware & Devices
Flash drive WRITE PROTECTED,, not able to format
I am having some problems with my flash drive (SANDISK 8GB), i can't format and change any file of my flash drive, every method for flushing my data gave me the same respond, THE DISK IS WRITE PROTECTED, i googled for the same but all was in vain,,, i tried formatting my drive with command...
General Discussion
How to remove/format write-protected USB's?
Hey guys, I've got a write-protected USB and wanting to remove it so I can manage files on it. I've also searched the webs for methods, however they do not work. I've tried formatting using CMD via safe mode, setting value to 0 in regedit, go into properties and change sharing settings to "full...
Hardware & Devices
How to Format a Write Protected Disk
I have "Jetflash Transend 8GB" flash drive. I can't format it. When i try to delete or format it this error appears "The disk is write protected" so how do i format it. That flash drive contains some Trojan horses.
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:20.
Twitter Facebook