Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 1TB WD external hard disk not initialized

24 Mar 2014   #11

Windows 10 Pro

Quote   Quote: Originally Posted by kaufmann View Post
To sygnus21==>

A mutual friend of mine has the same hard drive, so I tried it with his cable. The result was same.
I tried it with my cable in his laptop, and his cable in his laptop. It was of no use.
Also, I am able to detect his hard drive with my cable, in my laptop.
So, I assume that there's nothing with my pc or cable.
Based on what you present here, I'm 99.9 percent it isn't your PC and am just about equally sure the drive is bad.

Equally, with what you present, there's really no need for the procedures presented by jumanji as your laptop appears to be functioning correctly since you note you can detect your friend's drive.

With that, have you contacted WD's tech support?

As a side note, you might want to free up some space on your other drives as they getting to a point where you wont be able to install or run any programs from them. This is where your external drive would help out, but if it's dead... you may need a new one.

Anyway try contacting Western Digital's tech support and go from there. They may even offer to send you a replacement depending on warranty.

Good luck.

My System SpecsSystem Spec
24 Mar 2014   #12

Windows 7 Home Premium 32 bit

Hi Kaufmann,

1. The reason why I wanted you to stop Daemon from creating virtual drives is to confirm the source of the virtual drive. Even now your computer shows another drive F. If you do not have another physical drive (please confirm) then I am sure that it is coming from your Western Digital drive. WD drives may contain a VCD - and a troublesome one at it.

2. I was never in doubt of your cable because as per your first post screenshot, you had run Datalifeguard on your WD drive and as per indications it passed the test.

3. I am now inclined to think it is the Smartware that is preventing access to your drive. Now a question: Your drive is PW protected and no doubt you have instructed Smartware to auto access the drive with that. Now your friend used it. How? He knows the Password? What did he do to access the PW protected drive? If after this event your drive became inaccessible on your PC, I would definitely try to connect it with this event and Smartware rather than saying your drive is dead for sure.:)

4. Non-present devices and drive letters associated with those which Windows keeps in the registry can at times confuse Windows and prevent access to the drive. I tried to eliminate this possibility. Was it a cumbersome process - downloading a 25KB zip file, unzipping it, and clicking on the exe file?? You know it. I do it. Here it goes just clicking on an exe file.

1TB WD external hard disk not initialized-25-03-2014-09-50-17.jpg

Keep doing it periodically, to keep your computer clean to prevent that confusion and attendant problem.

5. Run the WD Lifeguard Diagnostics again. In the first post screenshot the drive is shown as zero capacity.( May be Windows and Smartware is responsible for it.) Please note and tell me whether the long test really runs. If it really runs to its capacity of 1 TB it should take a long time to complete. If it instantly gives a pass, then you should run the DOS version from a bootable DOS pendrive - overriding Windows and Smartware. In any case this will be necessary if you want to take it up with WD Tech Support. ( Your friend could have dropped and killed it.That possibility also exists. But I won't come to any conclusion merely on surmise :)) If you don't know how to run the diagnostics from a pen drive let me know. I shall then give the instructions. I need a break now.

My System SpecsSystem Spec
25 Mar 2014   #13

Windows 7 Home Premium 64bit.

Hi Jumanji,

1==> Yes, the VCD shown is coming from WD drive.

3==>Yes, my friend knew the password to the drive.

5==> I am afraid you are right! The long test gives me the pass result immediately.
I do not know how to run the test from a bootable pendrive. Could you please post me the instructions.
I appreciate your help. Thanks a lot!
My System SpecsSystem Spec

25 Mar 2014   #14

Windows 7 Home Premium 32 bit

I have read your post. May take some more time to work on it.

I have to brew my coffee and feed the fuel. :)

Please check after an hour or two.
My System SpecsSystem Spec
25 Mar 2014   #15

Windows 7 Home Premium 32 bit

Before you run the Diagnostics, a) try to input your password and access the drive.( uncheck Remember the Password also) b) Try removing the security in the software and try to access the drive without the need for a password. I think the software settings allow it. c) Ask your friend whether he had changed the Password d) ask your friend whether he had accidentally dropped the drive.

I do not have a Western Digital external drive. I do not know anything about Smartware as already stated in the beginning. I just had a cursory glance an hour or so ago. When your friend accessed it on his user account, it would have asked for the password. After that when you plugged it in into your user account, it should have asked for the Password. Did that happen?

Please remember, if you have forgotten the password, or the password has been changed there is no way to access the drive except erasing the drive with the software and starting afresh.

The software also enables you to run the diagnostics and you should do it first.(with your cable and with your friend's cable) . You should be knowing better about the software. So try everything possible with the software. Only a person who has been using that software can give you better instructions. Since Sygnus21 had said he had dealt with WD drives, let us see whether he can throw more light on it.

Now to run Datalifeguard,

1. Run Datalifeguard Diagnostic for DOS: Use your own cable

With Rufus Rufus - Create bootable USB drives the easy way , create a bootable MSDOS pen drive. Backup all data on your pen drive beforehand for it will be lost when Rufus formats the pen drive. Plug in your pen drive and run Rufus. Leave most of the things to default. Check your correct pen drive is shown. Select MSDOS in the drop down arrow in "Create a bootable disk using" and then click on Start.

Check the Support page for your WD model and download Data Liifeguard Diagnostic for DOS

If none, then Download WD Support / Downloads / SATA & SAS / WD VelociRaptor and extract the contents to the bootable msdos pen drive you had created.

Plug in your WD external drive, Boot from the pen drive and against the command prompt type dlgdiag5.exe and press enter to run it.

Check that your drive is shown with the correct capacity and do the short and long test.

2. Repeat the same with the cable borrowed from your friend who has the same drive.

3. Repeat Data LifeGuard for Windows with your friend's cable.

Keep us posted on what you do and the results.. May be other people can help even if I can't any further than this.:)
My System SpecsSystem Spec
26 Mar 2014   #16

Windows 7 Home Premium 64bit.

Hi Jumanji,

I really appreciate your help. Even though I am worried about this day and night, I have no choice and will be gone for 3 days.
I will be back this weekend and will do the steps suggested by you. I will post the screenshots of the test. Hope you will still be there to help me out. Thanks!!!
My System SpecsSystem Spec
26 Mar 2014   #17

Windows 7 Home Premium 32 bit

Not to worry. Take your time. The whole process itself may take time. Do it slowly and steadily without hurrying up.

Of importance is to read any and all documentation on the Smartware and try to get rid of the Security ( need for a password ) and also run the diagnostics in it to test the drive.

Removing the Security itself requires you to input the original Password. If you cannot remove it then it would mean that you have either forgotten the Password, or the Password has been changed.

I am also not sure whether Smartware allows you to run the diagnostics from it without gaining access to the drive with the Password.

In that case run diagnostics from DOS shutting down the Windows and Smartware which kicks in with the VCD.
My System SpecsSystem Spec

 1TB WD external hard disk not initialized

Thread Tools

Similar help and support threads
Thread Forum
External hard disk not initialized (case 2: unknown/)
Hello, I'm a doctor, I have some idea about these things but I don't wanto loose my data, so help needed. Got a case of bad hard disk, disk status: unknown/not initialized/not migrated/asking to do GPT or MBR to initialize et al. It's getting detected in 'Computer Management' but not as a...
Hardware & Devices
External Hard Disk, Unknown, Not Initialized ! No Unallocated Space.
Hi, I'm new to this forum. My external hard disk (Seagate) is detected in the task bar after connecting, but not visible in "My Computer". It is visible in Device manager under Disk Drives but not under USB. There are few threads in this forum which are similar to mine, except that...
Hardware & Devices
Windows 7: Disk 2 (external hard disk) is Unknown, Not Initialized
Hello, I have run into a problem that has been causing me quite a bit of headache as of late. A week ago, my WD Elements External Hard Disk is not displaying under hard disk drives, but does display under Devices and Printers. This is what it shows under computer management:...
Hardware & Devices
External hard drive disk unknown n not initialized!
Guys please help me to fix my hard disk WD elements 1TB I have tried so many ways to fix it.. but I got nothing in 4 days!! :cry: I have tried from command prompt " chkdsk /f /r " the first time I tried it works, but something error occured, and now I can't using that method.. when I tried...
Hardware & Devices
Unaccessible External Hard Drive: Disk 1 Unknown, Not Initialized
Hello. Through the power of google, I have come here to see If I can get any help recovering data. Essentially found this thread: and just having really similar issues. Issue is with my sisters...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:25.
Twitter Facebook Google+