Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Newly bought Kingston 3.0 flash drive stops at times

06 Apr 2014   #1

Windows 7 Home Premium x64
Newly bought Kingston 3.0 flash drive stops at times

I just bought a USB flash drive kingston data traveler 3.0 16gb recently , and when i format it as NTFS , and start storing some files in it , i start to see its writing speed is very low , just like 25 or so per sec , 33.6 with Asus 3.0 USB boost , and while im transfering files , i noticed that it stops every once a while , then continue. And this problem only occur when its formatted as NTFS , its fine when its FAT32 .... but if its using FAT32 i cant use more than 4gb for readyboost ... and i have tried to test the speed while its being used for readyboost and not , same result , same problem , only thing is the speed is faster while its free from any duty , should i worry about it or this is very normal and have nothing to worry about ? i just bought it for 7 days , mainly for readyboost , i can totally exchange it for a new one .... but i bought it from my aunt , she sells these things for a living so i needed to ask first before i blame her for it.

My System SpecsSystem Spec
06 Apr 2014   #2

Windows 7 Pro 64-bit

I have a Kingston 64GB and experience extremely slow transfers. Thought the drive was bad but after searching found it to be a pretty common problem with many complaints. Mine is so slow I won't even use it.
My System SpecsSystem Spec
06 Apr 2014   #3

Windows 7 Home Premium x64

........ kk .... guess i'll never buy kingston stuffs ever again , ty ....and i dont even think its running on 3.0 system , when i plug it on 2.0 port it give me the same speed , same problem
My System SpecsSystem Spec


 Newly bought Kingston 3.0 flash drive stops at times

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 Pro Key invalid for activation, newly bought, need help.
My windows 7 key won't work. Newly bought and installed on an MSI b350 motherboard. Is it legit? Diagnostic Report (1.9.0027.0): ----------------------------------------- Windows Validation Data--> Validation Code: 0 Cached Online Validation Code: N/A, hr = 0xc004f012 Windows Product Key:...
Windows Updates & Activation
Kingston flash drive not detected (probably hardware)
I have a Kingston flash drive 8gb usb 2.0 just like this one: but for some reason it's not working on my pc/laptop/ps3 and any other computer I tried it on. when I plug in the flash drive I don't get any detected sound on my windows...
Installing Windows 7 on newly bought drive
Drive is a Western Digital Caviar Blue (WD10EALX) 1TB. Computer is a Gateway FX7026. I've removed both my old drives, only the new drive is connected. I did a clean, custom install. I keep getting the message: "Windows cannot be installed to this disk. this computer's hardware may not...
Installation & Setup
Kingston Flash Drive Hoax
Well I need a new flash drive and was searching on ebay. I found this product: Kingston 64 GB Data Traveler 300 perfect condition USB - eBay (item 350375474636 end time Jul-28-10 18:56:35 PDT) only problem is is that the seller claims it to be a datatraveler 300, now that searies only is...
Hardware & Devices
Kingston Flash drive won't open
Hi, I have a Kingston DataTraveler 100 (8GB) flash dive. My pc detects it, installs the driver but the USB doesn't show in 'my computer'. So, I can't open it and the device is also not shown in 'disk management' but it is listed in 'device manager'. I also have another USB drive that works...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:56.
Twitter Facebook Google+