Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "USB 3.0 This device can perform faster" message even though connected

13 Apr 2014   #11
Phone Man

Windows 8.1 Pro w/Media Center 64bit, Windows 7 HP 64bit

Your speed looks normal for USB 3, at least that is what I get on my USB 3 WD external disc. I also have a USB 2 Seagate and it gets about a 1/3 of that.


My System SpecsSystem Spec
13 Apr 2014   #12

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1

@Phone Man, thanks. That's put my mind at ease.
My System SpecsSystem Spec
14 Mar 2015   #13

Windows 7 Pro 64bit

I am having the exact same issues.
It started with a Vantec dock that they said was faulty so I returned it. I then bought a Syba SY-ENC35026 and it is doing the same. Using WD Black 1TB drives. I tried it with two motherboards but got the same result. USBTreeView shows it only running at high speed.
Any help would be great as I am only getting 40-45MB/second.
My System SpecsSystem Spec

19 May 2015   #14

Win7 Ultimate 64bit

I just wanted to chime into this old post because of something I did to fix the issue I had with my USB 3.0 dock connected to a USB 3.0 hub. It was stating the "this device can perform faster ...".

After checking the cable and hub, I remembered something else that happened after transitioning to USB 3.0. If the cable isn't connected or pushed all the way in, it's possible that the 2.0 connections will connect, but the necessary 3.0 connections will not. So once I pushed in (make sure you power off the device/hub first) the cable all the way in to the hub, I was back to USB 3.0 speeds.
My System SpecsSystem Spec
23 Feb 2016   #15

Windows 7 Home Premium SP1 64bit

I know it's an old thread, but this is the exact problem I'm having and the suggestions haven't solved the issue yet.

So I looked at the USB device tree viewer, and my USB3 external HDD connects to the same USB2 hub no matter where I plug it in. I have 2x blue USB3 and 1 USB2 physical ports on the outside of my laptop.

Here's a screenshot.

The 3rd controller seems like it's the USB3. The 1st 2 not. My ex HDD is highlighted. How can I force it to use USB3? I already tried uninstalling driver and reconnecting.
Thanks for any help in advance!

My System SpecsSystem Spec
23 Feb 2016   #16

Windows 10 Pro x64 x3, Ubuntu

Is your external drive USB3 compatible - if not fully supported it will default back to USB2
My System SpecsSystem Spec
24 Feb 2016   #17

Windows 7 Home Premium SP1 64bit

Yeh, it is- says "USB 3.0 interface" on the box. The USB 3 cable came with it in the box too. HGST Touro S 1TB.
My System SpecsSystem Spec
09 Mar 2016   #18

Windows 7 Professional x64

I have a similar problem, not exactly the same, but similar. I'm hoping you guys have suggestions, because the other results for searching around for solutions to this problem on the net result in advice from 2012, the days where USB 3.0 was still a rather new thing. If there truly is nothing we can do about it, then I also hope my views allow other readers to put the problem in the "can't do anything about it, accept it" basket.

I can get USB 3.0 speeds out of this disk, Seagate Expansion 2 TB 2.5" sometimes. However, very often, I get the old Windows "This device can perform faster if you plug it into a SuperSpeed USB 3.0 port" warning. When that happens, UsbTreeView reports that the device is only running at H, not SS, and I'm back in the USB 2.0 era.

My solution is to plug the connector out of the drive, and plug it back in. Sometimes things go well, and I get SS connectivity and I can transfer at 50 to 60 MB/s (i'm not going to convert that to megabit per second, this is the speed Windows and FreeFileSync reports, and the speed I calculate when I do the filesize / time to copy calculation) - this I deem to be USB 3.0 speed.

I have more success angling the connector slightly when I plug it back in, almost as if I force different pins to make contact first, or possibly lowers the resistance of the connection at the time. The drive side us a USB 3.0 micro connector.

Also, often, when I reboot, the drive detects as H again. The only solution is to plug it again. The plug is wearing out as a result.

When it works fine, and rebooting causes the connection to downgrade, implicates drivers, firmware and software. I believe that is part of the issue. But powering up the drive also comes into play, maybe if the connection is assisted by manipulation when you plug the drive it goes SS, where if it is left alone, it has enough power to keep spinning, but the connection unassisted by manipulation has too high resistance to allow enough power through to spin up the device on a reboot.

My thoughts are it's a hardware problem, I propose 3 postulations:
  • The connector does not reliably connect all the pins with low enough resistance to power up and detect as SS.
  • The USB 3.0 micro jack on the drive got bent one too many times and a track on the PCB of the drive developed a dry contact.
  • The contacts degraded from too much movement on the connector.

To me, it boils down to the connection, and I feel the design of the USB 3.0 micro connector is the culprit. It's too fragile.

Lets hope USB C in future hardware improves our situation.
My System SpecsSystem Spec
15 Mar 2016   #19

win 7 pro x64

I had a similar problem with an expresscard USB 3.0. The card supplier explained that the speed is limited by the speed of the bus that the hub is connected to. If the bus speed cannot support full USB 3.0 speeds, the hub will operate at the highest speed it supports, faster than USB 2.0, but the OS will still tell you it is not full speed. In fact I was getting speeds higher than 2.0, but not full 3.0.

There also seem to be issues with the negotiation. Probably the USB 3.0 standard has ambiguities, and may not be easy to translate into Chinese, so subtle timing issues might result in fallback.
My System SpecsSystem Spec
16 Mar 2016   #20

Windows 7 Professional x64

Just a follow up - I found a cable that reliably connects as SS. I had several other cables, and they let me down. Maybe fish around for cables to have lots of options to test with.
My System SpecsSystem Spec

 "USB 3.0 This device can perform faster" message even though connected

Thread Tools

Similar help and support threads
Thread Forum
Error message "Could not perform this operation.....mail client"
When I click an email address on a website or if I click an email address on a spreadsheet, I get the following error message "Could not perform this operation because the mail client is not properly installed". Then, hundreds of blank internet explorer pages are opened. I researched online...
Browsers & Mail
The message: " No internet access" The fact: connected
I use Windows 7 RC at work. I connect to the internet over company LAN with static IP and manualy inserted DNS. My internet connection is OK, everything works, but there is a yellow triangle in the connection icon in tray. If I put the cursor over it, I can read: "Network No internet access" I...
Network & Sharing
Windows mobile device manager-"not connected" help!
I'm having a lot of trouble connecting my PDA. I used to have a decent connection with WMDM on both 7 and vista, but now it's starting to show "not connected" constantly. It's become worse on vista. Anyone know how to help? I'm trying to get my PDA HP ipaq HX2795 connected. I have two of them, and...
Hardware & Devices
"This device can perform faster"
Hi, I receive the notification in the taskbar below whenever I turn on my USB 3.0 externals. I didn't get this when I first used these externals, this has only happened more recently, and happens with both the Vantec and Eagle Tech USB 3.0 enclosures I have. FYI: I'm using proper USB 3.0...
Hardware & Devices
USB - annoying "Device Can Perform Faster" message
Pops up every time I plug in a USB - I've got two different flash drives and an old mp3 player. Message is the same for all devices. Been using 7 RC1 since it came out (flash drives and mp3 player for a lot longer) but this message box is a relatively recent thing. Gives me a list of all my USB...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:40.
Twitter Facebook Google+