Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win 7 64bit some usb devices not recognised

18 Apr 2014   #1
Joe Jitzu

Windows 7 Home Premium 64bit..
Win 7 64bit sp1 some usb devices not recognised

Using an Asus X54C laptop intel core i3 win7 64bit home premium sp1. all the sudden, usb ms mobile mouse 3000 v2 quit. It works in any other computer. Logitec wireless mouse that used to work in the laptop plug and play no longer will, these work in other comp. Also the usb external Seagate HD no longer works. Some other things do work in the same usb ports, camera, phone, etc. Leads me to believe it's software issue. I have read every forum and discussion that I can find for a week now. Tried every suggestion imaginable, anyone have another suggestion? thx.
This list is not in the order that I tried repairs, did simple things first. Also tried restoring the sys to one week before the problem began.
Updated bios
disabled legacy usb in bios
device manager admin auth, uninstalled usb hubs, devices and controlers and let win rebuild from cold boot
removed all hidden usb faded devices
took battery out and left with no power several hrs then cold boot
updated chipset
downloaded/installed drivers from ms for the mouse
downloaded/installed drivers from logitec
deleted infchache.1 file then coldboot to let win rebuild it
disabled and enabled usb power management, tried both ways.
ran CMD from prompt as admin, SFC/scannow and let win self test sys files, all were ok
:O help...
Today Win tried to install some drivers, then error pops up and says HP C4385 printer has no driver installed. Tried to let it install but it goes in same loop with error at the end. Wireless printer C4385 spools and works fine? Still have no mouse or some other usb devices as win doesn't see a problem. What the h is going on?

My System SpecsSystem Spec
15 May 2014   #2
Joe Jitzu

Windows 7 Home Premium 64bit..

Help plz, still fighting this issue. Only devices that are self powered seem to work. thx for any help.
My System SpecsSystem Spec
15 May 2014   #3

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64

Wow. You've already tried everything i would think of

This may be a kludge but but if it works... try connecting bus-powered devices to a self-powered USB hub.

Also (just curious) try booting into Knoppix or other Live CD. Are the same usb devices recognized under different OS?
My System SpecsSystem Spec

16 May 2014   #4
Joe Jitzu

Windows 7 Home Premium 64bit..

Thanks so much for the suggestions, I tried a live CD of Knoppix and all usb ports are still the same. This laptop is under warranty from Asus, think I let them take care of it. thanks again.
My System SpecsSystem Spec
17 May 2014   #5

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64

Glad that helped sort it out. And, better still, let ASUS handle it!
My System SpecsSystem Spec
12 Jun 2014   #6
Joe Jitzu

Windows 7 Home Premium 64bit..

Update on failed USB ports, I received my X54C Asus laptop back today from warranty repair. It was a failed mother board, Asus warranty went good for shipping both ways and installed a new mb. Running the Knoppix live CD was an excellent troubleshooting tip. Thanks again.
My System SpecsSystem Spec

 Win 7 64bit some usb devices not recognised

Thread Tools

Similar help and support threads
Thread Forum
Headphones Not Recognised In Playback Devices, Please Help.
Hey, I'm experiencing frustrating issues with my playback and wondered if you guys could help? Basically I noticed when I turned on my laptop that there was no sound coming out of my Headphones, only the speaker. It was in the right jack as there are only two its not that hard to get right haha....
Sound & Audio
USB devices not recognised
Hi, I am running windows 7 ultimate x64, acer aspire laptop 5742. I have 1 USB port that works with whatever i plug into it, the other 2 i have on my computer do not work, one is un responsive and does nothing when you plug anything into it and the other continually recognises and unrecognises...
Hardware & Devices
W7 64bit + XP Mode - DVD RW only recognised as DVD ROM
Hi, Sorry if this has already been dealt with but I can not track down any posts on this topic. Specifically, my Optical Drive is recognised in XP Mode but only to read data and not to write. Is this a limitation within XP Mode or is there likely to be some adjustment needed to my setup? ...
DVD not recognised intermittently by Windows 7 preofessional 64bit
Hi there, I have a Blu-Ray/DVD drive on my PC (its a brans new PC). When I first start windows up the drive genreally seems to be recognised by windows (i.e. I can see it in windows explorer), however at some point windows stops recognising the DVD drive forcing me to restart the PC if I...
Hardware & Devices
USB devices not recognised
Client has the problem on a Gigabyte GA-EP45-UD3LR board using Windows 7/64 Pro with 2 x sata hdd, memory card reader with 4 slots connected to mobo usb socket - card reader working fine when I insert sd card. (mouse/keyboard are ps2) All okay for 11 months, and then for the last 2 she's been...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App