Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Error Message when trying to add Printer

16 May 2014   #1

Windows 7 Professional 64 Bit SP1
Error Message when trying to add Printer

Hello -

I upgraded our Windows XP machines to Win7 Professional 64 bit SP1 machine.

On one machine, I cannot add printers - local or network.

The computer has a printer attached to it, via USB 2.0. Epson WorkForce Professional 645. I have installed the drivers, uninstalled them, downloaded drivers, all to no avail.
When I plug the printer in to the USB port (first time), Win says device was successfully installed. Yet when I go to print, it (printer) does not show up. I go to control panel, and "add a device/add printer" When I click on "Add Printer" I get the message:

"Windows can't open Add Printer. Access is Denied."

Since it is a local, attached printer, it has nothing to do with spooling.

I am logged in as an administrator.

I have not had this on any other computer ((total of 5 computers - all running Win7 Professional 64 bit SP1) all computers have a local attached printer connected via USB, as well as share a common network printer)


My System SpecsSystem Spec
18 May 2014   #2
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

Welcome to Seven Forums sachin528. Sounds like perhaps a permissions issue. Have a look at the suggestion on this thread:

Look at reply by nothingsknower 1st

First step, you have to be able to open up the print server properties. There's probably several ways to get there, but I opened an elevated command prompt (non-elevated didn't work) and ran


You should also be able to run this from the built-in administrators account. Note, there is a substantial difference between running this command as a built in administrator or a user-made administrator... UAC causes your user-made administrators to act as a standard user unless you specifically use their elevated token (like by creating an elevated command prompt)

Second, I went to the Security tab and added "Computername\Users" (substituting "Computername" with the name of my computer). Computername\Users were given the permission to "Print" and "View Server". No other permissions were granted to Computername\Users. Computername\Administrators had full permissions.

Pressed OK, logged out and back in. Printers were then visible again, and the Add Printer Wizard was again accessable.

The exact steps may not work for everyone, but it does appear the permissions here in the Print Server Properties is at the root at least one of the causes of the problem.
The one marked Answer by ErlyRisa may allow you to add a printer, but perhaps not fix the permission issue.

Windows can't open Add Printer. Access is denied. - Microsoft Community

A Guy
My System SpecsSystem Spec
04 Sep 2016   #3

Windows 7 Ultimate x64
Solved:Add a printer driver

Take Ownership of C:/Windows/system32/spool/
My System SpecsSystem Spec


 Error Message when trying to add Printer

Thread Tools

Similar help and support threads
Thread Forum
Lexmark X5070 printer is giving me an error message.
Hello, I have a HP Desktop Windows 7 Professional 32-bit. I tried a new printer and hated it. I reinstalled my Lexmark X5070 and I am having trouble with the reinstall. The actual reinstall went well for the most part. When I try to print content from a website I get an error message. ...
Hardware & Devices
Receiving an Error message ‘Printer is turned off’
My windows 7 pc is connected to network printer. When i give the command of printing via network printer then system prompts a message that printer is turned off and can’t print but reality is that it is turned ON. How to fix the issue?
Installation & Setup
HP 4470 Printer wont install error message (not enough space on drive)
This is the message I get when trying to install a printer. I have 2 hard drives one is a 1 TB w/ 800 GB free, the other is a 300 GB Hard Drive w/ 187 MB free. Yet I get the message that the drivers cannot be installed due to not enough hard drive space? If anyone can help me out w/ this one it...
Hardware & Devices
Error message when installing wireless printer
I am trying to install my printer to my wireless network, but I keep getting an error message that I am not the administrator on this computer. This is my personal computer, so don't know why I would not be the administrator. I did set up a homegroup and add my printer and all my documents, but...
Hardware & Devices
HP Printer Installation Error Message
Hi there, When I attempt to load the HP printer installation software from the disc, I get the message that, "Software cannot be installed using the 'Run as...'" Does anyone have a suggestion? Thanks, Trix
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:23.
Twitter Facebook Google+