Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: OCZ revodrive 3 x2 corrupted after "incompatible" factory driver instl

02 Jul 2014   #1

windows 7 64 pro sp1
OCZ revodrive 3 x2 corrupted after "incompatible" factory driver instl

HD workstation down due to installation of "incompatible" driver yesterday.

this is a 9 grand box which has never been connected to internet with no updates since original win 7 64 pro sp1

It has an Atechflash pro 57U CF card reader (great device) which stopped reading my 1000x CF cards
so i proceeded to Atechflash to download the latest drivers (taken down on their site today after my crash!)

installed without problem and rebooted, then I installed the icon driver which was supposed to show an icon for each type of media inserted and i previously did not have, asked for reboot. and then HANGED.

when I called tech support, they said that the two drivers (sitting next to each other for this device on their page) are "incompatible" WTH?

Restarted computer, after MS animation video cuts out and monitor shuts down.

restarted in safe mode F8F8, was able to see the initial driver not the "second icon driver" installation,

uninstalled the device driver

tried normal boot, same problem

rebooted second time to safe mode F8F8 to hunt for icon driver, could not find it.

3rd reboot, and it will not safeboot now, I get a black screen with the pointer and no menu

tried restore point, did not work (can not remember why, long day yesterday)

tried "last settings that worked", did not work

tried "startup repair" and it does not see the ocz revodrive c: nothing in system recovery options work due to c: drive not loaded

I don't see any operating system to choose for recovery, get an error when trying "restore your computer to an earlier time" or "use recovery tools,...."

startup repair has a detail link, it shows that the MBR needs repair (if i remember correctly, computer is 100 miles away till Sat) AND wants to reboot to "repair mode RECOMMENDED"

so I let is do its repair and boots back to same menu, i read online that it takes a few tries for MBR, so i did this 10 times then gave up. Since c: drive does not show i am not sure what it is repairing.

downloaded 32 and 64 bit drivers for the drive from OCZ and tried "load drivers" button, but no matter which of the files (tried all) I click it says that there is no information about the hardware in the driver

next i loaded the MS recovery disk i made last month, it shows the same menus that are in the startup F8F8 routine, still no c: no difference than the startup menu F8F8 (c: drive is active to show these repair menus...)

tried Hiren and spotmau to get to c: but they don't list it, do not know how to load the OCZ driver before these programs load.

the drive is in the asrock bios and I am sure working fine as before I installed the faulty icon driver

any suggestions you code rockers?

My System SpecsSystem Spec
03 Jul 2014   #2
Anshad Edavana

Windows 7 Ultimate x64


I never had a chance to configure a PCI-E based SSD card. However i guess configuring it will be similar to a RAID card.

Please try the below steps.

1. Download driver corresponding to your model from Download OCZ Drivers

There is driver for RevoDrive 350 , RevoDrive 3 and RevoDrive 3 x2 , RevoDrive and RevoDrive x2 , RevoDrive Hybrid models listed. make sure to download the right one.

2. Extract the zip and inside you will find two folders - i386 and AMD64. Since your OS is 64 bit, copy the AMD64 folder to a flash drive and plug in to the system.

3. Boot from Windows setup disk and choose "Repair your Computer" option. Select "Load Drivers" option and use the browse button to choose the inf file inside the "AMD64" folder.

Hopefully Windows setup will be able to detect your HDD. Then you can perform either "System Restore" or "System Image restore".
My System SpecsSystem Spec
03 Jul 2014   #3

windows 7 64 pro sp1

Anshad, correct answer!

I was thrown off by the name AMD64 since i have intel under the hood
and was trying to load the intel32 drivers, stupid naming if you ask me.

just call the drivers for what they are.

was able to restore to before the incompatible driver install and now logged back in.

Thank you for your answer
My System SpecsSystem Spec

03 Jul 2014   #4
Anshad Edavana

Windows 7 Ultimate x64

Glad to hear that. Hope that you won't face similar situation again .
My System SpecsSystem Spec

 OCZ revodrive 3 x2 corrupted after "incompatible" factory driver instl

Thread Tools

Similar help and support threads
Thread Forum
"Repair Your Computer" option not working (restoring factory backup)
I have a Dell Studio 1440 with Win 7 home premium 64bit. I want to use the built-in recovery but after pressing F8, I click on Repair Your Computer and Windows 7 begins to load instead of going to the recovery GUI. I am trying to restore the system to it's factory settings and it had worked...
Installation & Setup
No BSOD. Endless startup repair loop. "ntoskrnl.exe corrupted"
I can't get Windows to load properly. Can't get into any safe modes. Just the startup repair screen, over and over. It tells me that there are no system restore points. I have tried copying the ntoskrnl.exe from another Win 7 computer. I have tried the "How to get out of the endless system repair...
BSOD Help and Support
Login screen and "User Account Control" Dialog Corrupted
After a clean install of Windows 7 and installing both current NVidia (GeForce 7800GS AGP) drivers and monitor driver (ACER W223X) I was able to get Windows & to run in my monitor's native resolution (1680x1050) but no matter what resolution I run in I get some weird effects. When in the 'Login...
General Discussion
"Return computer to factory condition" or "Use A System Image Crea..."
Which one should I do? I originally wanted to just do "Return computer to factory condition" but Theog just suggested "Use A System Image Created Earlier." I have no idea what to do. So confusing! :confused:
Backup and Restore
Windows 7 "Incompatible" Driver Blocking
I have been having a problem for about a few months now. Whenever I reboot windows the usb and networking drivers wont load, they are "Blocked from loading due to incompatibility". It's really starting to annoy as i have to go into device manager and disable/re-enable them to make them work right....
BSOD with "usbhub.sys" and "driver power state failure"
I have been getting the BSOD since a few weeks and found out by trial and error that a USB-hub is causing the problem. Whenever I disconnect the hub before I shut off the computer I do not get the blue screen. Yesterday I also got a BSOD that mentioned driver power state failure. After I had...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App