Hard Drive Doesn't Mount Its self on Boot


  1. Posts : 12
    windows 7 64bit
       #1

    Hard Drive Doesn't Mount Its self on Boot


    Hi all,
    Suddenly got a strange problem with my Hard drive, it's a seagate 500gb, suddenly whenever i boot to my OS, my second hard drive isn't mounting its self a drive letter, so therefore i can't see it in 'my computer',
    but then if i go to disk management, assign it a letter like Local Disk (D), i can see it again and all my files are fine,

    Not sure why this is happening, happened on windows 8, then upgraded to 8.1, still didn't fix it, and now it's happening on my windows 7, fresh install

    Could be my hard drive giving up?

    Thanks
      My Computer


  2. Posts : 12
    windows 7 64bit
    Thread Starter
       #2

    bump
      My Computer


  3. Posts : 7,024
    Windows 7 Home Premium 32 bit
       #3

    Check whether this resolves your problem

    open command prompt
    type in diskpart automount enable and press ENTER
      My Computer


  4. Posts : 12
    windows 7 64bit
    Thread Starter
       #4

    still no luck, that command didn't help, whenever i reboot it just doesn't assign its self a letter, when i assign it, i can see it.
      My Computer


  5. Posts : 7,024
    Windows 7 Home Premium 32 bit
       #5

    OK, just to make doubly sure, give only the command automount, does it say "Automatic mounting of new volumes enabled" ?(Run Command Prompt as an administrator)

    Hard Drive Doesn't Mount Its self on Boot-07-07-2014-07-35-23.jpg

    If yes, then do a drive clean up as recommended here https://www.sevenforums.com/general-d...ml#post2821973 and check whether it resolves the problem
      My Computer


  6. Posts : 12
    windows 7 64bit
    Thread Starter
       #6

    Hi, thanks for the reply, still no luck, I've ran the command twice both successfully automounting results, but still the hard drive will not appear unless i assign it a letter

    Click on broken links for images, can't get images to work properly yet




    This is what my computer is like on boot up,
    The 64GB being my SSD, and my 500GB not appearing


    Now when i assign it a letter,



    But unless i assign that letter, i can't see it in my computer.
      My Computer


  7. Posts : 7,024
    Windows 7 Home Premium 32 bit
       #7

    I now presume that that 500GB drive is an internal drive and since you said it had happened in Windows 8, 8.1 and now 7, it may have something to do with how your drives are connected to your motherboard ports/ controllers.

    Please wait for someone conversant with such problems to help you. You may need to fill in your complete system specifications. System Info - See Your System Specs

    Also upload your screenshots to Seven Forums servers Screenshots and Files - Upload and Post in Seven Forums

    Please restate your problem with full details with a screenshot of Windows Disk Management so that it catches their eyes and attention.. ( I was under the impression that it was an external drive. Looks like I put my finger into a wrong pot. )
      My Computer


  8. Posts : 59
    Windows 7 Pro 64-bit
       #8

    Weekend morning my Windows 7 computer got the same issue when boot.

    did google, the problem primarily happens on a dual-boot system. a bootloader issue.

    Hard Drive Doesn't Mount Its self on Boot-image.png

    My Win7 system is NOT running dual-boot. however, in my recent install tests, I loaded various (good or bad) drivers to test. that should be a problem. hence I restored the OS from a backup one month ago.

    It's fine now.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:22.
Find Us