Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Printer uninstalled; can't reinstall; older drivers found

01 Aug 2014   #11

Windows 7 Professional 64bit

Hello again,

This is where I stand. I've tried every suggestion. Using Driver View and Installed Drivers List, I can't find anything even close. Nothing by Canon, nothing labeled mp-anything, nothing for printers. Except there is microsoft's usbprint.sys which I think is a generic usb printer driver and I haven't uninstalled it. Should I?

The deldrv link was for 64-bit. My primary machine is indeed 64-bit but the problem one is 32. I've used the del driver exe included in the mp130 installation package. It runs like it's doing something but nothing changes.

I tried the clean start up with no results; I've never thought it was a start-up problem. On a whim I tried booting to safe mode. The printer actually showed with the yellow triangle thingy. But troubleshooting said there were no drivers and nothing it could do. So no joy there

The MMC shows nothing under print management; no drivers at all.

This has used way too much of my time and a chunk of time from several of you for which I'm grateful. Barring an amazing revelation, I think it's time to just get a new printer.

I'll wait a day or so and close this thread. "Can" I close it without marking it solved?


My System SpecsSystem Spec
01 Aug 2014   #12

Windows 7x64 Home Premium SP1

Quote   Quote: Originally Posted by Gorham View Post
My primary machine is indeed 64-bit but the problem one is 32.
You could look in
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-3

I personally wouldn't mark the thread solved. Others will probably stumble across this thread with a similar problem and the problem has NOT been solved.
My System SpecsSystem Spec
02 Aug 2014   #13

Windows 7 Professional 64bit

I'm not sure what I'm looking for in that registry key. There's no mention of driver or DLL. I have
(Default) REG_SZ (value not set)
Directory REG_SZ 3
MajorVersion REG_DWORD 0x00000003 (3)
MinorVersion REG_DWORD 0x00000000 (0)

I did also want to ask if anyone had any reaction to my threat (plan?) to delete some or all of the keys that reference the MP130 in my original regedit search.

Thanks for your other comment. I wasn't going to mark it solved; as you say, it hasn't been. But I was going to hunt around and see if I could close it. I won't now. You're right; someone may come along and have a notion.

Meanwhile I think I have a Caveat Emptor to report. Whilst trying to solve the problem a Canon support site (at least it purported to be) sent me to a software program called DriverTuner. I ran the scan and it looked like it might have something so I took a chance on their 7-day subscription ($5). I did have presence of mind enough to download the drivers to a directory of my choosing and not to install them. When I tried to view properties for each download, I couldn't tell what it was and, even though I had a registered version, the properties were loaded with DriverTuner verbiage and also a section that said this was the unregistered version, steering me toward the website again.

I also discovered, through my check of the PayPal charge, that they'd set this up as a monthly ($30) subscription. There was no mention on the registration page that there were strings attached. I cancelled the subscription and will check again to be sure it stays cancelled. I just checked; it's still inactive (cancelled). Phew.

I should mention here that the website promises "We will refund to our users if they are dissatisfied with a product purchased from LionSea and request a refund within 60 days after the purchase." Well maybe not so much. I sent an email just requesting the promised refund and have received a reply saying they'll give it but not until they try to "help" me. I suspect I'll just eat the $5 and walk away.

This warning should probably be somewhere else but it directly obtains to this thread so I've put it here. I don't usually double post but it it should also be in another thread, I'd be happy to do a bit of civil disobeying.

Everyone already knows it but this is a wonderful place and I'm very grateful for it.


My System SpecsSystem Spec

02 Aug 2014   #14

Windows 7x64 Home Premium SP1

Quote   Quote: Originally Posted by Gorham View Post
I'm not sure what I'm looking for in that registry key.

@Gorham this may not help your situation but to make it clear anyway -
Here is the quote from the link I gave you:

You can actually "remove" corrupted print drivers that won't uninstall for whatever reason by deleting the registry key for them. This trick works regardless of version, so it will work on Enterprise as well as Home Premium.
Open Registry Editor (Start-Regedit), and navigate to the following key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Drivers\Version-3
To "remove" the driver, just delete the key for the driver that is giving you issues. When you re-install the driver, it will think that the driver is not installed and will overwrite everything cleanly.

Here are the corresponding keys (registry tree nodes) for my particular system
Printer uninstalled; can't reinstall; older drivers found-capture.jpg

I have never personally needed to delete any of these keys to overcome a driver re installation problem but if all else failed I would consider this option. I would only try it after taking precautions...
For me I would only touch the registry as a last resort and only after I have backed up the registry
Registry - Backup and Restore
Made a system image.

You asked for advice on deleting other registry entries. I would NOT unless you know exactly what you are doing.

My System SpecsSystem Spec

 Printer uninstalled; can't reinstall; older drivers found

Thread Tools

Similar help and support threads
Thread Forum
PDFs Only Print to Uninstalled Printer???!!
Vista Business SP2 formerly had Dell Photo AIO 926, but uninstalled then ran patch from Dell to completely uninstall. Only printer connected is HP. When trying to print from and PDF program, the only option is the Dell which no longer exists! Even hand-picked through registry, ran cleanup...
accidentally uninstalled atheros from my computer how to reinstall it
Hi guys, Accidentally i uninstalled my atheros driver from my computer,and not able to connect any wireless network. How to re-install atheros driver back in my computer. My model or version is AR8152/8158PCI-E.Please its urgent! My laptop is Lenovo G570 and model name is 4334...
Uninstalled video driver but now need to reinstall
Hi all, I recently uninstalled my video driver as it was causing my computer to freeze. I am now wanting to reinstall it however I cannot remember the model so do not know what to download from the geoforce site. I have scanned for hardware changes in device manager but nothing comes up. I...
Graphic Cards
How should I reinstall printer/drivers?
Just went from XP to a new Dell W7. I have a multi-function printer that used CD drivers on XP, but with W7, I had to install the printer with Windows Update and a scan utility from the manufacturer's web site. All of a sudden after a month, I can't scan, so I want to uninstall/reinstall the...
Cannot reinstall the driver after I uninstalled it (NVIDIA)
Hello! I really need help, because I just uninstalled my Nvidia 9400 Drivers. I was trying to install the newest drivers, because Battlefield asked me to do so, so I downloaded them, but they couldn't be installed, I was getting this error: "The graphic driver cannot find compatible graphics...
IE8 Uninstalled, can't reinstall.
I uninstalled IE8 through the control panel a number of weeks ago. I wish to download and install it again, but I cannot. Why? How can I get IE8 back?
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:03.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App