Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Printer uninstalled; can't reinstall; older drivers found

29 Jul 2014   #1

Windows 7 Professional 64bit
Printer uninstalled; can't reinstall; older drivers found

Windows 7 32-bit, Canon MP130 USB printer

Yesterday, suddenly, my printer was greyed out. Here's the sequence of actions I took (each unsuccessful):
1. Checked cable connections at both ends.

2. Replaced cable.

3. Checked device manager; it showed there.

4. Checked drivers.

5. Ran troubleshooting; nothing found.

6. Uninstalled printer using Revo Pro.

7. Downloaded software from Canon; started trying to reinstall but got this message.
Older MP Drivers Found!
MP Drivers The program has found an older version of the MP Drivers
already installed. Uninstall the older version and then execute the
setup program again.
8. Tried to find the "older drivers" but can't.

9. Ran search on the C drive (a daunting task)
First time through, I got an expanding pyramid of MP130 entries in a loop from AppData\temp and leading to a non-existent file. I got rid of that - I think - but still couldn't install.

Ran the search again; the loop is gone but now there aren't any search results other than the download I'm attempting to install.
10. Searched the registry:
HKCU\Printers: (string value) DeviceOld REG_SZ Canon MP130 Series Printer,winspool,Ne03:

HKCU\Printers\Settings: (binary) Canon MP130 Series Printer REG_BINARY 07 00 00 00 0d 00 0b 00 03 00 14 00 15 00 10 00 02 00 and 00s as far as the eye can see

HKCU\Software\.. a series of entries for my graphics program showing the
MP130 as printer

HKCU\Software\Microsoft\Windows\PhotoPrintingWizard\Canon MP130 Series

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\PhotoPrintingWizard\Canon MP130 Series Printer DriverName Canon MP130 Series Printer

HKCU\...\Windows\...\Compability Assistant\Persisted... and a reference to my download

HKLM\Software\Canon\Manual_Path\Canon PIXMA MP130 Series but then the string value is (Default) (value not set)

HKLM\Software\Canon\MSetup4\Canon_MP\ a string value showing PIXMA MP130 Series as printer

HKLM\Software\Canon\MsetupLog\ (string value) Name Canon PIXMA MP130 Series

HKLM\Software\Microsoft\Windows\CurrentVersion\Setup\PnpLockdownFiles Name: %SystemPath%\twain_32\MP130\CANOIT32.EXE Type:REG_DWORD Data:0x00000005 (5)

HKLM\Software\Microsoft\Windows\CurrentVersion\Setup\PnpLockdownFiles Name: %SystemPath%\twain_32\MP130\CISDS.DS
.... and a whole list of similar keys, all with the same data value:
HKLM\ControlSet001\Control\DeviceClasses\{28d78fad-5a12-11d1-ae5b-0000f803a8c2}\##?#USB#VID...(bunch of characters)\#\DeviceParameters PortDescription Canon MP130

HKLM\ControlSet01\Print\Monitors\Canon BJ Language Monitor MP130 Driver CNMLM62.DLL

HKLM\ControlSet01\Enum\USB\VID 04AA9&PIID_170&MI_00\6&159c15e6&0&0000 DeviceDesc MP130

HKLM\ControlSet01\Enum\USBPRINT\CANONMP130 Default (value not set)

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USBPRINT\CanonMP130\9&108f4615&0&USB001 DeviceDesc CanonMP130

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USBPRINT\CanonMP130\9&108f4615&0&USB001 HardwareID USBPRINT\CanonPM130423F CanonMP130423F

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\DeviceClasses\{28d78fad-5a12-11d1-ae5b-0000f803a8c2}\##?#USB#VID_04A9&PID_1701&MI_01#6&159c15e6&0&0001#{28d78fad-5a12-11d1-ae5b-0000f803a8c2}\#\Device Parameters PortDescription CanonMP130

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Print\Monitors\Canon BJ Language Monitor MP130 Driver CNMLM6S.DLL

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Enum\USB\VID_04A9&PID_1701&MI_00\6&159c15e6&0&0000 DeviceDesc MP130

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Enum\USBPRINT\CanonMP130 (Default) (value not set)

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Enum\USBPRINT\CanonMP130\9&108f4615&0&USB001 DeviceDesc CanonMP130

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Enum\USBPRINT\CanonMP130\9&108f4615&0&USB001 HardwareID USBPRINT\CanonPM130423F CanonMP130423F

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceClasses\{28d78fad-5a12-11d1-ae5b-0000f803a8c2}\##?#USB#VID_04A9&PID_1701&MI_01#6&159c15e6&0&0001#{28d78fad-5a12-11d1-ae5b-0000f803a8c2}\#\Device Parameters PortDescription CanonMP130

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Canon BJ Language Monitor MP130 Driver CNMLM6S.DLL

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\VID_04A9&PID_1701&MI_00\6&159c15e6&0&0000 DeviceDesc MP130

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBPRINT\CanonMP130 (Default) (value not set)

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBPRINT\CanonMP130\9&108f4615&0&USB001 DeviceDesc CanonMP130

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBPRINT\CanonMP130\9&108f4615&0&USB001 HardwareID USBPRINT\CanonPM130423F CanonMP130423F

HKEY_USERS\.DEFAULT\Printers\DevModes2 Canon MP130 Series Printer and a long binary

HKEY_USERS\S-1-5-21-1857497657-2102476093-3286847399-1000\Printers DeviceOld Canon MP130 Series Printer,winspool,Ne03:

HKEY_USERS\S-1-5-21-1857497657-2102476093-3286847399-1000\Printers\Settings Canon MP130 Series Printer and a long binary

HKEY_USERS\S-1-5-21-1857497657-2102476093-3286847399-1000\Software\Jasc\Paint Shop Pro 9\General\Miscellaneous PrinterName Canon MP130 Series Printer

HKEY_USERS\S-1-5-21-1857497657-2102476093-3286847399-1000\Software\Jasc\Paint Shop Pro 9\JascCmdPrint\QuickPrint\PrintingOptions PrinterName Canon MP130 Series Printer

HKEY_USERS\S-1-5-21-1857497657-2102476093-3286847399-1000\Software\Microsoft\Windows\CurrentVersion\Explorer\PhotoPrintingWizard DefaultPrinter Canon MP130 Series Printer

HKEY_USERS\S-1-5-21-1857497657-2102476093-3286847399-1000\Software\Microsoft\Windows\CurrentVersion\Explorer\PhotoPrintingWizard\Canon MP130 Series Printer DriverName Canon MP130 Series Printer

HKEY_USERS\S-1-5-21-1857497657-2102476093-3286847399-1000\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Compatibility Assistant\Persisted reference the download
...aside... Was there a way I could export the registry filtered for my search?

So here I am. The totally unhelpful message continues to appear and I have no idea what to do next. I did find a few references to drivers and I've made them bold but I didn't dare do anything with them.

Sorry if this is too much information; suggestions as to how I might have done it better will be most welcome.

Even more welcome will be some pointers for me to follow.

Thanks much.


My System SpecsSystem Spec
29 Jul 2014   #2

Windows 7 Professional 64bit


I went in and viewed hidden devices. I think I've found a possible clue but I don't know what to do about it. Under "Other devices" I have CanonMP 130 with a circled question mark; and MP 130 with the yellow exclamation point. Then down under "Universal Serial Bus Controllers" I have an Unknown Device with the yellow exclamation point. I each case no drivers are associated with the item. I uninstalled them through the device manager but when I scanned for hardware changes, they came right back.

I'm continuing to work on this on my own but I'm really way beyond my own expertise now.

Again, thanks for any help.

My System SpecsSystem Spec
29 Jul 2014   #3

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1

Uninstalled printer using Revo Pro=>why using Revo PRO?
Can you revert the changes? For example using "system restore". See System Restore
My System SpecsSystem Spec

29 Jul 2014   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1

My System SpecsSystem Spec
29 Jul 2014   #5

Windows 7 Professional 64bit

Oh wow! Surely should have tried that early on. I won't be back at that computer until tomorrow but I'll have a look at when an appropriate restore point might have be set. I'll report back than. Thanks much.
My System SpecsSystem Spec
30 Jul 2014   #6

Windows 7 Professional 64bit

Well, yes I should have thought of it but, no, it didn't work.

This is a computer used almost exclusively for word processing and web browsing. Little software activity so the only restore points I found were one automatically generated by windows and several generated by windows update. I chose the auto-generated one because it was created whilst the printer was still functional and had ramifications I could easily deal with.

The first time, it went through the process but after reboot, I got the message that the restore had not been completed; it suggested perhaps my anti-virus was to blame.

So I disabled the AV and tried again. It failed again and this time I thought to note the error number: 0x80070005

So I'm still stymied on two fronts. First, I can't get the stupid "older" drivers off that machine so I can do a fresh install of the printer. Second, I have no idea what caused the grey-out problem to begin with. There was no software installed or uninstalled and the printer had been working at the last session.

Anyway, the workstation user is saying this is an old printer and it might be easier in terms of time and effort to just get a new printer, especially since nothing fancy is required.

What say all of you?

My System SpecsSystem Spec
30 Jul 2014   #7

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1

Try Troubleshoot Application Conflicts by Performing a Clean Startup and do a "system restore" from clean startup. Maybe that works (?)
Any NORTON software on that machine?
My System SpecsSystem Spec
30 Jul 2014   #8

Windows 7 Professional 64bit

I should have mentioned I did try the driver uninstall program in the Canon software. It said it was uninstalling (something) but it didn't change anything. No, maybe it's no longer true but, from 'way back when, I won't let Norton products anywhere near the machines I manage. I'll think about the clean startup but thing is, everything (including the printer) worked four days ago and nothing has changed. But it can't hurt to try. Maybe. I'll study that page. Thanks.
My System SpecsSystem Spec
31 Jul 2014   #9

Windows 7 Home Premium 32bit

Give Nir Soft's driver view a run,it is an excellent tool for listing,etc, all installed drivers.Just google DRIVERVIEW.exe.
My System SpecsSystem Spec
31 Jul 2014   #10

Windows 7x64 Home Premium SP1

You can have a look at this
Completely removing Windows Vista/Windows 7 Printer Driver in MMC
The first comment suggests a registry key delete option. Before changing the registry I'd back it up and/or make a system image.
My System SpecsSystem Spec

 Printer uninstalled; can't reinstall; older drivers found

Thread Tools

Similar help and support threads
Thread Forum
Accidently uninstalled GTX670 drivers, now hardware cannot be found
Hello all I received noticed of a new update for my GPU. Normally I click 'custom install' as to avoid installing any of the 3D drivers since I had no need for them. Without thinking, I hit 'express install' and ended up installing all of the new drivers. After the install was complete, I...
Graphic Cards
FF 39.0.3 won't allow reinstall of uninstalled DnG search engine.
Hi, FF 39.0.3 won't allow reinstall of uninstalled DnG search engine. I previously uninstalled DnG search eng several mo ago. Now I tried to install DnG, in FF 39.0.3 and FF said it was already installed. My question is: How do uninstall an add on that has been previously uninstalled so I...
Browsers & Mail
Uninstalled video driver but now need to reinstall
Hi all, I recently uninstalled my video driver as it was causing my computer to freeze. I am now wanting to reinstall it however I cannot remember the model so do not know what to download from the geoforce site. I have scanned for hardware changes in device manager but nothing comes up. I...
Graphic Cards
How should I reinstall printer/drivers?
Just went from XP to a new Dell W7. I have a multi-function printer that used CD drivers on XP, but with W7, I had to install the printer with Windows Update and a scan utility from the manufacturer's web site. All of a sudden after a month, I can't scan, so I want to uninstall/reinstall the...
IE8 Uninstalled, can't reinstall.
I uninstalled IE8 through the control panel a number of weeks ago. I wish to download and install it again, but I cannot. Why? How can I get IE8 back?
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:49.
Twitter Facebook