Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WD extrnl drve not initialized in disk mgmt not shown in my comp

07 Aug 2014   #1

Windows 7 Ultimate 32 bit OS
WD extrnl drve not initialized in disk mgmt not shown in my comp

WD MyPassport 07a8 nt initialized in disk mgmt & nt shown in my comp.500GB Extrnl hrd dsk drive. its 90% used. Recommend a quick solution please.
Tried Ease US but its not detecting my hdd.
Tried updating driver uninstalling driver then replugging but no luck.
I am quite afraid about getting back my data.
I need to recover my data.
Please help me out

Attached Images
WD extrnl drve not initialized in disk mgmt not shown in my comp-my-screenshot.png 
My System SpecsSystem Spec
08 Aug 2014   #2


Hi there, this drive is power fed trough the USB cable. So if the cable is damaged or too long it could cause the drive to malfunction. Otherwise it could be a damaged partition or a failed drive. I hope it will be a power issue, as it will be easier to resolve.
Have you tried:
- using a different USB cable (the shorter the better),
- connect it to a different usb port on the PC and make sure all other usb fed devices are unplugged at the time;
- if it's a desktop make sure to use a usb port that is on the back of the PC.
- connecting it to a different PC with a different OS

It will be useful if you give a bit more information. Can you hear any unusual noises from the drive? Have you dropped it recently? Do you remember making any changes before it stopped working ?
You can also check this topic: FAQ: External hard drive no longer shows up in My ... - WD Community

Hope that helps and don't forget to share how it goes
My System SpecsSystem Spec

 WD extrnl drve not initialized in disk mgmt not shown in my comp

Thread Tools

Similar help and support threads
Thread Forum
Disk Mgmt ask to initialize a drive that isn't there.
Every time I open Disk Management is asks me to initialize a drive that isn't even there. I connect a bad drive as a slave, and it wouldn't initialize. now every time I open Disk Mgmt, it asks me to initialize the drive. I figure it is something in the registry I need to delete, but not sure of...
Hardware & Devices
Disk 1 Unknown, Not Initialized
Hi, My DVD Recorder died, so I took out the HDD Seagate DB35.2 and plugged it in my laptop. I get the above message in disk management. I also tried Knoppix 7.0 but the disk does not show up. My scope is to save the content in the disk and move it to my PC, is it a mission impossible? Any...
Hardware & Devices
Disk Not Initialized Msg. Meaning Of ?
Hello, Trying to get an old external HD working. Msg. that come up is that the Disk is not initialized. Gives me the option of doing so. What does not initialized mean, exactly, please ?
General Discussion
Desperetly Need HELP : My new 3 TB WD Shows as only 2 TB in Disk Mgmt
Hi, ( I have spent 2 days for finding a solution but no help ) I just bought the new Western Digital 3.0 Internal HDD & when I plugged in as a slave drive it shows only 2 TB in Device Manager. It is also asking me to initialize the drive as either MBR OR GPT. I...
Hardware & Devices
Disk not initialized message
I have used a hard drive disk for 3 years or so and today when booting I see its not showing and I get a message from disk management that it is not initialized although as I say its been running perfectly all this time and was so reliable that I placed all my "needed program and file on it" ...sad...
General Discussion
Bringing a HDD online in Disk Mgmt does what to the MBR of that drive?
I needed to copy files between two PCs and didn't have a USB big enough so I took the HDD out of my Dell Vista laptop and used it as an external drive to transfer the files I needed moving. When I connected it up to the destination PC running windows 7, the drive couldn't be seen in explorer. I had...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:05.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App