Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB3 malfunctions with AsRock mobo

09 Aug 2014   #1

Windows 7 Ultimate x64
USB3 malfunctions with AsRock mobo


I bought this computer a few years back for photo editing. One of the primary features that I wanted was USB3 support because I often have to unload my camera's huge memory cards on my PC. I bought a cheap AsRock motherboard with USB3 support and a Transcend USB3 card reader.

The problem is that the USB3 transfers rarely work. Just today I was trying to transfer files from the memory card but the transfer froze right at the beginning and the speed showed up as ~200 bytes/second. I tried to cancel the transfer but eventually had to reboot the computer because it just didn't stop.

I then wen't ahead and uninstalled AsRock XFast USB to see if it was the cause of the problems. This time the transfer kind of worked but only with speeds varying from 4 to 12 MB/s. The transfer also froze every now and then and then continued as if nothing had happened.

After that I switched the card reader to a USB2 port and all the files were transferred quickly with a speed of 20-30 MB/s without freezes.

I have made sure that my drivers and XFast are up to date. Often the problem goes away if I re-install them both but soon the same problems start again. Does anyone know what could be the source of the problem here? I'm a little disappointed with AsRock as I bought this specific mobo just because of its USB3 capabilities.


AsRock B75M-GL
Intel i7 2600S
Kingston 8GB 1333MHz DDR3
450W PSU
Windows 7 x64

My System SpecsSystem Spec
09 Aug 2014   #2

Windows 10 64 bit

I have an ASRock motherboard (Z77 Professional Fatal1ty). It has two USB3.0 controllers, according to what is installed in the USB, "Etron" and "Intel". Xfast is included with the ASRock install disc but I never installed that. USB3.0 works OK.

Attached Thumbnails
USB3 malfunctions with AsRock mobo-capture.jpg  
My System SpecsSystem Spec

 USB3 malfunctions with AsRock mobo

Thread Tools

Similar help and support threads
Thread Forum
mobo: biostar or asrock
im planning which to choose from biostar h61mgv3 or asrock h61m vs r2.0 i dont care much about prrformance, i care more in reliability and durability im not much of a hard core gamer. but i play atleast 5-8hrs a day. which board is better spec pentium g2020 4gb ddr3 1333 ram 500watt psu
Hardware & Devices
Choosing RAM for ASRock 880GMH-LE/USB3 MB
I apologise if this question has already been asked (there are >800 pages in this sub-forum). How can I tell if I can fit a given brand/model of RAM to my ASRock 880GMH-LE/USB3 MB? I currently have: 4 GB DDR3 1333 G-Skill (F3-10600CL9-2GBNT, 2x2 GB)This RAM isn't listed in the manufacturer's...
Hardware & Devices
USB3 card for Mobo (W7 drivers ??)
Hi there I've been so amazed with the USB3 performance on my Laptop that I really would like to get a USB3 card for a desktop running Windows 7. So questions for people running USB3 devices on Windows 7 (not Windows 8). The Mobo itself doesn't have native USB3 connection so I'd have to...
Hardware & Devices
Mixing graphics cards on (ASRock M3A770DE) mobo
Morning all, could anyone tell me whether it would be ok to run a Nvidia 7800GT and Nvidia 9500GT graphics cards side by side, safely on this mobo. Obviously i do not intend to run in SLI mode, i just want to run 4 monitors from all four outputs. Thank you in advance
Graphic Cards
Mixing memory chip sizes on ASRock M3A770DE mobo
Mrning all, Could any one tell me whether it would be ok to mix memory chip sizes on my mobo. currently i have 4gb of ddr2 in one slot. would it be ok to add something like CORSAIR 4GB (2x2GB) XMS3 DDR3 1600MHz, in memory slots 2 and 3, leaving slot 4 free for when i can possibly afford...
Hardware & Devices
asrock mobo / usb2
Hi all I have an asrock 775dual-VSTA and I recently upgraded to Windows 7 Ultimate, 32bit. Things seemed fine, but I realized my USB was performing very slowly. For example, it takes hours and hours just to upload a few albums to my iPod. I presume it's a motherboard driver problem....

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App