Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB 3.0 Occasionally not functioning

18 Aug 2014   #1

Windows 7 Home Premium x64
USB 3.0 Occasionally not functioning

Hi all,
I'm using an Asus A53SV laptop running on Windows 7 Home Premium 64x

Occasionally when I start my laptop, I'll find the USB 3.0 not functioning. I would plug a USB hub as there's not enough USB ports for all my devices. Whenever the USB 3.0 is not working, I would use the driver from Asus driver website to repair the driver function. After the repair, the port would work again, but will need to reinstall all the devices attached to the port.

My question is, why is this happening?

My System SpecsSystem Spec
18 Aug 2014   #2

Window 7 Home 32bits

Anyone know what is happening? I have same problem also. Thanks.

Business English
My System SpecsSystem Spec
20 Aug 2014   #3

Windows 7 Home Premium 64bit

Unlike USB2.0, Windows dont come with built in driver for USB3.0. There are different brands of USB3.0 controllers like Renesas, NEC. So Windows wants the user to install the Driver for the USB3 Controller that is attached. Driver is loaded only at "Starting Windows screen". If the driver doesnt get loaded, the problem occurs.
In my case,
USB 3.0 Occasionally not functioning-dddd.jpg
If I end this process, two out of my three USB3.0 ports fails to work.
So before reinstalling driver, make sure driver is loaded or not. Restarting may bring back the driver to life.

My System SpecsSystem Spec


 USB 3.0 Occasionally not functioning

Thread Tools

Similar help and support threads
Thread Forum
ICS - No longer functioning.
My setup: Windows 7 Home 64bit - quad CPU - 8GB ram - Available Virtual memory 14GB NIC 1 Internet - trying to re-setup ICS NIC 2 XBOX360 What happened recently: Everything worked fine with ICS, however I wanted a router with wire + wireless connections so I could use the wii and DS...
Network & Sharing
OS not functioning(Crashed)
Hi, I have an issue with my laptop.Few weeks back i had formatted my machine with an operator and recently its not working.The OS is not opening up ,its directly taking me to Set up.I again checked it out with an operator and he tried booting with a cd but can not view the files in my C:,D:...
General Discussion
Java not functioning.
Several times I have installed/reinstalled java but Win 7-64 Home Premium does not allow this to run. Programme is installed but applications, e.g. ping test speed test are reporting Java requires to be installed. Any assistance appreciated. Thanks.
CD Drives Not Functioning
I installed Win 7 Home Premium and I am having trouble spinning up my CD Drives (both of them). They were working under Win XP... If I attempt to install a game, the CD does not spin up. HELP!!! Dell Computer XPS 400 2.83 GHz Dual Processors 3.00 GB Ram Nvidea GeForce GTX 500TI Video Card
Hardware & Devices
UAC not functioning as expected
My apologies if this is not the correct forum for this question/issue. We have several Windows 7 professional systems. Most of them function as expected, however we have a few that do not. Case in point: We have two windows 7 pro 32bit systems that have the same identical setups, same...
System Security
Blu-Ray Drive Not Functioning
Should there be an Optical Drive section on this forum? Just a suggestion. Anyway, has anyone gotten ANY Blu-Ray drive to work in Win 7 64-bit yet? I've got the LG GGC-H20L Blu-ray/HD combo and I was at least able to get the drive to lose the caution/warning symbol in the device manager thanks...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:27.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App