Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: External USB2 drives "disappeared" from the computer explorer window

01 Sep 2014   #1

Win 7 Pro x 64
External USB2 drives "disappeared" from the computer explorer window

I have four external usb drives. All seem to have disappeared at the same time. I checked one of them on another computer and it's fine. There's no error \ in the device manager, except it said that the device on one port had failed. I disabled that but left it plugged in because I don't know how to tell which physical port corresponds to the info show by Windows. Rebooting doesn't help. The usb bus appears ok because it will charge my ipod, although if I plug in a thumb drive, that's not seen by windows either.

The only thing new I did before noticing this is I was trying out cleanmgr I(from the cmd window as administrator) and I ran cleanmgr /setup hoping there would be a screen saying what it does. There was not, and there was no visual response to running it.

There's lots of advice on the net about usb drives disappearing from windows, but I don't want to start trying a whole bunch of things without really understanding what they do. I'm hoping this is something simple. Any help appreciated.

Thank you, -Ron

More info: I just found the following message for all four of the "Generic Volume" lines in the Storage Volumes section of the device manager: "A driver (service) for this device has been disabled. An alternate driver may be providing this functionality. (Code 32)" How would I fix this?

My System SpecsSystem Spec
02 Sep 2014   #2

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64

Open Device Manager, right click any of the Generic Volumes->Properties->Details tab. Use the pull down menu and look if Class Upper Filters or Class Lower Filters exist. If yes, copy paste the values into next post

Attached Images
External USB2 drives "disappeared" from the computer explorer window-filters.jpg 
My System SpecsSystem Spec
03 Sep 2014   #3

Win 7 Pro x 64

Quote   Quote: Originally Posted by ComputerGeek View Post
Open Device Manager, right click any of the Generic Volumes->Properties->Details tab. Use the pull down menu and look if Class Upper Filters or Class Lower Filters exist. If yes, copy paste the values into next post
Thank you CG for the response and helpful image. I have fixed the problem (more below), but to answer your question directly, there is no category called "Generic Volumes" in the USB controllers tree, so I checked everything, including, most particularly, the four "USB Mass Storage Device" entries, and none has either of those two lines. In the Disk Drives tree, where all the drives appeared even before the fix, each drive does have a Class Upper Filters line and the entry is "snapman" for each of them. No Class Lower Filters.

I fixed the issue (except see below) with a system restore. But not the most recent one. The most recent one did not work, so, after a lot of reading, I was starting down the path of uninstalling/reinstalling the drives one by one. That was not working. (I do remember checking the "Start" number in HKLM\System\CurrentControlSet\services\usbhub) and it has been set to 3 (as I've read it should be) both during the failure and since the restore.) I know there's advice on the net about uninstalling all usb devices at same time, but I was hesitating there because I have a fear of being frozen out of my keyboard and mouse (both usb cabled). All my usb devices except the external drives seem to have been working fine the whole time. (The drives themselves are all still healthy.) On a whim, I tried the next earlier restore (ten days before the most recent one), and the drives reappeared in the windows explorer. So I guess the problem occurred between the two restore points, 8/19 and 8/29 (so cleaning out files had nothing to do with it), and an event log I keep for warnings and errors seems to confirm this in that a series of four warnings started appearing on 8/25. I just didn't notice it til six days later. Example:

Event ID 219: "The driver \Driver\tdrpman failed to load for the device STORAGE\Volume\{3adb8c6a-81fd-11e2-9c95-806e6f6e6963}#0000000269A04800."

Now here's the thing: There's a module in the top front of my (Dell XPS 9000) tower which contains one USB2 port and two card readers. Don't know if the card readers are functional now - never use them - but the port no longer functions. If I insert a flash drive Windows says: "One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it." (The flash drive works fine in another port.) This module failed once before when the computer was still under warranty, and Dell had replaced the corresponding card. I'm *assuming* it has failed again, and that the failure somehow caused the issue. I can live without this port, but I don't understand why the Device Manager never flagged any device as malfunctioning (other than the msg I reported above), and I also don't understand why the failure of one port (in which I did have one of the external USB drives) would cause all the other external drive (but no other USB device) to be lost to Windows. Note that Device Manager did recognize the physical drives themselves (all of which are completely functional, btw, so I don't know what that failed device error in my OP was about, unless it was essentially the same one I get now when trying to use this port), and in the USB tree it had the same four USB Mass Storage Device settings it has now. I don't know whether they contained the enumerations you mentioned, though. I'm not about to restore to a faulty configuration to find out.

So I don't know what it is that I disabled when discovering the problem, but nothing seems disabled now in the Device Manager. There is the faulty port, and I'm wondering if possibly I disabled it in software, and how to do a full diagnostic on it. I have discovered this tool:

Test with Microsoft USB Test Tool (MUTT) (Windows Drivers)

but it seems rather elaborate. I'd appreciate hearing if anyone recommends against it, or if there's a simpler way within windows to do diagnostics on this one port. (Remember, the Device Manager is not flagging anything.) I'm grateful to have my computer in working order, but it's a less than gratifying fix because I don't really understand USB architecture or, in particular, how a (circuit?) failure on one port could cause the other drives to "go missing" in Windows.

Apologies for the verbosity. Anyone who's read this far must really understand USB. I'd be grateful for a tutorial pointer on ports, hubs, controllers, buses, etc. Thanks, -Ron
My System SpecsSystem Spec

03 Sep 2014   #4

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64

Hi rkl122

I'm glad the System Restore fixed your problem. I know why all your USB drives suddenly stopped working. The info in your post confirms what I was looking for. Your problem was due to a corrupt Class Filter. Yours was from Acronis. You either have Acronis (or had it) installed. Acronis is a great product (i use it myself) but is notorious for leaving filters behind when it's uninstalled.

Event ID 219: "The driver \Driver\tdrpman failed to load for the device STORAGE\Volume\{3adb8c6a-81fd-11e2-9c95-806e6f6e6963}#0000000269A04800."
tdrpman is an Acronis class filter. A "filter" is like a driver snap-on part (like connecting Legos). If the filter is bad, the entire driver goes bad

I made a mistake in my instruction. To see Generic Volumes, you need to first click View->Show hidden devices then look under Storage Volumes

in any case, glad your System Restore fixed the driver
My System SpecsSystem Spec
04 Sep 2014   #5

Win 7 Pro x 64

Thank you CG. Yes I have an old version of Acronis installed. (I've also read about its notoriety with respect to drivers, which in fact makes me wary of it.)

I knew about that "unhide" switch in the Dev Manager, but not the implications. So with it on, there certainly are filters on each generic volume:

Class Upper:

Class Lower:

I'll research these (as you say at least one is from Acronis. Those last two (Class Lower) are not showing in the driver tab of Autoruns (a great SysInternals program)). But my question now becomes: are the filters potentially harmful, and if so, what to do about them? (Also showing are a ton of generic volume shadow copies, which I'll research.) There's also the question as to what caused the original "breakage"? Am I right that a single usb port (electrical) failure can trigger corruption of all devices in that class?

My system is still operating normally, except for that one bad port, and I now see the error I referred to in the OP. When I put a flash drive in that port, I get: "Windows has stopped this device because it has reported problems. (Code 43)." Uninstalling/reinstalling doesn't work, just regenerates the error, so I'm pretty sure it's a port malfunction which Windows doesn't recognize as such; the flash drive works in the other usb ports. (Also realized I can spring for a powered usb hub for a lot less than it would cost to replace this faulty panel.)

Anyway thank you for mentioning the high and low filters. Been reading. The lego analogy is so apt! And I see now why it's important to consider class attributes. I can reinstall an individual device til blue in the face - won't help if it's the class driver that's corrupted. -Ron
My System SpecsSystem Spec
05 Sep 2014   #6

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64

Hi rkl222

Looks like you've been doing your homework! :)

1. You can remove old USB Mass Storage drivers (along with old Generic volumes) and more stuff easily. See USB drive or flash problems? How to cleanup and remove old USB storage drivers - TechSpot Forums

2. It must have been a class filter for your Disks, that caused your problem. (given things are working and tdrpman and others still defined). In general, is good to check a disk and a generic volume for filters when such problems arise

3. As to the Acronis filters still there, you could either
a) Leave them alone since everything is now working (it's not hurting anything) or
b) if you did want to clean them and you're comfortable with editing the registry. We uninstall Acronis, delete the Acronis filters, then reinstall Acronis so it can re-install any filters that version needs
  • Create a System Restore point.
  • Before uninstall, we'll save a copy of your Acronis backup database and settings (so you don't have rebuild it all). Save a copy of C:\ProgramData\Acronis\TrueImageHome\Database\archives.xml somewhere, then you can uninstall Acronis
  • Use regedit and carefully navigate to HKLM\SYSTEM\CurrentControlSet\Control\Class
  • Click Edit->Find. Use it to find subkey {533c5b84-ec70-11d2-9505-00c04f79deaf} (you can simply copy/paste the key name into the find box)
  • You should see Upper Filters followed by the names of the storage volume class filters
  • Right click on Upper Filters, select modify. Position the cursor and delete the Acronis filter names.
  • Close regedit. Reboot
  • Reinstall Acronis. Acronis will reinstall any filters it needs

p.s. Yea, sounds like that one USB port is bad. Getting a self-powered hub sounds like a good idea!
My System SpecsSystem Spec

 External USB2 drives "disappeared" from the computer explorer window

Thread Tools

Similar help and support threads
Thread Forum
Windows Explorer not displaying "My Computer" or any Hard-Drives.
Dell M6500 When you open Windows Explorer via. the Start Menu > My Computer the summoned instance attempts to "Load" the Tree view on the left. Does not display "My Computer" or any Drives. If you then middle-click the icon on the start-bar, or open another instance of Windows Explorer...
General Discussion
Changing "Computer" and "Network" icons in explorer navigation pane
Does anybody know how I can change these icons? I changed the default icon for the network one in HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C} but it didn't change. Appreciate any help, B
External USB drives using letter E: not showing in "My Computer"
When I plug any hard drive or memory stick into either USB port on my Dell XP computer, the default E: drive letter and device does not appear in the "My Computer" window. I can see it when I access the administrative tool for storage devices and access it there also. If I change the drive...
Hardware & Devices
Properties "Security Tab" disappeared on external drive
Hi... It has been awhile since I have been here. I anticipate (or at least hope) that this visit won't be as chaotic. I recently switched back to Windows 7 from Vista a few weeks ago. I am running 32-bit Ultimate on an HP Pavillion laptop that has an AMD X2 64-bit chipset. It is running...
Hardware & Devices
Remove "labels" from drive types in "Computer" window?
Hi there, I didn't really know how to google for this (although I did), so I didn't find anything proper and like to ask you: How do I remove the "labels" from drive types in "Computer" window? What I mean: These labels above the different...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:51.
Twitter Facebook Google+