Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB ports not working

01 Nov 2009   #1

Windows 7
USB ports not working

When a USB device such as a flash drive is plugged in, the computer does not react at all. It does not find the device nor does it show (not even as unknown) in the device list. However when I boot the computer with the device plugged in, it works fine.

IThis may be related. I have an 'Unknown Device' that periodically pops up and then disappears. I've tried many software programs & checks but nothing can identify it. I have the latest Intel chipset drivers installed and my drivers through DriverMax are up-to-date.

I would appreciate any help.

My System SpecsSystem Spec
01 Nov 2009   #2

Windows 7 Professional x64

I you have not already done this, go into the BIOS (integrated peripherals) and find all USB controllers....anything that says USB on it and make sure it's enabled. For some reason, I have seen BIOSs that have certain USB function disabled be default. One was disabled on a Gigabyte board I got a few months ago. There must be some reason they have, but I would just make sure. It may be something simple like this. Hope this helps.
My System SpecsSystem Spec
01 Nov 2009   #3

XP, Vista, W7 64bit Home Premium

Put up your system specs and i will try and find it - not that I relish the thought.
My System SpecsSystem Spec

16 Jan 2010   #4

Winows XP; windows 7

I have an Acer Travelmate 4000. I recently set up this machine as a dual boot XP/Win 7. I recently have a problem in in 7 - the two USB ports on the side do not recogise anything although the one on the front works as normal! hen I boot in XP all three work! Any idears anyone?


My System SpecsSystem Spec

 USB ports not working

Thread Tools

Similar help and support threads
Thread Forum
USB 3.0 Ports Not Working
I just bought a new Kingston Ultimate 32 GB USB 3.0 flash drive. It works fine in my 2.0 ports but will only light up in the 3.0 ports and Windows 7 64 bit does not see it. I have enabled the USB 3.0 ports in my BIOS and I have got the latest NEC USB 3.0 driver for my MSI P55-GD85 motherboard. ...
Hardware & Devices
USB Ports Not Working
Last night I was transferring some files from my laptop to my external hard drive and everything was working fine but then a couple hours later, I went to plug in some rechargeable USB batteries that I have and noticed that they weren't lighting up. I then tried plugging in several of my other USB...
Hardware & Devices
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
Not all USB ports are working
Hello guys, I have just got my motherboard replaced by a PC World Techguy and I got it back last week. Because the BIOS on the new motherboard has not be altered to the same has the old one. The front 2 usb ports are not being recongized, but the one that my usb hub is plugged into is working...
Hardware & Devices
USB ports not working...PLEASE help!
My computer crashed and I had to take it in for repair. They put Windows 7 on it and I am liking it so far. However, none of the USB ports work. I work from home and all of my files are on an external hard drive so this is a big problem! I have a Dell Inspiron E1505. I have tried...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:51.
Twitter Facebook Google+