Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot Eject External HDD?

08 Sep 2014   #1

32 bit
Cannot Eject External HDD?

I had not safely remove my HDD under an vista computer, now I wanted to mount my HDD under Ubuntu but that's not possible and I'll get an error.

So I mounted my HDD under Windows 7 and did a checkdisk, but I canceled the checkdisk to early. Now I wanted to eject my HDD and get the following error?

I also tried to run the checkdisk again but then nothing started, do I just have to wait?

Attached Images
Cannot Eject External HDD?-eject.png 
My System SpecsSystem Spec
08 Sep 2014   #2

32 bit

Or should I just eject the drive (not safely) then is probably the problem solved and can I mount the drive under Ubuntu?
My System SpecsSystem Spec
08 Sep 2014   #3

Windows 7 Professional x64

If you are worried, why not just shutdown the computer and then unplug the drive?
My System SpecsSystem Spec

08 Sep 2014   #4

Windows 7 Home Premium 32 bit

^ Good. Way to go.
My System SpecsSystem Spec

 Cannot Eject External HDD?

Thread Tools

Similar help and support threads
Thread Forum
Can't eject external USB HDD
I often open content on my (Toshiba) portable hard drive from applications on the local hard drive. In WinXP, I didn't have any problems ejecting the portable drive once I was done and closed the application. ...To be clear, when I did get an "in use" error message, I would simply go into Task...
Hardware & Devices
Can't eject my external HD?
I need to do a repair installation. I unplugged my printers (after removing them from printers & devices) from the back of the printers, but not from USB. I also removed the PrimoPDF from there but not from my programs. I tried to eject the My Book External HD but it is telling me it's in...
Hardware & Devices
How to eject an external eSata drive?
I am fairly new to W7 and I was wondering how you safely remove an external eSATA hard drive that is connected to a Sumvision 3.5" HDD docking station? Iv'e looked everywhere and cannot find anything that says eject. I did look in the Sumvision manual and it says supports plug and play? Thanks!
Hardware & Devices
Unable to safely eject external drives etc
Any ideas what I should do here..... I can attach and use external devices - but when I try to safely eject there is nothing there - in other words, right click icon on system tray but the device is not listed. Any suggestions with what could be the problem here? Thanks
Hardware & Devices
External hard drive won't eject
Hello all, I've got a Seagate Free Agent Pro external drive (currently connected via eSATA), which solidly refuses to disconnect from the system, using the "safe disconnect" dance. Whenever I try, after a pause I get the error message: "This device is currently in use. Close any programs...
Hardware & Devices
problem to eject external drives
hi.i have a problem since now.i cant eject and safe remove my external drives and memory sticks.when i try to click on the list to any device 'eject drive' from the notification area,nothing message any more that i cant remove with safety my device.sometimes then,there is no list when i...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:03.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App