Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: SSD will not boot when fitted in a Caddy

09 Sep 2014   #1

Xp and Windows 7 32 bit and 64 bit
SSD will not boot when fitted in a Caddy

I have several computers all of them have two caddies fitted. The operating system is normally fitted in one the C: drive and the Data Store is in the D: drive. So far I have used Western Digital drives.
The computer I am having the problem with is an Asus Sabertooth 990FX board with the latest BIOS 1604.
I have decided to fit SSD's to all my computers. This Sabertooth machine allowed the HDD C: drive to be migrated to the SSD. This was done with the HDD C:drive in a Caddy and the SSD in the second caddy in place of the D: drive The migration was successful.
I then remove the HDD C: drive and fitted the newly migrated SSD C: drive to the same caddy which had housed the HDD. I powered up and found the SSD was not recognized. The message to insert a boot disc etc was displayed.
I tried the SSD in another machine with an Asus board this time an M5A 78L-M. The computer booted up OK.
I returned to the Asus Sabertooth machine and tried the SSD connected directly to the SATA ports on the Motherboard.and it booted.

The problem as I see it is the SSD will boot with a direct connection but will not boot when a Caddy is in the circuit.

Has anyone had a similar problem and any suggestions on a Fix.

My System SpecsSystem Spec
10 Sep 2014   #2

Windows 7 Ultimate 64-bit, Windows 8.1 64-bit, Mac OS X 10.10, Linux Mint 17, Windows 10 Pro TP

Is the caddy a SATA or PATA? If SATA is the BIOS set to boot the port is plugged into on the motherboard first?
My System SpecsSystem Spec
10 Sep 2014   #3

Xp and Windows 7 32 bit and 64 bit

The Caddy is SATA. The BIOS is set to boot from "Floppy"/USB first, CD/DVD second and HDD third.

Reading more into your questions do you think it should be the other way round - HDD first?
My System SpecsSystem Spec

10 Sep 2014   #4

W10 Pro desktop, W10 laptop, W10 laptop, W10 Pro tablet (all 64-bit)

Boot order shouldn't matter.

I assume you checked the caddy over and made sure the ssd was firmly inserted, no bent pins or any other similar problems?
My System SpecsSystem Spec
10 Sep 2014   #5

Xp and Windows 7 32 bit and 64 bit

Yes I even tried different makes of both caddy and drawer. This has really stumped me. All the combinations I also tried on the M5A 7L-M machine and it ran OK I am starting to think it may be a Motherboard fault. Although the one common factor in the failure mode is the caddy ( of various types)
My System SpecsSystem Spec
16 Dec 2014   #6

Xp and Windows 7 32 bit and 64 bit

Well I think I have found the solution to the problem. All the caddys or Mobile Racks had one thing in common. They had centronics type connectors. I came across a caddy which has standard SATA connectors on the back and another SATA connector on the inside of the caddy. A PCB is between the two connectors. The Caddy is a ICY BOX IB-129SSK-B. I bought one on spec and it worked. The computer is now running from a SSD in a Caddy.
I don't understand why it had not worked on the other caddys but the important thing is the problem is solved. I hope this may help others in the future.
If anyone can provide a reason for the problem I would be most interested to hear.
Many thanks to those who offered their help.
My System SpecsSystem Spec

 SSD will not boot when fitted in a Caddy

Thread Tools

Similar help and support threads
Thread Forum
Speakers fitted in monitor and can't hear a thing
I have speakers fitted in my monitor and I have realtek HD audio manager I updated it in 2012 the september update, and still there is no volume, but i did try one thing, i changed it from stereo and put it on the Quadrophonic one then the 2 speakers at the back i tested and they worked but in...
Sound & Audio
Old Hard Disk now fitted into a caddy but it is not being recognised
I took my old SATA hard disk & fitted it into a caddy. On caddy I am getting a green light indicating HDD is connected & the hard disk is idle, a red light should go on if hard disk is being accessed. Although caddy is Plug & Play it is not being recognised. The old hard disk previously was...
Hardware & Devices
Caddy - Quick Question for Anyone who has one
I'm looking on the web for a caddy (to get old HHDs doing something useful again). Is there anything I need to look out for / avoid in particular? My drives are: 3.5 inch SATA II Do I just ensure I have ordered the correct size of caddy, and that it accepts SATA II?
Hardware & Devices
reading a HDD in a Caddy
Is there any software program that can read a HDD in a caddy irrespective of the formatting of the files. What I'm trying to read is a HDD out of a Humax 9200 PVR.
General Discussion
after new SSD fitted and New Win7 installed, can't find network adaptr
Hi all. i've reinstalled a brand new OS windows 7 32bit becoz a new SSD just being installed, I've installed all drivers which downloaded from ASUS support, but i can't find the lan adaptor after that, all drivers has been installed correctly from the view of Device manager. if i insert the RJ45...
Network & Sharing
Removable caddy and harddrives
Hi need some help and i am perplexed by the issue in Windows7x64 Ultimate. I have a USB hard drive caddy. Install the hard drive (on cable select and master have tried both) but Windows7 will not initialize any of the drives. BIOS sees the drives. Windows Disk Management sees the drives. ...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:03.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App