Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Internal Hard Drive name defaults to "PenDrive"

03 Nov 2009   #11
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64

Your mention now of having a Cloud setup suggests a virtual volume for online application. I think you just named the problem yourself there. The name you gave that is what you are seeing displayed in WE while the Disk Management will only show the physical drive there which can renamed over and over without any effect on the mounted volume.

Having been using the Gladinet Cloud Desktop here while having the 64bit 7 RC as well as a few Linux distros installed on the Portable Virtual Box the program was used for uploading files to the Windows Live SkyDrive in order to download to the installation on virtual drives since those lacked direct access to the internal drives on the system.

If you look at the image here you will see how that becomes a separate drive being provided a drive letter while not being seen in the Disk Management tool. Actually that is simply a folder mounted virtually seeing the drive letter designation. If you have anything like this setup this is why you are unable to rename it.

Attached Images
Internal Hard Drive name defaults to "PenDrive"-gladinet-virtual-drive.jpg 
My System SpecsSystem Spec
05 Nov 2009   #12

Windows Vista Business

Hello conticreative, I am expericiencing the same problem of being unable to rename drives called PENDRIVE. Only I am running Vista Business on the computer where the problem first occured! I have three external hard disks that were called Documents, Music and Multimedia once, but they now all show up as PENDRIVE. Also my USB-stick, that once was called "Smileface", is now PENDRIVE.
When I insert this USB-stick in another PC, its name remains PENDRIVE! I tried it on a machine running Windows 7 Ultimate and Windows XP. So I don`t think the problem is Windows7 specific.....
My System SpecsSystem Spec
05 Nov 2009   #13

Windows 7 Home Premium x64

I think conticreative, found the solution.

This is a link to MS forum, in which I think he posted his question too, and finally got the solution. It was probably a virus, but I am not sure.

New Hard drive refuses to be renamed from "PenDrive (it's not a pendrive)

My System SpecsSystem Spec

05 Nov 2009   #14
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64

Good find! zx81 It certainly won't hurt running a sweep of the system for any bugs. External hard drives as well as flash drives are more suceptable to bugs then your internal drives that typically see more security scans.

If you download or copy a bug or infected file onto an external drive and then back onto your system it then may become active and spread efecting your main system files as well as others.
My System SpecsSystem Spec
06 Nov 2009   #15

Win 7 - Mac OS X - Linux
[SOLVED] Internal Hard Drive name defaults to "PenDrive

I have an update on this issue. Apparently while transferring files I must have caught a trojan that my new Antivirus caught (the old one on Vista didn't) and once I cleaned it the HD reverted to the right name "Medusa"
the two occurrences were too closed together for it to be coincidence so I suppose the trojan was the cause of the inability to rename the drive.

I wanted to thank you very much for the help but we can close this thread now since the problem has been resolved
My System SpecsSystem Spec
11 Nov 2009   #16

Windows 7

Hi, i have samo problem too. I renamed my drives but in WE they still had names Local Disk. It wont change... what to do. How to rename it in DM.

P.S. About large icons, just hold CTRL on desktop and use mouse scroll, see what happen
My System SpecsSystem Spec
16 Oct 2012   #17

Windows 7 Ultimate, Mac OS X, Linux
Same Problem

I have the same issue, had it for awhile and even after formatting drives completely which takes care of it for a little bit, the problem comes back.

Attached Thumbnails
Internal Hard Drive name defaults to "PenDrive"-pendrive-issue.png  
My System SpecsSystem Spec

 Internal Hard Drive name defaults to "PenDrive"

Thread Tools

Similar help and support threads
Thread Forum
Hard Drive "Not Initialized", "device is not ready",won't recognize
I used a DriveWire - Universal Hard Drive Adapter (IDE / PATA / SATA to USB HDD Adapter) to hook up A 3.5" Hard Drive (Samsung model HD502HJ) to my desktop in an attempt to get my wife's files off her old desktop machine and merge them into mine. It all started off fine, the drive was recognized...
Hardware & Devices
Internal Drive disappears"G:\ Refers to a location that is unavailabe"
Hey everyone, This is my first post here, and it is because of a terrible problem I am having where one of my internal drives literally just disappears from my computer after about 15 minutes of my computer running. If I restart the computer the drive will come back but then just disappear...
Hardware & Devices
2nd internal hard drive wont appear "error: core library not found"
I have a problem with windows saying my 1TB WD HDD isnt there. When I boot my computer up i can see it on the boot menu, but when i log into my computer an error message pops up and says "error: core library not found", and my D: is gone. I boot off of a 64gb SSD. It also seems the problem is...
Hardware & Devices
clicking "insert picture" it always defaults back to "large icons"
When I go to insert a picture in a certain program the "picture services" window pops up. I go to choose the "icon size" for my photos and it will not remember the selection, "medium icons" for the size of my photos in the selection window. It always reverts back to "large icons". I can only see...
General Discussion
How to change "FAT32" penDrive to "NTFS"? can't format it "NTFS"
I have "Kingston" 4GB pen-drive its file system is "FAT32" i try to change its files system to "NTFS" using "formatting" process. When i try to format it in "NTFS" this error show. "Windows was unable to complete the Format." So how do i change its file system to "NTFS"? :mad: ...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App