Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Intel I7 4790k Turboboost enabled but not working

21 Sep 2014   #1

windows 7 Professional
Intel I7 4790k Turboboost enabled but not working

I have Turboboost enabled in the bios. It says its on. Its supposed to boost to 4.4ghz, stock 4.0. When I check Computer Details, its still 4.0ghz. I have experience and don't mind overclocking manually, however, I would much prefer to first try turbo boost and see how that works. I might find I dont need to OC anyways. It would be nice to see if I can give boos a try before I go tampering with numbers and voltages. I might still OC. Like I said. Would be nice to give turbo a try before I start messing with things potentially needlessly.

I am using an ASUS z97 HERO VII motherboard, and like I mentioned in the title, an I7 4790k. I don't know that this is a item model compatibility issue or not. I wouldn't think it is because of how easily I was able to enable it in the UEFI Bios. On the off chance it is, the models might be important.

I see other people with this issue on the Intel and TomsHW forums, but after trying their fixes, provided they were not out of date, nothing worked.

Could I be missing something? is there a driver I need, perhaps? Unfortunately, this is my first tower with an Intel chip in many years and I am not familiar with all the community recommended drivers. Only those that are said to be required by the mobo or have come with it. On that note, though, I do have all the mandatory drivers up to date, per the Intel website.

I appreciate any helpful responses. It means a lot. Hopefully this is a heard of problem, that I am just missing a step, somewhere, and this will be an easy fix (fingers crossed).

My System SpecsSystem Spec
21 Sep 2014   #2

windows 7 Professional

I made a discovery that the turbo boost isnt really OC, technically, just dynamically expanding as needed, Marked as solved
My System SpecsSystem Spec

 Intel I7 4790k Turboboost enabled but not working

Thread Tools

Similar help and support threads
Thread Forum
Stereo Mix enabled but not working
I'm trying to get the Stereo Mix device under Recording Devices to actually broadcast sound, but I can't seem to figure out what's wrong with it. It's enabled, and even set as a default device. I also can't seem to get programs like CamStudio to record the sound even though the option is...
Sound & Audio
AMD FX 6350 vs Intel i7 4790k. Is really worthy?
Hi! First of all, here're my specs: Operating System Windows 7 Home Premium 64-bit SP1 CPU AMD FX-6350 19 °C Vishera 32nm Technology RAM 8,00GB Dual-Channel DDR3 @ 669MHz (9-9-9-24) Motherboard
USB port not working Intel USB3 xhci Driver for Intel® 8/9 Series
Hi, Just wondering if anyone has been having the same issue. Windows 7 x64 series 8 motherboard. ASUS z87-expert. My USB3 and USB2 are not working right after I install the Intel USB3 xhci Driver for Intel® 8/9 Series version I have used the setup.exe to install the driver...
i7 4790k or i5 4690k?
I need to know which one to get. I easily have the money for the i7, although I don't want to spend unnecessarily, obviously. My main usage is going to be gaming but I will also be doing RAM intensive applications such as multimedia editing (photo and video mostly). I don't know if the...
PC Custom Builds and Overclocking
My Wireless card Said Enabled but isn't working
This is what i got in ipconfig. As you can see it's not detecting the Wireless LAN card. I've done everything; reinstalling drivers, reboot after reboot, I don't know what to do! I'm running Toshiba Satlelite C655 with windows 7 64bit. my card is atheros. Microsoft Windows Copyright (c)...
Network & Sharing
Microphone not working, is enabled but wont pick up audio
I've had this problem ever since i built the PC and latest drivers don't seem to fix it. Previously on Win XP, i had to disable a line in to get the mic to work, however those options don't appear to be available on Win 7 i have an EVGA nForce 680i SLi motherboard, and running Win7 64bit Home...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:18.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App