Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Problem installing a 4TB storage drive

05 Oct 2014   #1

Windows 7 64 bit
Problem installing a 4TB storage drive


I have a Dell XPS machine that original came with 2 x 320GB RAID drives. A while back I installed an SSD that holds the OS and programs and split the RAID into 2 separate drives for data storage. I just bought a Seagate 4TB drive as need much more storage, but when I swapped out one of the 320GB HD I only see 1.7TB in disk management.

Looking on Seagate help pages i found this that says there are issues with older versions of Intel RST

Intel Rapid Storage Technology (RST) drivers and Support for Disk Drives Beyond 2.2 TeraBytes (TB)

If i go to device manager the only controller I see is Intel ICH8R/ICH9R/ICH10R/DO/5 Series/3400 Series SATA RAID Controller. The driver properties are the same as the help article so I'm guessing this is the issue. However doing update driver doesn't automatically find a newer driver. The Intel driver update utility found a new driver, but the installation just seems to be hanging about 10% across the bar (possibly because I don't actually have any active RAID discs?)

The bottom of the Seagate articles say Intel RAID does not support >2.2TB. So the question is is there a driver I can download that will sort this out or do I need to do something dramatic to remove this RAID controller and install some other controller that will recognize the full 4TB?

Thanks for any advice


My System SpecsSystem Spec
05 Oct 2014   #2

Windows 7 64 bit

Managed to get the new driver through IE9 and now see 3.7TB.
My System SpecsSystem Spec

 Problem installing a 4TB storage drive

Thread Tools

Similar help and support threads
Thread Forum
Problem with installing Google Drive
I am having a problem installing Google drive along with a few other google programs. essenitally i get a message box with the following: "Google Update installation failed with error 0x8004071b". Keep in mind, i had just reformated my local hard disk. Any ideas as to how to resolve this problem?...
Format & Partition New Drive to Use as a Backup Drive or Storage Drive
I want to prepare a factory fresh drive so that I can use it to save backup images. Soon I will have a second drive that will only be used to store data files. Neither drive will ever be used for the installation of an operating system. From what I've read, I see no advantage to having more than a...
Hardware & Devices
Problem in installing windows 7 using a usb flash drive
i want to install windows 7 in my dell inspiron n4050,it came with the preinstalled ubuntu,..i do not know how to install windows 7 on my laptop as i want to use windows 7 intead of ubuntu..plz if anybody can help,..i have an iso file on my usb of windows
Installation & Setup
Problem installing USB mass storage device driver
I have an Acer R3610 (so everything is via USB). When I plug in an I/O Magic disk drive, I get an error "Device driver software was not successfully installed". I had earlier tried to fix this situation by going to Device Manager and deleting all drivers under USB controllers. When I rebooted...
problem installing from flash drive
i have a very long story but i will try to keep it short. if you need more information to help me let me know. so in short. i just put a new hard drive in. set my bios up to boot from usb flash drive first, then cd rom. well i had both the cd and the flash drive in, i'm not sure which one it...
Installation & Setup
Installing more than one SATA Drive problem...Solved!
I read a few people having problems when trying to install multiple drives not being recognized, system hanging etc.. I had the same problem. Well today I said let me try something. Attached the drive the went into the BIOS & guess what, the New drive was pushed to 1st boot order?! Changed...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:55.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App