Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: False "Low Battery Alarm" with after-market battery - Dell Studio

18 Oct 2014   #1
ssimlai

Windows 7 Home Premium 32bit SP1
 
 
False "Low Battery Alarm" with after-market battery - Dell Studio

Hello,

Sorry for being away from posting on the forum since a long time, though I have been visiting the forum lot many times, without logging in - mainly through Google search. That shows how effective the website really is.

Since some time a very persistent error has been bothering me and I thought it best to come here and post the issue.

After my original battery for my Dell Studio 1555 32-bit computer died, I replaced batteries thrice, one after another (the computer is five years old).
The three replacement batteries were:
1. Dell - exact replacement 56 Wh
2. LB1 - matching specs but 48 Wh
3. Dell - exact replacement 56 Wh

Since the second replacement battery, the Low Battery Alarm has been disturbing me each time that:
1. The computer is restarted with the main power disconnected.
2. The main power jack is removed after a 100% charge.
3. The main power jack is removed anytime.

Since in the first place I never set this alarm manually, I am assuming there could either be a Dell specific registry issue with after-market batteries, though I don't understand why. Either way the irritant must go.

I checked Advanced Power Options under Power Scheme but found nothing that would give me a hint of what's wrong.

The alarm screenshot is attached.

Any help would be welcome.


Attached Images
False "Low Battery Alarm" with after-market battery - Dell Studio-low-battery-alarm.jpg 
My System SpecsSystem Spec
.
18 Oct 2014   #2
ss538

Windows 7 Enterprise
 
 

Rule out the OS and Drivers by downloading a Linux LiveCD and booting from that See if you get the same errors/alarms/warnings.
If you do it could be a faulty charging circuit in your laptop. Check with Dell and see if they have a battery calibration tool. Sometimes completely running the battery flat a couple of times does a "reset" kind of thing.
Sorry I can't think of anything else just now.
My System SpecsSystem Spec
Reply

Thread Tools




Similar help and support threads
Thread Forum
Laptop shuts down at 96% battery and "Plugged in, not charging" issue
Hi all, Laptop is a 5 years old HP Pavilion DM4-2153ca. Issue started a few months ago when laptop was shutting down at 63% battery, and when I plugged it it would charge until 9x% and then say "plugged in, not charging". In the meantime I upgraded to Windows 10 and the issue wasn't solved....
General Discussion
Impossibile to disable "Microsoft Composite Battery"
I not have battery in my laptop. Then i have disabled "Microsoft AC Adapter" and "Microsoft ACPI-Compliant Control Method Battery" in "Device Manager" but not is possibile to disable "Microsoft Composite Battery". Why, It makes sense to have "Microsoft Composite Battery" without "Microsoft AC...
Hardware & Devices
Reinstall driver "Microsoft ACPI Compliant Control Method Battery"
Hello all, I've spent a good few days trying everything the internet has thrown up to fix my mistake but nothing has worked. I shall list my attempts to fix subsequently. My problem is this: six days ago, I was using my laptop on its battery and I noticed that the battery icon in the...
Drivers
Dell Studio 1558 | battery doesnt charge even when it shows charging
Hi everyone, My name is Tarun. I have been facing an issue with my newly purchased battery. I did not use my laptop for an year or so because my battery was dead and i didn't even remove that dead battery from the laptop, it was kept inserted for an year. A few days ago I purchased a new...
General Discussion
"Internal battery" notices..what problems could a low battery cause?
Okay, so I've been having a few programs with my computer...this including slowness, poor wifi connections, and odd performance of wacom tablets. The problems with a tablet are described in more detail here-->...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:45.
Twitter Facebook