Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: External HDD Unallocated 2047.35gb other Sol'n?

23 Oct 2014   #21

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Probably a good idea Pimple Haze and if Mr VenJay wants to do that I have a little ditty to show how


Make a bootable Ubuntu disk

Set the BIOSto boot from the optical when the machine boots it will show you a screen with TRY or INSTALL >select TRY.You can of course remove the hard driveand any other drives when doing this as if the optical alone is the only driveleft in the machine then the BIOS willonly find the optical to boot from.

When it isfinished - it takes very little time you will get a screen like in the pic .

Open thedrive you want > User and dig down until you get to the data / settings you may be able to copy / paste the materialyou want to an external source or other installed drive doing this.

I am notsure if it will but I have recovered tons of data etc using this method both on"dead" or just plain drives that you cannot get data from using Windows.

Attached Thumbnails
External HDD Unallocated 2047.35gb other Sol'n?-ubutux.png  
My System SpecsSystem Spec
23 Oct 2014   #22

Windows 7 Home Premium x64

Hi again everyone!

I'm sorry for the delay here, I have missed I few new posts and as I can see I haven't quite understood everything right?
So the 2TB hard drive is an external one, not internal! That does change things a bit! Though, I don't understand why it would make it so hard to initialize?
@MrVenJhay, so the disk has shown failure? But you haven't checked it thoroughly? If you can, I would suggest scan it fully, you could use the WD Data Lifeguard Tool for that:

Afterwards, look at the results, post them here, to see if it's even worth it to deal with this external hard drive. Looks like a bad one, it happens so sometime, or if it's not brand new, then it could've been damaged somehow.

What brand and model is the hard drive? If you don't know can you send a picture? Depending on the disk and how old (new) it is, you could try and RMA it.

But I couldn't understand if it has any information on it that you would need?

@PimpleMaze, the Ubuntu idea is great! @Icit2lol, great guide! But I have a bit of doubt in this particular case. If the 2TB disk is write protected that probably means that it's hardware encrypted. I am not sure if loading it in Ubuntu would be able to initialize it? I may be wrong, if so, please correct me! Otherwise, it's worth to try.

Last case scenario, I would still suggest RMA-ing the disk as this one just seems bad.

Best of luck!

My System SpecsSystem Spec
23 Oct 2014   #23

Windows 7 Home Premium 32 bit

Facts in this case:

1. 500GB external HDD reads as a 2047.35 GB drive, unknown, Not initialised, Unallocated. ( It is not a 2TB drive. The OP has clearly stated this in his first post. Moreover a 2TB drive will never read as 2047GB.)

2. Trying to initialise it throws out the error message of it being writeprotected.

Read together and there is no doubt whatsoever that the drive is a goner.

Yes, if your drive is still under warranty, RMA it.

If not, you can work as follows to determine whether it is the SATA/PATA to USB bridge interface inside the enclosure or the physical HDD inside that has given up. ( Yep somewhere in the HWInfo I saw it as
IDE <->USB, Primary-Slave)

Take out the HDD and connect it as an internal drive on your desktop and see how it behaves. Check it in Windows Disk Management. If it is a PATA drive, you have to connect it with a PATA cable and configure it as a Master if you don't have any other PATA drive.

If the drive proves to be good you can use it. If it proves to be bad , just throw it away.
My System SpecsSystem Spec

23 Oct 2014   #24

Windows 7 Ultimate x64

Probably right, Jumanji.
Try another usb cable.
try another usb port,
try another computer, if possible.
If nothing works, and the external drive's under warranty, RMA!
otherwise take it out of the enclosure and connect it as internal drive.
If that doesn't help try updating the firmware, if available,
try running the tools that are available from the manufacturer's website
But don't toss it away before you tried it on linux too.
My System SpecsSystem Spec
23 Oct 2014   #25

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Ok well I did suggest that the drive was hooked up to another machine back in post #16 and as far as I could tell from the very beginning the drive was an external and was showing a very odd capacity and I should have suggested a chkdsk on that drive back then.

However there seems to be a fair bit of confusion throughout the thread and I think the Ubuntu run would have probably shown that drive up for what it actually is, and as in the HW Info readout the drive was seen to be a 500GB drive and in fact I suggested ditching this drive quite a ways back. I suppose I should have been a bit more explicit and say to return it under warranty if that was possible the reference to ditching I agree sounds a bit too a blanket cover way of getting the thing changed.

There are also other signs that flag a problem for me I that the drive testing with Partition Wizard took so long and again I should have suggested something like a Seagate test or similar. So apart for my idea of a chkdsk on that drive I really have nothing more to add.
My System SpecsSystem Spec
23 Oct 2014   #26
Layback Bear

Windows 7 Pro. 64/SP-1

I ask back in post #5 for a clean shot of Disk Management.

Disk Management - Post a Screen Capture Image

All we get is a bunch of pictures covering pictures, covering pictures. It makes it very difficult to impossible to see the information needed.

Have a nice day.
My System SpecsSystem Spec
24 Oct 2014   #27

Windows 7 Home Premium x64

I suppose the confusion on this thread prevented us from understanding the issue better. The clean screenshots could've also been useful.
So @MrVenJhay, @jumanji and @PimpleMaze have given the most promissing troubleshooting. In the end, if nothing has worked, again, check on your manufacturer's website if your drive is still in warranty and RMA it.
I apologize for any confusion and hope you get back yourself a nicely working hard drive!

Best of luck!

My System SpecsSystem Spec
24 Oct 2014   #28

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Yes CK suppose that is why it is good there are more than one pair of eyes viewing a thread at any one time.
My System SpecsSystem Spec
24 Oct 2014   #29

Windows 7 Home Premium x64

Of course, Icit2lol! Also, I am happy to see all cooperative attitude here without any unnecessary rudeness or unprofessional behaviour!


My System SpecsSystem Spec

 External HDD Unallocated 2047.35gb other Sol'n?

Thread Tools

Similar help and support threads
Thread Forum
How to Fix external HDD bad disk, unallocated, not initialize
Hi. I have a WD 500gb external HDD. I can't access it anymore and I really don't know how to fix it. It won't show in My Computer but I can still see it Disk Management. The files are not important since I have a copy of it, I just really need to fix my external. Any help would be much appreciated....
Hardware & Devices
How do i fix unknown, not initialized and unallocated external hd?
Please help me fix this problem. any information you need just ask me i will tell you all you need. Thanks in advance
General Discussion
How do i fix unknown, not initialized and unallocated external hd?
Please help me to get my important data from my bad hard disk, I have a segate 500 GB usb external HDD, It was working fine since last 3 years. yesterday i connect this to a XP machine, and start coping some data. the coping speed was very slow, so I restarted the machine in between. After that...
Hardware & Devices
3TB external suddenly becomes 746GB unallocated
Evening, Seagate 3TB (ST3000DM001) in a Thermaltake BlacX (USB+E-Sata) docking station that had 5 partitions spread over the actual drive's capacity, now registers as 746.5GB unallocated. I connected the dock to a Win 7 desktop through E-Sata and copied files off of the external...
Hardware & Devices
Unallocated space on new 4TB external HDD, how can I name this volume?
see attached. I've just bought this new 4TB HDD (disk 2) to replace other 500GB (disk 3). After having viewed a few tutorials on YouTube I did "Shrink Volume" on the primary partition (when that's all there was) and created the 1.6GB space. When right clicking on the Unallocated space, all...
General Discussion
External drive was readable, now it is unallocated?
Hi all, The situation is fairly simple. This morning I : 1: Unmounted and unplugged my external drive which is a WD My Book Essential 2TB 2: Took it to a colleague and tried to connect it to his IMac4 which has OS X 3: Nothing worked, we could see the drive but couldn't access it even with...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App