Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: My Alfa AWUS036H USB Device Keeps Enabling and Disabling

30 Oct 2014   #1

Windows 7 Ultimate 64-Bit
My Alfa AWUS036H USB Device Keeps Enabling and Disabling

Hi all,

I finally broke down and decided to make an account as ask for some help. Really trying to get this working normally again.

As stated in the title when I plug in my USB wireless device to my Desktop Tower, the device appears in the task-bar and adapter screen to continuously enable and disable itself. It does not work or scan wireless networks. I was toying with VirtualBox trying to get Linux to recognize the device and such, and something happened along the way that seemed to corrupt this device in Windows. I've since restored my system to before VirtualBox was installed but that didn't fix the issue.

The facts:
  • This happens on any USB port
  • It's not the device, as it works fine on my other computers
  • It's not the USB ports, since my other wireless USB mini stick works on them
  • I've tried uninstalling the driver and deleting it and restarting - does not work
  • Interestingly, when I disable the WLAN AutoConfig service, the issue does not happen, it appears this begins to happen once the device is invoked for something - such as detecting wireless networks
  • While the issue is happening if I try to manually enable the adapter during this cycle, or if I right click the USB taskbar icon and try to disconnect it - I will get a BSOD

Any ideas? There seems to be something in Windows, some registry setting or something that's causing this behavior. Is there a way to make the system forget this device ever existed in every regard? Again, it works on my other Windows 7 machines just fine...

Let me know what more information I can provide. Really appreciate it.


My System SpecsSystem Spec
01 Nov 2014   #2

Windows 7 Ultimate 64-Bit

My System SpecsSystem Spec
17 Sep 2015   #3

Windows 7 Ultimate x64

Hi all,

Sorry if I bumped this thread, I'm facing the same issue

Tried many suggestions and still the same

@w4jiro: if you solved it, please how

or the issue from the motherboard?
My System SpecsSystem Spec

19 Sep 2015   #4
Ravi K

Windows 7 Professional

Adding to this, I have a 500GB and a 1 TB internal HDDs on my win 7 professional 32 bit desktop. When I attach a 1TB USB HDD to the machines, it keeps getting recognised and de-recognised. As one of the other members mentioned earlier, the external HDD works fine on other machines and USB slots are also working fine. Is there some addressing limitation in win 7?
My System SpecsSystem Spec
19 Sep 2015   #5
Ravi K

Windows 7 Professional

Sorry! posted this in a wireless issue instead of a HDD issue..will re-post correctly.
My System SpecsSystem Spec

 My Alfa AWUS036H USB Device Keeps Enabling and Disabling

Thread Tools

Similar help and support threads
Thread Forum
BSOD while enabling/disabling wireless device NETwNs64.sys
Hi guys, I am having some troubles trying to use my laptop wireless device, because every time I try to connect to my home connection it last no more than 10 minutes and after that it shows LIMITED ACCESS on my connection icon. Im not very good at computers so the only thing I can do is DISABLE...
BSOD Help and Support
Soldier requests some help with Alfa AWUS036H wireless adapter
I bought this adapter as a way to stay connected to family back home during this deployment but I am having some issues getting it to work. I installed step for step how the installation cd told me to and I even went online and downloaded the latest driver. I am using Window 7 x64 on this new HP...
Hardware & Devices
[HELP]Alfa awus036h Problems[HELP]
Hey guys Two days ago i got the alfa and i havnt simpily been able to get it to work, i've tried drivers from the alfa website, the realtek website and so on... strange part is that its not shown in device manager when plugged in and the lan utilitys that are installed from the drivers open then...
Alfa AWUS036H 1000mW
Does anyone have the problem with this device? Same REALTEK 8187L chip, i can install, the windows recognize it... but it doesnt detect any network. Tried with Vista, the device works perfectly...
Linksys and alfa awus036h with windows 7 64 bit
i have a usb alfa awus036h when i install the driver from for windows 7 windows 7 intall it and when i click on the wifi connection bottom right it say no connection, someone know the problem ? If i intall on windows 7 32bit i work perfectly. on windows 7 64 bit nothing work. ...
Network & Sharing
alfa awus036h (RTL8187L) win 7 64 bit driver.
hi... has any of you have had any luck finding RTL8187L driver for win 7 64 bit.. i have a ALFA AWUS036h wireless adapter that uses a (RTL8187L) chipset but it doesnt work for 64 bit.. it would only work on 32 bit win 7.. HELP PLEASE!!!!

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:40.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App