Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: you do not have sufficient rights to perform this operation

04 Dec 2014   #1

windows ultimate x64 bit
you do not have sufficient rights to perform this operation

I can't format my local drive

My System SpecsSystem Spec
04 Dec 2014   #2

Windows 10 Pro 64-bit

Is your user account an administrator?
My System SpecsSystem Spec
04 Dec 2014   #3

Windows 7 Professional 32 bit. & Linux Mint 17 32 bit


First of all, you need to be an administrator to perform such tasks.
Make sure that you are using an admin. account.
Then try it again.

The Local Drive usually contains the Operating system Files. You must not format it under any circumstances.

If you are and admin user Please recheck that you are not formatting the boot partition, else your computer will become unusable, until you reinstall the OS.

Hope i helped
My System SpecsSystem Spec


 you do not have sufficient rights to perform this operation

Thread Tools

Similar help and support threads
Thread Forum
CD drive "You do not have sufficient rights to perform this operation"
This is a new development. Windows 7, 64 bit laptop I put a music CD into my laptop's cd drive and windows Media player says "no CD". So I double clicked on the CD drive icon and was told "You do not have sufficient rights to perform this operation". *****the funny thing is that I think it seems...
Hardware & Devices
Error message "Could not perform this operation.....mail client"
When I click an email address on a website or if I click an email address on a spreadsheet, I get the following error message "Could not perform this operation because the mail client is not properly installed". Then, hundreds of blank internet explorer pages are opened. I researched online...
Browsers & Mail
Windows Resource Protection could not perform the requested operation
I also have some similar problem. My windows Help center has gone bad with multiple _elbasuer_ instances. But there is no BCRM_Bluetooth_Help strng in the registry. So an sfc scan could help, was my thought. But sfc /scannow stops at 9% with a message "Windows Resource Protection could not perform...
Performance & Maintenance
sfc /scannow stops at 69% ...could not perform the requested operation
Again, sorry if I posted this on the wrong section... Anyway, in the beggining of the year I got the infamous malware that infected many PC's worldwide (can't remember the name) and got my action center completely destroyed. I eventually fixed it, by adding the Security Center service that was...
Performance & Maintenance
XP Mode - Virtual PC - "User does not have sufficient access rights"
Can no longer run XPMode. Had it running fine for 5 months or so, then the other day I tried to start it and it the machine could no longer be found. I restored the vhd files from last month's back up but now every time I try to run it or edit the settings of the machine, I get the error message:...
Could not perform this operation because
I just purchased and installed Windows 7 Home Premium on my Toshiba 64 bit computor. It had Vista on it and did not like it from the get go but Circuit City installed it. The problem I am having is when I click on the mail icon on the toolbar I get the following message: could not perform this...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App