Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WD 320 GB that can't initialize

19 Dec 2014   #1

windows 8.1
WD 320 GB that can't initialize

I have a similar problem that can't solve.
I have a WD 320 GB that can't initialize.

It all started when I disconnected it without using the notifications icon on the right below (in windows 7). Immediately after that I tried to connect it to another computer, but couldn't open the drive, saying something like: "cyclic redundancy error" and asking if I want to format (which I denied).

After that I scanned it with chkdsk /b but interrupted because it was taking too long; also was saying that I don't have enough space to restore the clusters.(the disc is full with data that I don't mind erasing)

I also tried to open it in Linux live cd:

Again I tried chkdsk /f this time:

Later on I scanned it with HDD Regenerator, which warns me something about IDE compatibility:

I disregard the warn and start scanning; soon after that (about 30 mins) stops scanning without solving the issue, but creating more problems.

Now the system does not detect the volume anymore. I tried to initialize it with Disk Manager; it says that has a hardware problem:

I tried to scan it with mini tool Partition Wizard but goes too slow; barely scans 100.000 sectors in one hour (has 600.000.000 in total).

What I want to know is: can it be used anymore or should I buy another one? (data backup is not important for me since it only contained some virtual machines I use at school)
ps: the disk is spinning and the light is on

My System SpecsSystem Spec
19 Dec 2014   #2

Windows 7 Home Premium 32 bit

Please check your drive with Datalifeguard Diagnostics for Windows. WD Support / Downloads / Legacy Internal / WD RE2

Quick Test, Extended Test and also Write Zeros with Full Erase option. If it fails, that is it. It has failed.
My System SpecsSystem Spec
19 Dec 2014   #3

windows 8.1

quick test failed

thank you for the help !

I now know what to do
My System SpecsSystem Spec

19 Dec 2014   #4

Windows 7 Home Premium 32 bit

Did you try Write Zeros with Full Erase option? I will give up only if that too fails :).
My System SpecsSystem Spec

 WD 320 GB that can't initialize

Thread Tools

Similar help and support threads
Thread Forum
Can't initialize new HDD
I'm adding a 2TB disk and can't seem to get the expected results. In Disk Management, I have right-clicked on the new drive, but no option to initialize appears. I have never seen the Initialize Disk Wizard, as expected. The attached Computer Management screenshot shows the present situation. ...
Hardware & Devices
Cannot Initialize Harddrive
Hey, I boot into windows and my Raid0 disks are gone, Disk Management shows the disk as Unallocated. Unable to initialize the disk even, just gives an error "Windows cannot find the file specified" the first time after i launch windows, after that it greys out and im unable to use that option. ...
Hardware & Devices
can't initialize to MBR!
I just managed to install a second HDD, and my OS sees it. However, Partition Wizard does not let me initialize to MBR. When I go to "Disc" on the top bar, everything in the drop down menu is grayed out. It is NTFS formatted, made Primary, Status is "none". I want to prepare it to install...
Hardware & Devices
Cannot Initialize HDD
Hey there, I'm having trouble getting my new Seagate Barracuda 1.5TB HDD to initialize. It Shows up under devices, and I'm able to see it's properties etc... When I locate it with the device manager, and right click it, I'm only given the options to Uninstall, Update the Drives, Disable, Scan...
Hardware & Devices
XP Can't Initialize
I installed everything ok. I have an e8300 which is listed in the supported CPU's list. When I go to run it for the first time, I get this error It then proceeds with the setup until it reaches the end and gives me the "can't initialize" error, or...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:37.
Twitter Facebook Google+