Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No power to USB after failed hardware install

29 Dec 2014   #1

Windows 7 Ultimate x64
No power to USB after failed hardware install

Hello all.
I am desperate for help!
I have a Toshiba A300 laptop running Windows 7 Ult x64
I attempted to install a Logitech camera & webcam, Windows failed to install the drivers.
After that, I lost all power to my left and right USBs.
I tried System Restore, changing the Power Settings (keeping USBs on) but nothing worked.
After running a third-party USB disabler/enabler, I was able to enable the left USB port, but still have no power to both right ports.
I am at a loss of how to diagnose and fix this issue.
I am 99% sure that this is not a hardware issue, but rather a Windows 7 safeguard against the botched driver install for the Logitech installation.
I don't know enough about advanced tweaking to diagnose this issue.
If anyone could help, it would be my Christmas miracle!

My System SpecsSystem Spec
29 Dec 2014   #2
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Your computer is quite old and cam with Vista Business and DDR II ram the best I can tell.

If this is not correct please give me more information that I can work with.

From where and how did you get Windows 7 Ultimate/64 and is it activated with SP-1 installed?
My System SpecsSystem Spec
29 Dec 2014   #3

Windows 7 Ultimate x64

Yes this laptop is older.
It came with Vista and XP Roll Back.
I upgraded the ram when I bought Windows 7 from my school.
Yes it is activated with SP1 and is current with all MS Updates.
My System SpecsSystem Spec

29 Dec 2014   #4
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

This is going to be a tough one.
If it was my computer I would remove all Logitech drivers just installed for your camera and webcam.

I would also remove what ever this is. ( third-party USB disabler/enabler).
Try to get the computer back to the way it was before all this mess started.
Then check if the usb ports work as they should. Their is a chance your older motherboard is not able to handle what is need for your camera and webcam to work properly.

Then check if what ever camera and webcam you are using is compatible with Windows 7/64.

I will go back to the ranch and see if I can find someone with knowledge with old laptops and cameras.

Could you let us know what kind of camera/webcam you are trying to get to work.
My System SpecsSystem Spec
29 Dec 2014   #5

Windows 7 Ultimate x64

Thanks for the quick reply "Layback Bear".
I have sad news for myself because I believe that I just confirmed the worst scenario.
It appears as though I was wrong about the 99% being a software issue, and it looks more likely that I fell into that horrid 1% hardware failure.
I just booted the laptop from a USB I created running Puppy Linux, and I was unable to locate any of the right-side USB ports.
Apparently the camera (a Logitech ClickSmart 310) which appears to be defective may have blown out the USB controller related to the right-side ports.
Since Puppy Linux is completely independent from Windows, I can only assume that this new discovery is accurate - unfortunately!
My System SpecsSystem Spec
29 Dec 2014   #6
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

I think you are correct.
Hang in their and let some other members read your thread. They might have some suggestions.

Any thing plugged into a powered usb port that has a short can cause the problem you described.
My System SpecsSystem Spec
29 Dec 2014   #7

Windows 7 Ultimate x64

I just installed a neat piece of diagnostic software called "usbdeview-x64" from NirSoft.
I have now confirmed that the USB devices are reading Port 1: 500 mA, Ports 2 and 3: 0 mA.
Looks pretty clear that I will be hunting for a Toshiba repair shop.
...just hope it doesn't cost more than replacing the laptop!
Thanks again "Layback Bear" for your help.

I just wish this laptop had a surge protector built into it!
My System SpecsSystem Spec
29 Dec 2014   #8

Windows 10 Pro/ Windows 10 Pro Insider

If your problem is hardware, there is little we can do here, but before I paid money for a fix, I would make sure that it is not a driver problem. I find it difficult to believe that a Logitech program could damage a USB port. I have a couple of suggestions. First, click start and then type Device manager in the search box. then post a screenshot of Device manager with USB ports expanded. It will probably take 2 or 3 screenshots, but that's OK. Here is how to post screenshots, Screenshots and Files - Upload and Post in Seven Forums. It is pretty easy. Lets see what it shows.

Then you can run through this and see if anything helps USB Driver - General Fix for Problems

I would imagine it is in the tutorial, but find the port you are having problems with in Device Manager, right click it and select uninstall. Once it is uninstalled, reboot the computer, that will force Windows to reinstall it, because it will 'detect new hardware'.

When you installed Windows 7 did you find Chipset drivers for Windows 7? That is another option to reinstall the chipset drivers. That is where the USB drivers usually come from. But work through the tutorial first and see if it helps any.
My System SpecsSystem Spec
29 Dec 2014   #9

Windows 7 Ultimate x64

Hi "essenbe"
Thanks for the heads up! I read through the material you provided - very informative!!!!!
Unfortunately because I also booted from an independent OS (Puppy Linux) from a USB key (on the left port)
it pretty much confirmed that the right ports are dead.
I would love to be wrong on this, but evidence appears to be hardware.
...and there's no software that can fix that.

P.S. I bookmarked your url link. Thanks again!
My System SpecsSystem Spec
29 Dec 2014   #10
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

I'm not sure a driver can cause a (0) ma so I'm going to be watching and hopefully I can learn something.

I would recommend trying essenbe suggestions. Who knows we all might learn something. essenbe is one of the sharper knives in the kitchen. If it was my computer I would try his suggestions.

Taking a old laptop to a shop for that kink of repair will normally cost more than a new laptop.
My System SpecsSystem Spec

 No power to USB after failed hardware install

Thread Tools

Similar help and support threads
Thread Forum
HAL.DLL BSOD Need to diagnose failed hardware
I've recently started to get BSOD not long after startup, with the computer throwing a 0x00000124. I've been in and out of town over the last few weeks and I first noticed the issue after coming back for a day and booting up my PC only to have it BSOD while watching a YouTube video. After crashing...
BSOD Help and Support
random Kernel-Power errors persist on clean install/new hardware
I had a system that was blue screening and having sporadic critical Kernel-Power errors. I have since replaced the power supply, motherboard, CPU, graphics card and RAM. the only parts that remained were the ODD and HDD.. I am still getting Kernel-Power errors ("information" and "error" level only...
Hardware & Devices
DirectX hardware aceleration failed
Hello, have recently reinstalled windows 7 x64 and i guess that my directx got some problems. unable to start any game now. every time trying to lunch game, program gives different errors. now trying to start world of tanks and it saying: "Application has failed to start because DirectX...
Hardware Power Consumption-Picking a new Power Supply
Ok, so it's time again for me to pick a new power supply, however, I'm in need of some help determining the appropriate wattage for my hardware setup. AMD Phenom II X4 955 45nm AM3 GSkill Ripjaw X 16.0 GB Dual-Channel DDR3 @ 668MHz (9-9-9-24) Corsair TX750w (I dont think its the V2) ASUS...
Hardware & Devices
Windows setup failed to configure on your hardware??!!
I am typing on my phone so hopefully you know my situation just by that! I had just replaced my hard drive from my sony vpccw29gx. It was corrupt. I bought a different brand hard druve, but same rpm. I ordered the recovery disks from sony. I installed the disks, but after the windows 7...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:16.
Twitter Facebook Google+