Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Error in installing a printer 0x000006f7

10 Jan 2015   #21

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Lost a post - here's the short version

Open Device manager, expand non Plug and Play
uninstall the following two HP drivers
Net Driver HPZ12
Pml Driver HPZ12

I'll be back - more to read / confirm.

My System SpecsSystem Spec
10 Jan 2015   #22

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Quote   Quote: Originally Posted by Dan Boy View Post
Hi Guys, thanks for the replies. Sadly my printer is a Laserjet 5000n. I have tried their universal drivers but No joy, am I missing something? How come the stock Microsoft driver won't work anymore?

What do I search for for the fix file?

Cheers Dan.
Stock MS driver? I don't know of any for printers - graphics and Ethernet adapters yes. I'm not aware of any stock printer drivers from MS.

This printer used to work, I assume.

After reviewing your thread, I wonder if I read the issue wrong. I was chasing an install issue, perhaps this is a network issue. When you tried the HP UPD, I noted that the documentation said it would only work with a direct connect (IP) - so now I'm looking at the issue from a different angle.

When (if) the printer used to work, was it Ethernet connected. Then the printer stopped working and you tried to re-install it - that's when you got the error in post# 1?

If that was the scenario, then I'll have to look at the network side. If that isn't the scenario then we can try a few tricks to get the install to at least recognize the printer.

My System SpecsSystem Spec
11 Jan 2015   #23
Dan Boy

Windows 7 Home Premium 32 bit

Bill, its fixed!!!

A mate came round to take a look and it turned out that it was a permissions problem with the W32X86 folder.

As a user I did not have permissions to view the contents of this.

Many thanks for all the time and effort for the people who got involved with this.

Thanks, Dan.
My System SpecsSystem Spec

11 Jan 2015   #24

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

No problem, thanks for posting your solution. I never would have thought of going down that path.

My System SpecsSystem Spec

 Error in installing a printer 0x000006f7

Thread Tools

Similar help and support threads
Thread Forum
Installing a Brother printer, error 0x00000704
Hello, I spoke with the technical support of Brother and he told me that (error 0x00000704) was a mistake of window registe. Can you help me fix this error? Thank you, Gabriel
Hardware & Devices
I'm installing TCP/IP Printer... no communication but error printing..
I am attempting to add a TCP/IP printer to a desktop. I used the set of instructions using, add a printer, create a port, TCP/IP, enter in the IP address of the printer, and the system never finds the printer. It just says, 'device is not found on the network'. Is there another step? My...
Hardware & Devices
Error installing acrobat printer
Hi, i've installed the Acrobat printer without problems in Windows Xp but i keep getting this error when installing it in windows 7 sp1 64. I install it from Start- devices & printes- add printer -> add local printer-> create a new port-> local port-> give name->...
Error message when installing wireless printer
I am trying to install my printer to my wireless network, but I keep getting an error message that I am not the administrator on this computer. This is my personal computer, so don't know why I would not be the administrator. I did set up a homegroup and add my printer and all my documents, but...
Hardware & Devices
Getting permission error when installing HP C310 Printer
When I attempt to install the software for my new HP C310 printer I get "fatal errors" due to permissions in the new folders. I heave used the "built-in-admin" tutorial that Brink wrote. I have taken ownership of the folders in Program Files and Progam Data. This is where the error occurs. I...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:07.
Twitter Facebook Google+