Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: samsung mobile mtp device failed to load driver

07 Jan 2015   #1

Windows 7 32bit
samsung mobile mtp device failed to load driver

I have recently bought Samsung galaxy S5 device. When I tried to connect it to my computer I nothing happend (what should have happen is that it will pop up the "What do you want to do? Go to folder/..." menu).
So I tried another usb socket. still the same problem. I have Ubunto install as a sperate OS on my computer, and there everything is working fine - so the problem is not in the cable/USB on my computer.

I went to Device manager and under "Portable devices" I see the "SAMSUNG Mobile MTP Device" icon with a yellow mark. I open it and I see "this device is not working properly because windows cannot load the drivers required for this device. (code 31)". I also have "SAMSUNG Mobile USB Modem" under modem in device manager (but it says that this device is working properly).
I tried to remove the "SAMSUNG Mobile MTP Device" and double click it and choose "update driver"->"search online". It found the driver but was unable to install it (got a "access deined" screen).

**This is not a problem of registry "UpperFilter"/"LowerFilter" problem. I saw it online while I was google a soultion and this is not my case***

I also tried to install the driver by installing "samsung KIES". It didn't help.

When I connect the decive and go to Windows Update -> a new update for samsung mobile is showing but when I choose it and click update it fails everytime.

I run antivirus and this is not a case.

I am pretty lost. I know that if I will format my computer and install Windos 7 it will solve the problem but I don't want to do this drastic step.

Can someone please help me?


My System SpecsSystem Spec
07 Jan 2015   #2

Windows 7 Professional (64-Bit)

I don't know the answer to this, but I see you've had many views and no replies.
I'm sure that you've googled this and it isn't to patronize you, but here are a couple things I've found that MAY help.

Possible Solution 1:
"Access Denied" Message During USB Device Installation - National Instruments

Possible Solution 2:
When installing the driver(s),
Even though you allowed admin in your user profle and allowed it to run in admin, this does not give you full control for all users. Do the following below. Then, Logoff, login with the new admin owner. Only the owner of this pc has full user rights.
Its worth a shot

How to enable the hiding admin account for login
1- In the run type: secpol.msc
2- Find and click on, Local Policies,security options,
3- Over to the Right in the policy setting, (accounts: Administrators account status) Enable
Close tht and got to
1- Run, lusrmgr.msc
2- Create a new user, or use Administrater, Built-in account for administering.
3- Right click, Properties
4- Uncheck, Account is disabled
If you chose you can change the name and add a password, now when you log off you can have the options to log in as admin, owner of this pc and have controll over all users. its better to have th admin login the the below

Or this but sometimes this method has failed and sometimes not

net user administrator /active:yes ,you have admin until reboot, or you go no.
My System SpecsSystem Spec
07 Jan 2015   #3

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

I have a Galaxy S4 and have no problem connecting it through USB cable and getting to it as an MTP device.

When it connects, it might initially notify as "connected as installer" which is the wrong type of USB connection. So I just pull down the notify bar, tap on the top item which is the "USB connected as..." item, and then check the "media device (MTP)" box. It will now re-connect itself as an MTP device and you can use Windows Explorer to get to both internal and external storage. Remember MTP connections don't have drive letters so you must use Windows Explorer or similar "sophisticated" software which can deal with MTP connections, in order to manually access the storage/card of the phone and copy to/from your PC.

Note that the MTP connection for the phone will also put an item in the "safely remove hardware" icon in the System Tray. So you need to "eject ..." the phone before you pull the USB cable out of the PC, when you're finished with your maintenance whatever you've done.

I do NOT use any Kies software, although I did install it when I first bought the phone from Sprint. Since then I've replaced it with an S4 from Verizon, but it's the same phone. There may have been drivers installed through that Kies software originally, but I do not use it.

To be honest, I cannot recall if my currently installed USB driver for the phone came from Kies (which I installed but don't use), or PDANet+ (which I bought for its USB tethering feature, and which also provides a USB driver), or from another source. It's been a while now.

I'm sure the S5 is very similar. You should try downloading the Samsung USB drivers from this page. Specify your Galaxy S5 in the search box, and then pick your model. Download and run it. I just did this for my S4 and the version retrieved seems back-level,

If that doesn't work, you can also try downloading the Samsung USB drivers for S5 from this page instead. Note that the driver from this source is apparently version, and the notes say last updated in December 2014. So this seems probably what you want.

My S4 is currently connected via USB and shows up in Device Manager as "Samsung Android Phone", sub-title "Samsung Android ADB Interface". The drivers are from Samsung, dated 1/2/2014 and are version The drivers for the S5 may be different. The relatively recent date of the S4 driver seems newer than any of my installer files, so perhaps this is from an automatic Windows Update. Don't know where I got dated 1/2/2014.
My System SpecsSystem Spec

07 Jan 2015   #4

Windows 7 Professional (64-Bit)

Disregard my comment and listen to dsperber, I don't own a Samsung device. I'm an iPhone guy, I was just trying to throw something out there that might help you.
My System SpecsSystem Spec
07 Jan 2015   #5

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Just double-checked the drivers for my S4 using my laptop. It showed the driver coming from June Fabrics (which is the PDANet+ vendor) dated 2009, rather than from Samsung with the 2014 date as my desktop machine showed. Also, the Hardware ID for the phone was minimalist.

I then did an "update driver software...", specifying to do an automatic search on the web. It came back saying I already had the latest drivers installed.

However a Windows Update icon appeared in the System Tray, and there were several items for Android and MTP and the phone. So I went ahead and installed all of it.

And now, sure enough, the driver on the laptop is now the identical dated 1/2/2014 and coming from Samsung, same as is on my desktop machine. Also, the Hardware ID for the phone had changed substantially, with about 6 more detail lines now appearing. So clearly that's where this driver comes from... Windows Update via Samsung. Perhaps this is related to Android OS updates, or Samsung firmware updates for the phone, or both, but it does seem gets things current and acceptable to Win7.

So I don't know how this squares with the latest driver from that AndroidXDA site. All rather confusing, but it does seem from MS Windows Update is what my Win7 environment believes is appropriate. And I do have complete MTP control over the phone and its internal/card storage contents through Windows Explorer.
My System SpecsSystem Spec
30 Jan 2015   #6

windows 7 home premium 64 and others

Have same issue with galaxy s4. Have been plugging into my windows pc's 7 and 8.1 for over a year no problem.
Problem just cropped up, even after loading latest samsung USB per your suggestion.
Symptom is it goes through windows update anyway, installs yet another usb driver, then tries and fails to load MTP driver.

Multiple instances of this failure are in google, but since this worked a month or two back, whatver broke was in last 30 to 60 days.

re installing MTP in various ways and other suggested MTP fixes all have no effect.

Device manager shows
"Portable devices" has sub device "MTP USB Device" with yellow error symbol on it.
Re installing driver for that (MTP USB device) always fails.
My System SpecsSystem Spec
30 Jan 2015   #7

windows 7 home premium 64 and others

at least one supposed fix is a virus. Mtp usb device driver failed windows 7 brought up
my AVG virus shield.
So anyone running ANYTHING to try and fix the MTP issue should run it through virus scan first!
Its being targeted.
My System SpecsSystem Spec
01 May 2015   #8

MS Windows 7 Ultimate 64-bit SP1
Samsung Galaxy S4

I went through all the post here and tried many different ways to fix the same problem.

It did fine until about 2-3 weeks ago and it quit.

I just upgraded to Samsung it still failed I ran the windows update search checked in Device Manager Portable device it shows date 5/11/2012 and driver version 2.9.319.511 and it also added Samsung modems driver date 6/10/2014 and driver ver. I dont have one I scanned anti-malwarebytes everything is clean.

my phone reads connected as media device(MTP) tried swapping to camera(PTP) and back to (MTP) and still fails everything fails.

Please help I'm confused
My System SpecsSystem Spec
02 May 2015   #9

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

As I stated earlier, MTP is certainly the way to configure the USB connection on the phone.

Here's my Verizon S4 connected to one of my PC's:

You can see that the drivers on this particular PC are from Samsung, which are older than yours.
My System SpecsSystem Spec
03 May 2015   #10

MS Windows 7 Ultimate 64-bit SP1

wow before you replied I tried
USB Driver - General Fix for Problems

now I cant even get any read that its there it doesn't show in Device Manager

Attached Thumbnails
samsung mobile mtp device failed to load driver-device-manager.jpg  
My System SpecsSystem Spec

 samsung mobile mtp device failed to load driver

Thread Tools

Similar help and support threads
Thread Forum
The driver \Driver\WUDFRd failed to load for the device... error
Hi, Since the 11/18/2012 event viewer (Event ID 219, Task Category 212) has been posting a warning: The driver \Driver\WUDFRd failed to load for the device WpdBusEnumRoot\UMB\2&37c186b&0&STORAGE#VOLUME#_??_USBSTOR#DISK&VEN (followed by name of USB device) It only occurs on start up if I...
Out of ideas - The driver \Driver\kbdhid failed to load for the device
This has been a problem for over a year now. 140+ identical PCs running identical images, with identical keyboards. Some have the problem, some do not, and it's incredibly unpredictable. PCs are HP Compaq Elite 8300 SFF running Windows 7 x64 Professional. People will be working at their PC,...
Hardware & Devices
The driver \Driver\atrfiltr failed to load for the device...
I have this computer what for some reasons wont install USB Smartcard readers. Its Win7 64. I have tried different smartcards but they wont help, also i tried to install drives manually but still wont work. I uninstalled and installed drivers many times. Also i tried, but didnt work: Change...
The driver \Driver\WUDFRd failed to load for the device error
Hi i have a couple of weeks ago installed windows and i just got bsod crash and this was the only error in the event viewer The driver \Driver\WUDFRd failed to load for the device WpdBusEnumRoot\UMB\2&37c186b&0&STORAGE#VOLUME#_??_USBSTOR#DISK&VEN_GENERIC&PROD_USB_CF_READER&REV_1. ...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:33.
Twitter Facebook