Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Usb ports not working when used with any network dongle. Port issue?

10 Jan 2015   #1

64 ultimate service pack 1
Usb ports not working when used with any network dongle. Port issue?

I had some minor problems with my usb soundcard so I did a clean installation of win7.
Now it's gotten way worse.
All usb ports are working when plugging in my wireless keyboard/mouse. My usb stick 4gb works aswell.
All ports are fully functional according to the device manager. I have installed all chipset drivers etc .

Now here comes the strange part:
When plugging in my usb mobile broadband modem it installs correctly from the plug n play and says it's ok. But when I try to access it I get "windows can't access this disc". The modem works fine on my laptop so I know it's good.

Ok so I try to share my iphone via the USB like I've done so many times before. It installs correctly and I can access my files on my iphone but it doesn't show up at all as a network adapter. Turning on the wireless function instead I can surf the web through my iphone...

What is this? My usb ports are working but not when it has anything to do with internet connections.
Both Iphone sharing via USB and the USB broadband dongle shows the same problem.
Is there a setting in the BIOS that has changed?
I tried resetting my BIOS but the problem persists.

The 3g dongle shows up on "devices and printers" and checking properties -> harwardware all devices are "working properly"
But NOT on Network Adapters as it did before I reinstalled Win7

In device manager the dongle shows up on
DVD/CD-ROM drives as HUAWEI Mass Storage USB Device
In the Universal Serial Bus Controller:
HUAWEI Mobile Connect - Bus Enumerate Device

In safe-mode I can see two disks coming form the dongle in "Computer" - "Devices"
one "Removable disk" and one "DVD/CD-Rom drive"

What can I try next?
Everything else is working fine and other usb devices work properly.

Attached Thumbnails
Usb ports not working when used with any network dongle. Port issue?-modem.jpg  
My System SpecsSystem Spec
10 Jan 2015   #2

64 ultimate service pack 1

Think I should add also that when I try to update the dongle it says Port not found. Error 10.
Well it's clear that it is found as I can see it in devices. I plugged in my soundcard in the same port and had no problem installing it. So it's like my USB ports don't want to connect to the internet
My System SpecsSystem Spec

 Usb ports not working when used with any network dongle. Port issue?

Thread Tools

Similar help and support threads
Thread Forum
Laptop Network Port not working
Dear All, Please help me to judge this issue. I have problem with my laptop network port. When i plug Network cable from Modem to my Laptop Network port, i always get No internet connection and when i tried other laptop and the problem still persist.. At first time i thought maybe problem...
Network & Sharing
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
Opening Firewall Ports (Selected By Their Port Number)
Hello, Trying to use a program that communicates with, and controls, a radio via a 232 cable. Apparently there are a number of Ports that must be open for it to work. I have looked at all the Firewall screens, and the Advanced Firewall screens, their Rules etc., but cannot find any place...
Network & Sharing
Network Printer : firewall issue, which port open ?
Hello, I just bought a Samsung network multifunction printer CLX-6210FX. I am encountering trouble wiht the built-in Windows 7 firewall. Despite the TCP port 9100 is open both for entry and exit in the firewall, no file will print untill I shut down totally the firewall. Which port should I...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:52.
Twitter Facebook Google+